Update to NSS_3_13_5_RTM

- Resolves: Bug 812423 - nss_Init leaks memory, fix from RHEL 6.3
- Resolves: Bug 830410 - Missing Requires %%{?_isa}
- Use Requires: %%{name}%%{?_isa} = %%{version}-%%{release} on tools
- Fix rpmlint reported error E: explicit-lib-dependency zlib
- Enable sha224 portion of powerup selftest when running test suites
- Require nspr 4.9.1
- Selective merge from master
This commit is contained in:
Elio Maldonado 2012-07-12 10:53:34 -07:00
parent 971f5d4461
commit b8e66b58b6
5 changed files with 51 additions and 12 deletions

2
.gitignore vendored
View File

@ -4,5 +4,5 @@ blank-secmod.db
blank-cert9.db
blank-key4.db
PayPalEE.cert
/nss-3.13.4-stripped.tar.bz2
/nss-3.13.5-stripped.tar.bz2
/nss-pem-20120402.tar.bz2

View File

@ -0,0 +1,27 @@
From ea14b3279da63a344dcaf3466592c2619025ac28 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Mon, 9 Jan 2012 14:10:07 +0100
Subject: [PATCH] nss - rhbz #772628 (fix a memory leak in nssinit.c) V2
---
mozilla/security/nss/lib/nss/nssinit.c | 4 ++++
1 files changed, 4 insertions(+), 0 deletions(-)
diff --git a/mozilla/security/nss/lib/nss/nssinit.c b/mozilla/security/nss/lib/nss/nssinit.c
index f1c0327..9fbbab7 100644
--- a/mozilla/security/nss/lib/nss/nssinit.c
+++ b/mozilla/security/nss/lib/nss/nssinit.c
@@ -754,6 +754,10 @@ nss_Init(const char *configdir, const char *certPrefix, const char *keyPrefix,
PZ_NotifyAllCondVar(nssInitCondition);
PZ_Unlock(nssInitLock);
+ if (initContextPtr && configStrings) {
+ PR_smprintf_free(configStrings);
+ }
+
return SECSuccess;
loser:
--
1.7.1

View File

@ -7,5 +7,5 @@ Name: NSS
Description: Network Security Services
Version: %NSS_VERSION%
Requires: nspr >= %NSPR_VERSION%, nss-util >= %NSSUTIL_VERSION%
Libs: -lssl3 -lsmime3 -lnss3
Libs: -L${libdir} -lssl3 -lsmime3 -lnss3
Cflags: -I${includedir}

View File

@ -1,13 +1,13 @@
%global nspr_version 4.9
%global nss_util_version 3.13.4
%global nspr_version 4.9.1
%global nss_util_version 3.13.5
%global nss_softokn_fips_version 3.12.9
%global nss_softokn_version 3.13.4
%global nss_softokn_version 3.13.5
%global unsupported_tools_directory %{_libdir}/nss/unsupported-tools
Summary: Network Security Services
Name: nss
Version: 3.13.4
Release: 2%{?dist}
Version: 3.13.5
Release: 1%{?dist}
License: MPLv1.1 or GPLv2+ or LGPLv2+
URL: http://www.mozilla.org/projects/security/pki/nss/
Group: System Environment/Libraries
@ -76,6 +76,8 @@ Patch32: Bug-800674-Unable-to-contact-LDAP-Server-during-winsync.patch
# upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=734492
Patch33: Bug-800682-Qpid-AMQP-daemon-fails-to-load-after-nss-update.patch
# upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=745224
Patch34: Bug-772628-nss_Init-leaks-memory.patch
%description
Network Security Services (NSS) is a set of libraries designed to
@ -87,8 +89,7 @@ v3 certificates, and other security standards.
%package tools
Summary: Tools for the Network Security Services
Group: System Environment/Base
Requires: nss = %{version}-%{release}
Requires: zlib
Requires: %{name}%{?_isa} = %{version}-%{release}
%description tools
Network Security Services (NSS) is a set of libraries designed to
@ -161,6 +162,7 @@ low level services.
%patch30 -p0 -b .784672
%patch32 -p0 -b .800674
%patch33 -p0 -b .800682
%patch34 -p1 -b .772628
%build
@ -195,8 +197,6 @@ export NSPR_LIB_DIR
export FREEBL_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nss-softokn | sed 's/-I//'`
export FREEBL_LIB_DIR=%{_libdir}
export USE_SYSTEM_FREEBL=1
# prevents running the sha224 portion of the powerup selftest when testing
export NO_SHA224_AVAILABLE=1
NSS_USE_SYSTEM_SQLITE=1
export NSS_USE_SYSTEM_SQLITE
@ -575,6 +575,18 @@ rm -rf $RPM_BUILD_ROOT/%{_includedir}/nss3/nsslowhash.h
%changelog
* Thu Jul 12 2012 Elio Maldonado <emaldona@redhat.com> - 3.13.4-3
- Update to NSS_3_13_5_RTM
- Resolves: Bug 830410 - Missing Requires %%{?_isa}
- Use Requires: %%{name}%%{?_isa} = %%{version}-%%{release} on tools
- Drop zlib requires which rpmlint reports as error E: explicit-lib-dependency zlib
- Enable sha224 portion of powerup selftest when running test suites
- Require nspr 4.9.1
- Selective merge from master
* Fri Apr 13 2012 Elio Maldonado <emaldona@redhat.com> - 3.13.4-3
- Resolves: Bug 812423 - nss_Init leaks memory, fix from RHEL 6.3
* Sun Apr 08 2012 Elio Maldonado <emaldona@redhat.com> - 3.13.4-2
- Resolves: Bug 805723 - Library needs partial RELRO support added
- Patch coreconf/Linux.mk as done on RHEL 6.2

View File

@ -5,4 +5,4 @@ a5ae49867124ac75f029a9a33af31bad blank-cert8.db
2ec9e0606ba40fe65196545564b7cc2a blank-key4.db
bf47cecad861efa77d1488ad4a73cb5b PayPalEE.cert
d19159b7f91b94afaf7fa78bba006c13 nss-pem-20120402.tar.bz2
74bbd7b520179c2e226a021fba8ff365 nss-3.13.4-stripped.tar.bz2
658daa72d8a79589ba9e3712591939e9 nss-3.13.5-stripped.tar.bz2