Fix bougus date

This commit is contained in:
Elio Maldonado 2016-06-09 15:37:10 -07:00
parent 47ddb0da82
commit 937aef60d8
2 changed files with 35 additions and 2 deletions

View File

@ -0,0 +1,26 @@
--- ./lib/ssl/Makefile.allow_keylogfile 2016-06-08 21:54:29.504328764 -0700
+++ ./lib/ssl/Makefile 2016-06-08 22:03:57.061313047 -0700
@@ -34,19 +34,20 @@
else
ifeq ($(OS_TARGET),OS2)
CSRCS += os2_err.c
else
CSRCS += unix_err.c
endif
endif
-# Enable key logging by default in debug builds, but not opt builds.
-# Logging still needs to be enabled at runtime through env vars.
-NSS_ALLOW_SSLKEYLOGFILE ?= $(if $(BUILD_OPT),0,1)
+# For Fedora stable branch compatibility, i.e f23 and f22
+# Enable key logging by default in debug builds and opt builds.
+# Logging doesn't need to be enabled at runtime through env vars.
+NSS_ALLOW_SSLKEYLOGFILE = 1
ifeq (1,$(NSS_ALLOW_SSLKEYLOGFILE))
DEFINES += -DNSS_ALLOW_SSLKEYLOGFILE=1
endif
#######################################################################
# (5) Execute "global" rules. (OPTIONAL) #
#######################################################################

View File

@ -21,7 +21,7 @@ Name: nss
Version: 3.24.0
# for Rawhide, please always use release >= 2
# for Fedora release branches, please use release < 2 (1.0, 1.1, ...)
Release: 1.1%{?dist}
Release: 1.2%{?dist}
License: MPLv2.0
URL: http://www.mozilla.org/projects/security/pki/nss/
Group: System Environment/Libraries
@ -98,6 +98,8 @@ Patch60: nss-pem-unitialized-vars.path
Patch61: nss-skip-util-gtest.patch
# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1277569
Patch62: mozbz1277569backport.patch
# Local: for stable branch compatibility
Patch63: nss-allow-keylogfile-in-opt-builds.patch
%description
Network Security Services (NSS) is a set of libraries designed to
@ -186,6 +188,7 @@ pushd nss
%patch60 -p1 -b .unitialized_vars
%patch61 -p0 -b .skip_util_gtest
%patch62 -p1 -b .compatibility
%patch63 -p1 -b .allow_keylogfile
popd
#########################################################
@ -795,12 +798,16 @@ fi
%changelog
* Thu Jun 09 2016 Elio Maldonado <emaldona@redhat.com> - 3.24.0-1.2
- Restore optimized build support for logging SSL/TLS key material to logfile
- Resolves: Bug - 1343289 - Update to nss 3.24 removes sslkeylogfile support
* Thu Jun 02 2016 Elio Maldonado <emaldona@redhat.com> - 3.24.0-1.1
- Allow application requests to disable SSL v2 to succeed
- Resolves: Bug 1342158 - nss-3.24 does no longer support ssl V2, installation of IPA fails because nss init fails
- Update nss_tests with some of the new gtests from upstream
* Fri May 28 2016 Elio Maldonado <emaldona@redhat.com> - 3.24.0-1.0
* Sat May 28 2016 Elio Maldonado <emaldona@redhat.com> - 3.24.0-1.0
- Rebase to NSS 3.24.0
* Thu Mar 10 2016 Elio Maldonado <emaldona@redhat.com> - 3.23.0-1.1