Merge branch 'master' into f15
This commit is contained in:
commit
8b5f3e43f0
34
nss-646045.patch
Normal file
34
nss-646045.patch
Normal file
@ -0,0 +1,34 @@
|
||||
diff -up ./mozilla/security/nss/tests/dbtests/dbtests.sh.noroot ./mozilla/security/nss/tests/dbtests/dbtests.sh
|
||||
--- ./mozilla/security/nss/tests/dbtests/dbtests.sh.noroot 2011-04-06 09:56:07.207701000 -0700
|
||||
+++ ./mozilla/security/nss/tests/dbtests/dbtests.sh 2011-04-06 10:19:54.159552000 -0700
|
||||
@@ -201,6 +201,9 @@ dbtest_main()
|
||||
cat $RONLY_DIR/* > /dev/null
|
||||
fi
|
||||
|
||||
+ # skipping the next two tests when user is root,
|
||||
+ # otherwise they would fail due to rooty powers
|
||||
+ if [[ $EUID -ne 0 ]] then
|
||||
${BINDIR}/dbtest -d $RONLY_DIR
|
||||
ret=$?
|
||||
if [ $ret -ne 46 ]; then
|
||||
@@ -208,6 +211,10 @@ dbtest_main()
|
||||
else
|
||||
html_passed "Dbtest r/w didn't work in an readonly dir $ret"
|
||||
fi
|
||||
+ else
|
||||
+ html_passed "Skipping Dbtest r/w in a readonly dir because user is root"
|
||||
+ fi
|
||||
+ if [[ $EUID -ne 0 ]] then
|
||||
${BINDIR}/certutil -D -n "TestUser" -d .
|
||||
ret=$?
|
||||
if [ $ret -ne 255 ]; then
|
||||
@@ -215,6 +222,9 @@ dbtest_main()
|
||||
else
|
||||
html_passed "Certutil didn't work in an readonly dir $ret"
|
||||
fi
|
||||
+ else
|
||||
+ html_passed "Skipping Certutil delete cert in an readonly directory test because user is root"
|
||||
+ fi
|
||||
|
||||
Echo "test opening the database ronly in a readonly directory"
|
||||
|
29
nss.spec
29
nss.spec
@ -6,7 +6,7 @@
|
||||
Summary: Network Security Services
|
||||
Name: nss
|
||||
Version: 3.12.10
|
||||
Release: 3%{?dist}
|
||||
Release: 5%{?dist}
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
URL: http://www.mozilla.org/projects/security/pki/nss/
|
||||
Group: System Environment/Libraries
|
||||
@ -45,6 +45,7 @@ Patch7: nsspem-642433.patch
|
||||
Patch8: 0001-Bug-695011-PEM-logging.patch
|
||||
Patch16: nss-539183.patch
|
||||
Patch17: nss-703658.patch
|
||||
Patch18: nss-646045.patch
|
||||
|
||||
%description
|
||||
Network Security Services (NSS) is a set of libraries designed to
|
||||
@ -87,6 +88,7 @@ any system or user configured modules.
|
||||
%package devel
|
||||
Summary: Development libraries for Network Security Services
|
||||
Group: Development/Libraries
|
||||
Provides: nss-static = %{version}-%{release}
|
||||
Requires: nss = %{version}-%{release}
|
||||
Requires: nss-util-devel
|
||||
Requires: nss-softokn-devel
|
||||
@ -120,6 +122,7 @@ low level services.
|
||||
%patch8 -p1 -b .695011
|
||||
%patch16 -p0 -b .539183
|
||||
%patch17 -p0 -b .703658
|
||||
%patch18 -p0 -b .646045
|
||||
|
||||
|
||||
%build
|
||||
@ -162,6 +165,21 @@ USE_64=1
|
||||
export USE_64
|
||||
%endif
|
||||
|
||||
##### phase 1: build freebl/softokn shared libraries
|
||||
# there no ecc in freebl
|
||||
unset NSS_ENABLE_ECC
|
||||
# Compile softoken plus needed support
|
||||
%{__make} -C ./mozilla/security/coreconf
|
||||
%{__make} -C ./mozilla/security/dbm
|
||||
%{__make} -C ./mozilla/security/nss
|
||||
|
||||
##### phase 2: build the rest of nss
|
||||
# nss supports pluggable ecc
|
||||
NSS_ENABLE_ECC=1
|
||||
export NSS_ENABLE_ECC
|
||||
NSS_ECC_MORE_THAN_SUITE_B=1
|
||||
export NSS_ECC_MORE_THAN_SUITE_B
|
||||
|
||||
# We only ship the nss proper libraries, no softoken nor util, yet
|
||||
# we must compile with the entire source tree because nss needs
|
||||
# private exports from util. The install section will ensure not
|
||||
@ -515,11 +533,18 @@ rm -rf $RPM_BUILD_ROOT/%{_includedir}/nss3/nsslowhash.h
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jun 27 2011 Michael Schwendt <mschwendt@fedoraproject.org> - 3.12.10-5
|
||||
- Provide virtual -static package to meet guidelines (#609612).
|
||||
|
||||
* Fri Jun 10 2011 Elio Maldonado <emaldona@redhat.com> - 3.12.10-4
|
||||
- Enable pluggable ecc support (#712556)
|
||||
- Disable the nssdb write-access-on-read-only-dir tests when user is root (#646045)
|
||||
|
||||
* Fri May 20 2011 Dennis Gilmore <dennis@ausil.us> - 3.12.10-3
|
||||
- make the testsuite non fatal on arm arches
|
||||
|
||||
* Tue May 17 2011 Elio Maldonado <emaldona@redhat.com> - 3.12.10-2
|
||||
- Fix crmf hard-coded maximum size for wrapped private keys (#703658)
|
||||
- Fix crmf hard-coded maximum size for wrapped private keys (#703656)
|
||||
|
||||
* Fri May 06 2011 Elio Maldonado <emaldona@redhat.com> - 3.12.10-1
|
||||
- Update to NSS_3_12_10_RTM
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
4f4b65c7fc3a97945aa50a64a39ef9b5 nss-3.12.10-stripped.tar.bz2
|
||||
05ccaacf0146ef7b74f100e9d2141633 nss-3.12.10-stripped.tar.bz2
|
||||
e63cddf74c07f0d818d1052ecc6fbb1f nss-pem-20101125.tar.bz2
|
||||
a5ae49867124ac75f029a9a33af31bad blank-cert8.db
|
||||
9315689bbd9f28ceebd47894f99fccbd blank-key3.db
|
||||
|
Loading…
Reference in New Issue
Block a user