fix test script
This commit is contained in:
parent
cd77ff2c17
commit
423cf344b1
@ -20,3 +20,46 @@ diff --git a/tests/merge/merge.sh b/tests/merge/merge.sh
|
||||
# modify CONFLICTDIR potentially corrupting the database
|
||||
certutil -A -n "Alice #1" -t C,, -i ${R_CADIR}/TestUser42.cert -d ${CONFLICT1DIR} -f ${R_PWFILE}
|
||||
certutil -M -n "Alice #1" -t ,, -d ${CONFLICT1DIR} -f ${R_PWFILE}
|
||||
diff --git a/tests/all.sh b/tests/all.sh
|
||||
--- a/tests/all.sh
|
||||
+++ b/tests/all.sh
|
||||
@@ -106,16 +106,18 @@
|
||||
RUN_FIPS=""
|
||||
|
||||
############################## run_tests ###############################
|
||||
# run test suites defined in TESTS variable, skip scripts defined in
|
||||
# TESTS_SKIP variable
|
||||
########################################################################
|
||||
run_tests()
|
||||
{
|
||||
+ echo "Running test cycle: ${TEST_MODE} ----------------------"
|
||||
+ echo "List of tests that will be executed: ${TESTS}"
|
||||
for TEST in ${TESTS}
|
||||
do
|
||||
# NOTE: the spaces are important. If you don't include
|
||||
# the spaces, then turning off ssl_gtests will also turn off ssl
|
||||
# tests.
|
||||
echo " ${TESTS_SKIP} " | grep " ${TEST} " > /dev/null
|
||||
if [ $? -eq 0 ]; then
|
||||
continue
|
||||
@@ -167,18 +169,19 @@ run_cycle_pkix()
|
||||
export NSS_ENABLE_PKIX_VERIFY
|
||||
|
||||
TESTS="${ALL_TESTS}"
|
||||
TESTS_SKIP="cipher dbtests sdr crmf smime merge multinit"
|
||||
|
||||
NSS_SSL_TESTS=`echo "${NSS_SSL_TESTS}" | sed -e "s/normal//g" -e "s/fips//g" -e "s/_//g"`
|
||||
export -n NSS_SSL_RUN
|
||||
|
||||
- # use the default format
|
||||
+ # use the default format. (unset for the shell, export -n for binaries)
|
||||
export -n NSS_DEFAULT_DB_TYPE
|
||||
+ unset NSS_DEFAULT_DB_TYPE
|
||||
|
||||
run_tests
|
||||
}
|
||||
|
||||
######################### run_cycle_upgrade_db #########################
|
||||
# upgrades certificate database to shareable format and run test suites
|
||||
# with those databases
|
||||
########################################################################
|
||||
|
5
nss.spec
5
nss.spec
@ -9,7 +9,7 @@ Name: nss
|
||||
Version: 3.33.0
|
||||
# for Rawhide, please always use release >= 2
|
||||
# for Fedora release branches, please use release < 2 (1.0, 1.1, ...)
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
License: MPLv2.0
|
||||
URL: http://www.mozilla.org/projects/security/pki/nss/
|
||||
Group: System Environment/Libraries
|
||||
@ -774,6 +774,9 @@ done
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Nov 8 2017 Kai Engert <kaie@redhat.com> - 3.33.0-5
|
||||
- Fix test script
|
||||
|
||||
* Tue Nov 7 2017 Kai Engert <kaie@redhat.com> - 3.33.0-4
|
||||
- Update tests to be compatible with default NSS DB changed to sql
|
||||
(the default was changed in the nss-util package).
|
||||
|
Loading…
Reference in New Issue
Block a user