Fix ldflags so we actually pick up the build flags from rpm
This commit is contained in:
parent
f5e7a76ada
commit
2078d428ac
13
nss-dso-ldflags.patch
Normal file
13
nss-dso-ldflags.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Index: nss/coreconf/Linux.mk
|
||||||
|
===================================================================
|
||||||
|
--- nss.orig/coreconf/Linux.mk
|
||||||
|
+++ nss/coreconf/Linux.mk
|
||||||
|
@@ -144,7 +144,7 @@ ifdef USE_PTHREADS
|
||||||
|
endif
|
||||||
|
|
||||||
|
DSO_CFLAGS = -fPIC
|
||||||
|
-DSO_LDOPTS = -shared $(ARCHFLAG) -Wl,--gc-sections
|
||||||
|
+DSO_LDOPTS = -shared $(ARCHFLAG) -Wl,--gc-sections $(DSO_LDFLAGS)
|
||||||
|
# The linker on Red Hat Linux 7.2 and RHEL 2.1 (GNU ld version 2.11.90.0.8)
|
||||||
|
# incorrectly reports undefined references in the libraries we link with, so
|
||||||
|
# we don't use -z defs there.
|
12
nss.spec
12
nss.spec
@ -3,7 +3,7 @@
|
|||||||
# NOTE: To avoid NVR clashes of nspr* packages:
|
# NOTE: To avoid NVR clashes of nspr* packages:
|
||||||
# - reset %%{nspr_release} to 1, when updating %%{nspr_version}
|
# - reset %%{nspr_release} to 1, when updating %%{nspr_version}
|
||||||
# - increment %%{nspr_version}, when updating the NSS part only
|
# - increment %%{nspr_version}, when updating the NSS part only
|
||||||
%global baserelease 2
|
%global baserelease 3
|
||||||
%global nss_release %baserelease
|
%global nss_release %baserelease
|
||||||
# use "%%global nspr_release %%[%%baserelease+n]" to handle offsets when
|
# use "%%global nspr_release %%[%%baserelease+n]" to handle offsets when
|
||||||
# release number between nss and nspr are different.
|
# release number between nss and nspr are different.
|
||||||
@ -129,6 +129,7 @@ Source101: nspr-config.xml
|
|||||||
# but it doesn't hurt to keep it.
|
# but it doesn't hurt to keep it.
|
||||||
Patch4: iquote.patch
|
Patch4: iquote.patch
|
||||||
Patch12: nss-signtool-format.patch
|
Patch12: nss-signtool-format.patch
|
||||||
|
Patch13: nss-dso-ldflags.patch
|
||||||
# fedora disabled dbm by default
|
# fedora disabled dbm by default
|
||||||
Patch40: nss-no-dbm-man-page.patch
|
Patch40: nss-no-dbm-man-page.patch
|
||||||
# allow crypto policies to enable kyber
|
# allow crypto policies to enable kyber
|
||||||
@ -291,9 +292,9 @@ Header files for doing development with the Netscape Portable Runtime.
|
|||||||
%setup -q -T -b 0 -n %{name}-%{nss_archive_version}
|
%setup -q -T -b 0 -n %{name}-%{nss_archive_version}
|
||||||
cp ./nspr/config/nspr-config.in ./nspr/config/nspr-config-pc.in
|
cp ./nspr/config/nspr-config.in ./nspr/config/nspr-config-pc.in
|
||||||
|
|
||||||
%patch 100 -p0 -b .flags
|
%patch -P 100 -p0 -b .flags
|
||||||
pushd nspr
|
pushd nspr
|
||||||
%patch 101 -p1 -b .gcc-atomics
|
%patch -P 101 -p1 -b .gcc-atomics
|
||||||
popd
|
popd
|
||||||
|
|
||||||
pushd nss
|
pushd nss
|
||||||
@ -385,7 +386,7 @@ export XCFLAGS="$XCFLAGS -Wno-array-parameter"
|
|||||||
|
|
||||||
export LDFLAGS=$RPM_LD_FLAGS
|
export LDFLAGS=$RPM_LD_FLAGS
|
||||||
|
|
||||||
export DSO_LDOPTS=$RPM_LD_FLAGS
|
export DSO_LDFLAGS=$RPM_LD_FLAGS
|
||||||
|
|
||||||
export PKG_CONFIG_ALLOW_SYSTEM_LIBS=1
|
export PKG_CONFIG_ALLOW_SYSTEM_LIBS=1
|
||||||
export PKG_CONFIG_ALLOW_SYSTEM_CFLAGS=1
|
export PKG_CONFIG_ALLOW_SYSTEM_CFLAGS=1
|
||||||
@ -1090,6 +1091,9 @@ update-crypto-policies &> /dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 20 2024 Bob Relyea <rrelyea@redhat.com> - 3.101.0-3
|
||||||
|
- Make sure the rpm LD flags are passed to the NSS build system.
|
||||||
|
|
||||||
* Wed Jun 12 2024 Bob Relyea <rrelyea@redhat.com> - 3.101.0-2
|
* Wed Jun 12 2024 Bob Relyea <rrelyea@redhat.com> - 3.101.0-2
|
||||||
- Enable the Kyber record so we can control it with policies.
|
- Enable the Kyber record so we can control it with policies.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user