Update to NSS 3.46
This commit is contained in:
parent
ad1ef42b5a
commit
180b09f605
1
.gitignore
vendored
1
.gitignore
vendored
@ -37,3 +37,4 @@ TestUser51.cert
|
||||
/nss-3.43.tar.gz
|
||||
/nss-3.44.tar.gz
|
||||
/nss-3.44.1.tar.gz
|
||||
/nss-3.46.tar.gz
|
||||
|
@ -1,155 +0,0 @@
|
||||
# HG changeset patch
|
||||
# User Daiki Ueno <dueno@redhat.com>
|
||||
# Date 1562162181 -7200
|
||||
# Wed Jul 03 15:56:21 2019 +0200
|
||||
# Node ID 88feab2a3e5e4b00b1626d59a0d3ecef93cafb92
|
||||
# Parent b5d3f574967f8c5c705dab15682b0e16fac3e4be
|
||||
tests: ensure CAVS test dirs are created
|
||||
|
||||
diff --git a/tests/fips/cavs_scripts/aes.sh b/tests/fips/cavs_scripts/aes.sh
|
||||
--- a/tests/fips/cavs_scripts/aes.sh
|
||||
+++ b/tests/fips/cavs_scripts/aes.sh
|
||||
@@ -83,6 +83,8 @@ if [ ${COMMAND} = "verify" ]; then
|
||||
exit $result
|
||||
fi
|
||||
|
||||
+test -d "${RSPDIR}" || mkdir "${RSPDIR}"
|
||||
+
|
||||
for request in $cbc_kat_requests; do
|
||||
response=`echo $request | sed -e "s/req/rsp/"`
|
||||
echo $request $response
|
||||
diff --git a/tests/fips/cavs_scripts/aesgcm.sh b/tests/fips/cavs_scripts/aesgcm.sh
|
||||
--- a/tests/fips/cavs_scripts/aesgcm.sh
|
||||
+++ b/tests/fips/cavs_scripts/aesgcm.sh
|
||||
@@ -56,6 +56,8 @@ if [ ${COMMAND} = "verify" ]; then
|
||||
exit $result
|
||||
fi
|
||||
|
||||
+test -d "${RSPDIR}" || mkdir "${RSPDIR}"
|
||||
+
|
||||
for request in $gcm_decrypt_requests; do
|
||||
response=`echo $request | sed -e "s/req/rsp/"`
|
||||
echo $request $response
|
||||
diff --git a/tests/fips/cavs_scripts/dsa.sh b/tests/fips/cavs_scripts/dsa.sh
|
||||
--- a/tests/fips/cavs_scripts/dsa.sh
|
||||
+++ b/tests/fips/cavs_scripts/dsa.sh
|
||||
@@ -59,6 +59,8 @@ if [ ${COMMAND} = "verify" ]; then
|
||||
exit $result
|
||||
fi
|
||||
|
||||
+test -d "${RSPDIR}" || mkdir "${RSPDIR}"
|
||||
+
|
||||
request=KeyPair.req
|
||||
response=`echo $request | sed -e "s/req/rsp/"`
|
||||
echo $request $response
|
||||
diff --git a/tests/fips/cavs_scripts/ecdsa.sh b/tests/fips/cavs_scripts/ecdsa.sh
|
||||
--- a/tests/fips/cavs_scripts/ecdsa.sh
|
||||
+++ b/tests/fips/cavs_scripts/ecdsa.sh
|
||||
@@ -50,6 +50,8 @@ if [ ${COMMAND} = "verify" ]; then
|
||||
exit $result
|
||||
fi
|
||||
|
||||
+test -d "${RSPDIR}" || mkdir "${RSPDIR}"
|
||||
+
|
||||
request=KeyPair.req
|
||||
response=`echo $request | sed -e "s/req/rsp/"`
|
||||
echo $request $response
|
||||
diff --git a/tests/fips/cavs_scripts/hmac.sh b/tests/fips/cavs_scripts/hmac.sh
|
||||
--- a/tests/fips/cavs_scripts/hmac.sh
|
||||
+++ b/tests/fips/cavs_scripts/hmac.sh
|
||||
@@ -31,6 +31,9 @@ if [ ${COMMAND} = "verify" ]; then
|
||||
done
|
||||
exit $result
|
||||
fi
|
||||
+
|
||||
+test -d "${RSPDIR}" || mkdir "${RSPDIR}"
|
||||
+
|
||||
for request in $hmac_requests; do
|
||||
response=`echo $request | sed -e "s/req/rsp/"`
|
||||
echo $request $response
|
||||
diff --git a/tests/fips/cavs_scripts/ike.sh b/tests/fips/cavs_scripts/ike.sh
|
||||
--- a/tests/fips/cavs_scripts/ike.sh
|
||||
+++ b/tests/fips/cavs_scripts/ike.sh
|
||||
@@ -33,6 +33,8 @@ if [ ${COMMAND} = "verify" ]; then
|
||||
exit $result
|
||||
fi
|
||||
|
||||
+test -d "${RSPDIR}" || mkdir "${RSPDIR}"
|
||||
+
|
||||
request=ikev1_dsa.req
|
||||
response=`echo $request | sed -e "s/req/rsp/"`
|
||||
echo $request $response
|
||||
diff --git a/tests/fips/cavs_scripts/kas.sh b/tests/fips/cavs_scripts/kas.sh
|
||||
--- a/tests/fips/cavs_scripts/kas.sh
|
||||
+++ b/tests/fips/cavs_scripts/kas.sh
|
||||
@@ -68,6 +68,8 @@ if [ ${COMMAND} = "verify" ]; then
|
||||
exit $result
|
||||
fi
|
||||
|
||||
+test -d "${RSPDIR}" || mkdir "${RSPDIR}"
|
||||
+
|
||||
request=KASFunctionTest_ECCEphemeralUnified_NOKC_ZZOnly_init.req
|
||||
response=`echo $request | sed -e "s/req/rsp/"`
|
||||
echo $request $response
|
||||
diff --git a/tests/fips/cavs_scripts/rng.sh b/tests/fips/cavs_scripts/rng.sh
|
||||
--- a/tests/fips/cavs_scripts/rng.sh
|
||||
+++ b/tests/fips/cavs_scripts/rng.sh
|
||||
@@ -30,6 +30,9 @@ if [ ${COMMAND} = "verify" ]; then
|
||||
done
|
||||
exit $result
|
||||
fi
|
||||
+
|
||||
+test -d "${RSPDIR}" || mkdir "${RSPDIR}"
|
||||
+
|
||||
for request in $drbg_requests; do
|
||||
response=`echo $request | sed -e "s/req/rsp/"`
|
||||
echo $request $response
|
||||
diff --git a/tests/fips/cavs_scripts/rsa.sh b/tests/fips/cavs_scripts/rsa.sh
|
||||
--- a/tests/fips/cavs_scripts/rsa.sh
|
||||
+++ b/tests/fips/cavs_scripts/rsa.sh
|
||||
@@ -38,6 +38,8 @@ if [ ${COMMAND} = "verify" ]; then
|
||||
exit $result
|
||||
fi
|
||||
|
||||
+test -d "${RSPDIR}" || mkdir "${RSPDIR}"
|
||||
+
|
||||
request=SigGen15_186-3.req
|
||||
response=`echo $request | sed -e "s/req/rsp/"`
|
||||
echo $request $response
|
||||
diff --git a/tests/fips/cavs_scripts/sha.sh b/tests/fips/cavs_scripts/sha.sh
|
||||
--- a/tests/fips/cavs_scripts/sha.sh
|
||||
+++ b/tests/fips/cavs_scripts/sha.sh
|
||||
@@ -51,6 +51,8 @@ if [ ${COMMAND} = "verify" ]; then
|
||||
exit $result
|
||||
fi
|
||||
|
||||
+test -d "${RSPDIR}" || mkdir "${RSPDIR}"
|
||||
+
|
||||
for request in $sha_ShortMsg_requests; do
|
||||
response=`echo $request | sed -e "s/req/rsp/"`
|
||||
echo $request $response
|
||||
diff --git a/tests/fips/cavs_scripts/tdea.sh b/tests/fips/cavs_scripts/tdea.sh
|
||||
--- a/tests/fips/cavs_scripts/tdea.sh
|
||||
+++ b/tests/fips/cavs_scripts/tdea.sh
|
||||
@@ -77,6 +77,8 @@ if [ ${COMMAND} = "verify" ]; then
|
||||
exit $result
|
||||
fi
|
||||
|
||||
+test -d "${RSPDIR}" || mkdir "${RSPDIR}"
|
||||
+
|
||||
for request in $cbc_kat_requests; do
|
||||
response=`echo $request | sed -e "s/req/rsp/"`
|
||||
echo $request $response
|
||||
diff --git a/tests/fips/cavs_scripts/tls.sh b/tests/fips/cavs_scripts/tls.sh
|
||||
--- a/tests/fips/cavs_scripts/tls.sh
|
||||
+++ b/tests/fips/cavs_scripts/tls.sh
|
||||
@@ -30,6 +30,9 @@ if [ ${COMMAND} = "verify" ]; then
|
||||
done
|
||||
exit $result
|
||||
fi
|
||||
+
|
||||
+test -d "${RSPDIR}" || mkdir "${RSPDIR}"
|
||||
+
|
||||
for request in $tls_requests; do
|
||||
response=`echo $request | sed -e "s/req/rsp/"`
|
||||
echo $request $response
|
6
nss.spec
6
nss.spec
@ -1,5 +1,5 @@
|
||||
%global nspr_version 4.21.0
|
||||
%global nss_version 3.44.1
|
||||
%global nss_version 3.46.0
|
||||
%global unsupported_tools_directory %{_libdir}/nss/unsupported-tools
|
||||
%global saved_files_dir %{_libdir}/nss/saved
|
||||
%global dracutlibdir %{_prefix}/lib/dracut
|
||||
@ -109,7 +109,6 @@ Patch3: nss-module-leak.patch
|
||||
Patch4: iquote.patch
|
||||
# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1552767
|
||||
Patch5: nss-skip-tls13-fips.patch
|
||||
Patch6: nss-cavs-tests.patch
|
||||
|
||||
%description
|
||||
Network Security Services (NSS) is a set of libraries designed to
|
||||
@ -875,6 +874,9 @@ update-crypto-policies &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Sep 3 2019 Daiki Ueno <dueno@redhat.com> - 3.46.0-1
|
||||
- Update to NSS 3.46
|
||||
|
||||
* Tue Jul 2 2019 Daiki Ueno <dueno@redhat.com> - 3.44.1-1
|
||||
- Update to NSS 3.44.1
|
||||
|
||||
|
2
sources
2
sources
@ -3,4 +3,4 @@ SHA512 (blank-cert9.db) = 2f8eab4c0612210ee47db8a3a80c1b58a0b43849551af78c7da403
|
||||
SHA512 (blank-key3.db) = 01f7314e9fc8a7c9aa997652624cfcde213d18a6b3bb31840c1a60bbd662e56b5bc3221d13874abb42ce78163b225a6dfce2e1326cf6dd29366ad9c28ba5a71c
|
||||
SHA512 (blank-key4.db) = 8fedae93af7163da23fe9492ea8e785a44c291604fa98e58438448efb69c85d3253fc22b926d5c3209c62e58a86038fd4d78a1c4c068bc00600a7f3e5382ebe7
|
||||
SHA512 (blank-secmod.db) = 06a2dbd861839ef6315093459328b500d3832333a34b30e6fac4a2503af337f014a4d319f0f93322409e719142904ce8bc08252ae9a4f37f30d4c3312e900310
|
||||
SHA512 (nss-3.44.1.tar.gz) = eb8777701a25b54377026633b6bf284e4c62308012058355f348a7c57525afe96db74a07de41ba01754e316a7dff06689de527359a5474ed7ab606779c4cf169
|
||||
SHA512 (nss-3.46.tar.gz) = de309ec8d6aa2c3cf4d5ebfe9fa1f8bf5def717d22018d5c88c1de963b4ae7b0d69ad64e68d830574fc85613483fd538cb2f319ffb3fa2e1b97ec02f85d37c48
|
||||
|
Loading…
Reference in New Issue
Block a user