- fix bug bug 429175 in libpem module
This commit is contained in:
parent
cdf0dd20eb
commit
0d8160acc5
12
nss-pem-bug429175.patch
Normal file
12
nss-pem-bug429175.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -u --recursive mozilla.orig/security/nss/lib/ckfw/pem/pobject.c mozilla/security/nss/lib/ckfw/pem/pobject.c
|
||||
--- mozilla.orig/security/nss/lib/ckfw/pem/pobject.c 2007-09-06 16:46:30.000000000 -0400
|
||||
+++ mozilla/security/nss/lib/ckfw/pem/pobject.c 2008-08-13 21:08:43.000000000 -0400
|
||||
@@ -160,7 +160,7 @@
|
||||
(void *) &ck_false, (PRUint32) sizeof(CK_BBOOL)
|
||||
};
|
||||
static const NSSItem pem_x509Item = {
|
||||
- (void *) &ckc_x509, (PRUint32) sizeof(CKC_X_509)
|
||||
+ (void *) &ckc_x509, (PRUint32) sizeof(CK_ULONG)
|
||||
};
|
||||
static const NSSItem pem_rsaItem = {
|
||||
(void *) &ckk_rsa, (PRUint32) sizeof(CK_KEY_TYPE)
|
6
nss.spec
6
nss.spec
@ -4,7 +4,7 @@
|
||||
Summary: Network Security Services
|
||||
Name: nss
|
||||
Version: 3.12.0.3
|
||||
Release: 0.9.1%{?dist}
|
||||
Release: 0.9.2%{?dist}
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
URL: http://www.mozilla.org/projects/security/pki/nss/
|
||||
Group: System Environment/Libraries
|
||||
@ -30,6 +30,7 @@ Source12: %{name}-pem-20080124.tar.bz2
|
||||
|
||||
Patch1: nss-no-rpath.patch
|
||||
Patch2: nss-nolocalsql.patch
|
||||
Patch5: nss-pem-bug429175.patch
|
||||
Patch6: nss-enable-pem.patch
|
||||
patch7: nss-fix-tests.patch
|
||||
|
||||
@ -83,6 +84,7 @@ low level services.
|
||||
|
||||
%patch1 -p0
|
||||
%patch2 -p0
|
||||
%patch5 -p0 -b .429175
|
||||
%patch6 -p0 -b .libpem
|
||||
%patch7 -p0 -b .prex
|
||||
|
||||
@ -440,6 +442,8 @@ done
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Aug 22 2008 Kai Engert <kengert@redhat.com> - 3.12.0.3-0.9.2
|
||||
- fix bug bug 429175 in libpem module
|
||||
* Mon Jun 02 2008 Kai Engert <kengert@redhat.com> - 3.12.0.3-0.9.1
|
||||
- Update to NSS_3_12_RC4
|
||||
* Mon Apr 14 2008 Kai Engert <kengert@redhat.com> - 3.12.0.1-1
|
||||
|
Loading…
Reference in New Issue
Block a user