Merge branch 'master' into f14
This commit is contained in:
commit
0ade450edc
@ -1,52 +0,0 @@
|
||||
diff -up ./mozilla/security/nss/lib/Makefile.nolocalsql ./mozilla/security/nss/lib/Makefile
|
||||
--- ./mozilla/security/nss/lib/Makefile.nolocalsql 2010-02-27 16:40:25.891777537 -0800
|
||||
+++ ./mozilla/security/nss/lib/Makefile 2010-02-27 16:41:59.175902327 -0800
|
||||
@@ -62,11 +62,11 @@ ifndef USE_SYSTEM_ZLIB
|
||||
ZLIB_SRCDIR = zlib # Add the zlib directory to DIRS.
|
||||
endif
|
||||
|
||||
-ifndef MOZILLA_CLIENT
|
||||
-ifndef NSS_USE_SYSTEM_SQLITE
|
||||
-SQLITE_SRCDIR = sqlite # Add the sqlite directory to DIRS.
|
||||
-endif
|
||||
-endif
|
||||
+#ifndef MOZILLA_CLIENT
|
||||
+#ifndef NSS_USE_SYSTEM_SQLITE
|
||||
+#SQLITE_SRCDIR = sqlite # Add the sqlite directory to DIRS.
|
||||
+#endif
|
||||
+#endif
|
||||
|
||||
ifndef MOZILLA_CLIENT
|
||||
ifeq ($(OS_ARCH),Linux)
|
||||
diff -up ./mozilla/security/nss/lib/softoken/legacydb/manifest.mn.nolocalsql ./mozilla/security/nss/lib/softoken/legacydb/manifest.mn
|
||||
--- ./mozilla/security/nss/lib/softoken/legacydb/manifest.mn.nolocalsql 2010-02-27 16:44:24.998777709 -0800
|
||||
+++ ./mozilla/security/nss/lib/softoken/legacydb/manifest.mn 2010-02-27 16:45:08.533803472 -0800
|
||||
@@ -46,9 +46,9 @@ MAPFILE = $(OBJDIR)/nssdbm.def
|
||||
|
||||
DEFINES += -DSHLIB_SUFFIX=\"$(DLL_SUFFIX)\" -DSHLIB_PREFIX=\"$(DLL_PREFIX)\" -DSOFTOKEN_LIB_NAME=\"$(notdir $(SHARED_LIBRARY))\"
|
||||
|
||||
-ifdef MOZILLA_CLIENT
|
||||
-INCLUDES += -I$(DIST)/include/sqlite3
|
||||
-endif
|
||||
+#ifdef MOZILLA_CLIENT
|
||||
+#INCLUDES += -I$(DIST)/include/sqlite3
|
||||
+#endif
|
||||
|
||||
CSRCS = \
|
||||
dbmshim.c \
|
||||
diff -up ./mozilla/security/nss/lib/softoken/manifest.mn.nolocalsql ./mozilla/security/nss/lib/softoken/manifest.mn
|
||||
--- ./mozilla/security/nss/lib/softoken/manifest.mn.nolocalsql 2010-02-27 16:42:52.213902231 -0800
|
||||
+++ ./mozilla/security/nss/lib/softoken/manifest.mn 2010-02-27 16:43:34.040776788 -0800
|
||||
@@ -47,9 +47,9 @@ MAPFILE = $(OBJDIR)/softokn.def
|
||||
|
||||
DEFINES += -DSHLIB_SUFFIX=\"$(DLL_SUFFIX)\" -DSHLIB_PREFIX=\"$(DLL_PREFIX)\" -DSOFTOKEN_LIB_NAME=\"$(notdir $(SHARED_LIBRARY))\" -DSHLIB_VERSION=\"$(LIBRARY_VERSION)\"
|
||||
|
||||
-ifdef MOZILLA_CLIENT
|
||||
-INCLUDES += -I$(DIST)/include/sqlite3
|
||||
-endif
|
||||
+#ifdef MOZILLA_CLIENT
|
||||
+#INCLUDES += -I$(DIST)/include/sqlite3
|
||||
+#endif
|
||||
|
||||
EXPORTS = \
|
||||
secmodt.h \
|
17
nss.spec
17
nss.spec
@ -6,7 +6,7 @@
|
||||
Summary: Network Security Services
|
||||
Name: nss
|
||||
Version: 3.12.7
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
URL: http://www.mozilla.org/projects/security/pki/nss/
|
||||
Group: System Environment/Libraries
|
||||
@ -16,7 +16,7 @@ Requires: nss-softokn%{_isa} >= %{nss_softokn_version}
|
||||
Requires: nss-system-init
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: nspr-devel >= %{nspr_version}
|
||||
BuildRequires: nss-softokn-devel >= 3.12.4
|
||||
BuildRequires: nss-softokn-devel >= %{nss_softokn_version}
|
||||
BuildRequires: nss-util-devel >= %{nss_util_version}
|
||||
BuildRequires: sqlite-devel
|
||||
BuildRequires: zlib-devel
|
||||
@ -39,7 +39,6 @@ Source9: setup-nsssysinit.sh
|
||||
Source10: PayPalEE.cert
|
||||
Source12: %{name}-pem-20100809.tar.bz2
|
||||
|
||||
Patch2: nss-nolocalsql.patch
|
||||
Patch3: renegotiate-transitional.patch
|
||||
Patch6: nss-enable-pem.patch
|
||||
Patch7: nsspem-596674.patch
|
||||
@ -73,6 +72,8 @@ manipulate the NSS certificate and key database.
|
||||
%package sysinit
|
||||
Summary: System NSS Initilization
|
||||
Group: System Environment/Base
|
||||
# providing nss-system-init without version so that it can
|
||||
# be replaced by a better one, e.g. supplied by the os vendor
|
||||
Provides: nss-system-init
|
||||
Requires: nss = %{version}-%{release}
|
||||
Requires(post): coreutils, sed
|
||||
@ -111,7 +112,6 @@ low level services.
|
||||
%{__cp} %{SOURCE10} -f ./mozilla/security/nss/tests/libpkix/certs
|
||||
%setup -q -T -D -n %{name}-%{version} -a 12
|
||||
|
||||
%patch2 -p0 -b .nolocalsql
|
||||
%patch3 -p0 -b .transitional
|
||||
%patch6 -p0 -b .libpem
|
||||
%patch7 -p0 -b .596674
|
||||
@ -148,8 +148,8 @@ export NSPR_LIB_DIR
|
||||
NSS_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nss-util | sed 's/-I//'`
|
||||
NSS_LIB_DIR=`/usr/bin/pkg-config --libs-only-L nss-util | sed 's/-L//'`
|
||||
|
||||
#export NSS_INCLUDE_DIR
|
||||
#export NSS_LIB_DIR
|
||||
NSS_USE_SYSTEM_SQLITE=1
|
||||
export NSS_USE_SYSTEM_SQLITE
|
||||
|
||||
%ifarch x86_64 ppc64 ia64 s390x sparc64
|
||||
USE_64=1
|
||||
@ -490,6 +490,11 @@ rm -rf $RPM_BUILD_ROOT/%{_includedir}/nss3/nsslowhash.h
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Aug 28 2010 Elio Maldonado <emaldona@redhat.com> - 3.12.7-2
|
||||
- Define NSS_USE_SYSTEM_SQLITE and remove unneeded patch
|
||||
- Add comments regarding an unverioned provides which triggers rpmlint warning
|
||||
- Build requires nss-softokn-devel >= 3.12.7
|
||||
|
||||
* Mon Aug 16 2010 Elio Maldonado <emaldona@redhat.com> - 3.12.7-1
|
||||
- Update to 3.12.7
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user