Update to nss-3.16.0

- Cleanup the copying of the tools man pages
- Update the iquote.patch on account of the rebase
This commit is contained in:
Elio Maldonado 2014-03-18 17:27:02 -07:00
parent 8b13702a67
commit 0834927548
4 changed files with 79 additions and 14 deletions

2
.gitignore vendored
View File

@ -8,4 +8,4 @@ TestCA.ca.cert
TestUser50.cert
TestUser51.cert
/nss-pem-20140125.tar.bz2
/nss-3.15.5.tar.gz
/nss-3.16.0.tar.gz

View File

@ -20,6 +20,69 @@ diff -up nss/cmd/lib/Makefile.iquote nss/cmd/lib/Makefile
+INCLUDES += -iquote $(DIST)/../private/nss
+INCLUDES += -iquote $(DIST)/../public/nss
#######################################################################
# (7) Execute "local" rules. (OPTIONAL). #
diff -up nss/cmd/selfserv/Makefile.iquote nss/cmd/selfserv/Makefile
--- nss/cmd/selfserv/Makefile.iquote 2014-03-14 13:31:59.000000000 -0700
+++ nss/cmd/selfserv/Makefile 2014-03-18 14:48:16.065834825 -0700
@@ -35,7 +35,8 @@ include $(CORE_DEPTH)/coreconf/rules.mk
# (6) Execute "component" rules. (OPTIONAL) #
#######################################################################
-
+INCLUDES += -iquote $(DIST)/../public/nss
+INCLUDES += -iquote $(DIST)/../private/nss
#######################################################################
# (7) Execute "local" rules. (OPTIONAL). #
diff -up nss/cmd/ssltap/Makefile.iquote nss/cmd/ssltap/Makefile
--- nss/cmd/ssltap/Makefile.iquote 2014-03-14 13:31:59.000000000 -0700
+++ nss/cmd/ssltap/Makefile 2014-03-18 14:48:16.065834825 -0700
@@ -39,7 +39,8 @@ include $(CORE_DEPTH)/coreconf/rules.mk
# (6) Execute "component" rules. (OPTIONAL) #
#######################################################################
-
+INCLUDES += -iquote $(DIST)/../private/nss
+INCLUDES += -iquote $(DIST)/../public/nss
#######################################################################
# (7) Execute "local" rules. (OPTIONAL). #
diff -up nss/cmd/strsclnt/Makefile.iquote nss/cmd/strsclnt/Makefile
--- nss/cmd/strsclnt/Makefile.iquote 2014-03-14 13:31:59.000000000 -0700
+++ nss/cmd/strsclnt/Makefile 2014-03-18 14:48:16.065834825 -0700
@@ -36,7 +36,8 @@ include $(CORE_DEPTH)/coreconf/rules.mk
# (6) Execute "component" rules. (OPTIONAL) #
#######################################################################
-
+INCLUDES += -iquote $(DIST)/../public/nss
+INCLUDES += -iquote $(DIST)/../private/nss
#######################################################################
# (7) Execute "local" rules. (OPTIONAL). #
diff -up nss/cmd/tstclnt/Makefile.iquote nss/cmd/tstclnt/Makefile
--- nss/cmd/tstclnt/Makefile.iquote 2014-03-14 13:31:59.000000000 -0700
+++ nss/cmd/tstclnt/Makefile 2014-03-18 14:48:16.065834825 -0700
@@ -37,6 +37,8 @@ include $(CORE_DEPTH)/coreconf/rules.mk
#######################################################################
#include ../platlibs.mk
+INCLUDES += -iquote $(DIST)/../public/nss
+INCLUDES += -iquote $(DIST)/../private/nss
#######################################################################
# (7) Execute "local" rules. (OPTIONAL). #
diff -up nss/cmd/vfyserv/Makefile.iquote nss/cmd/vfyserv/Makefile
--- nss/cmd/vfyserv/Makefile.iquote 2014-03-18 14:49:25.794897961 -0700
+++ nss/cmd/vfyserv/Makefile 2014-03-18 14:50:03.817477638 -0700
@@ -37,6 +37,8 @@ include $(CORE_DEPTH)/coreconf/rules.mk
#######################################################################
#include ../platlibs.mk
+INCLUDES += -iquote $(DIST)/../public/nss
+INCLUDES += -iquote $(DIST)/../private/nss
#######################################################################
# (7) Execute "local" rules. (OPTIONAL). #
diff -up nss/coreconf/location.mk.iquote nss/coreconf/location.mk

View File

@ -1,6 +1,6 @@
%global nspr_version 4.10.2
%global nss_util_version 3.15.5
%global nss_softokn_version 3.15.5
%global nss_util_version 3.16.0
%global nss_softokn_version 3.16.0
%global unsupported_tools_directory %{_libdir}/nss/unsupported-tools
%global allTools "certutil cmsutil crlutil derdump modutil pk12util pp signtool signver ssltap vfychain vfyserv"
@ -18,8 +18,8 @@
Summary: Network Security Services
Name: nss
Version: 3.15.5
Release: 2%{?dist}
Version: 3.16.0
Release: 1%{?dist}
License: MPLv2.0
URL: http://www.mozilla.org/projects/security/pki/nss/
Group: System Environment/Libraries
@ -274,9 +274,7 @@ export IN_TREE_FREEBL_HEADERS_FIRST=1
%{__rm} -rf ./mozilla/security/nss/cmd/rsaperf_low
##### phase 2: build the rest of nss
# nss supports pluggable ecc
NSS_ENABLE_ECC=1
export NSS_ENABLE_ECC
# nss supports pluggable ecc with more than suite-b
NSS_ECC_MORE_THAN_SUITE_B=1
export NSS_ECC_MORE_THAN_SUITE_B
@ -291,10 +289,9 @@ pushd ./nss
%{__make} clean_docs build_docs
popd
# and copy them here
for m in "%{allTools}"; do
cp ./nss/doc/nroff/${m}.1 .
done
# and copy them to the dist directory
%{__mkdir_p} ./dist/docs/nroff
%{__cp} ./nss/doc/nroff/* ./dist/docs/nroff
# Set up our package file
# The nspr_version and nss_{util|softokn}_version globals used
@ -524,7 +521,7 @@ for f in nss-config setup-nsssysinit; do
done
# Copy the man pages for the nss tools
for f in "%{allTools}"; do
install -c -m 644 ${f}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${f}.1
install -c -m 644 ./dist/docs/nroff/${f}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${f}.1
done
# Copy the man pages for the configuration files
for f in pkcs11.txt; do
@ -734,6 +731,11 @@ fi
%changelog
* Tue Mar 18 2014 Elio Maldonado <emaldona@redhat.com> - 3.16.0-1
- Update to nss-3.16.0
- Cleanup the copying of the tools man pages
- Update the iquote.patch on account of the rebase
* Tue Mar 04 2014 Elio Maldonado <emaldona@redhat.com> - 3.15.5-2
- Restore requiring nss_softokn_version >= 3.15.5

View File

@ -8,4 +8,4 @@ f998b70c1be25e8bb9f5fdb5d50eb6f2 TestCA.ca.cert
1b7b6808cd77d5df29bf5bb9e5fac967 TestUser50.cert
ab0b56dd505a995425c03e5266f7c8d6 TestUser51.cert
b8a94e863c852e1f8b75e930e76f8640 nss-pem-20140125.tar.bz2
7a8cb5418ac8aa15d91d7bc549698268 nss-3.15.5.tar.gz
6a60df5c01f6c4ed8dbdbe85cf818a28 nss-3.16.0.tar.gz