Update to 10.4.0
https://nodejs.org/en/blog/release/v10.4.0/ Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
0ee60cf892
commit
6bbcfaf555
1
.gitignore
vendored
1
.gitignore
vendored
@ -97,3 +97,4 @@
|
|||||||
/node-v10.2.0-stripped.tar.gz
|
/node-v10.2.0-stripped.tar.gz
|
||||||
/node-v10.2.1-stripped.tar.gz
|
/node-v10.2.1-stripped.tar.gz
|
||||||
/node-v10.3.0-stripped.tar.gz
|
/node-v10.3.0-stripped.tar.gz
|
||||||
|
/node-v10.4.0-stripped.tar.gz
|
||||||
|
@ -1,14 +1,14 @@
|
|||||||
From 03d9247890c2755710a8208974d2919b6a217a63 Mon Sep 17 00:00:00 2001
|
From b5b4b7f8acd2d67c79d1fc2c954aa88edff27511 Mon Sep 17 00:00:00 2001
|
||||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||||
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
||||||
Subject: [PATCH 1/4] Disable running gyp on shared deps
|
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
||||||
|
|
||||||
---
|
---
|
||||||
Makefile | 7 +++----
|
Makefile | 7 +++----
|
||||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index a7099947c72a783a4b9d96c950ac084153532d94..bfd205d0992d4bb4b901a1f3d5595e01e6f88bf8 100644
|
index b11168aaa456af019a32885f5495c4527a16e9a0..1297fbfc9f68261ea8ebfd1ac70f32581918d078 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -89,14 +89,13 @@ $(NODE_EXE): config.gypi out/Makefile
|
@@ -89,14 +89,13 @@ $(NODE_EXE): config.gypi out/Makefile
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
From 396550f6e26912fe6ef774bc60e24ef73e2f5366 Mon Sep 17 00:00:00 2001
|
From e84a42f54aa1dabc115a0c647af6aa1500a85f34 Mon Sep 17 00:00:00 2001
|
||||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||||
Date: Tue, 1 May 2018 08:05:30 -0400
|
Date: Tue, 1 May 2018 08:05:30 -0400
|
||||||
Subject: [PATCH 2/4] Suppress NPM message to run global update
|
Subject: [PATCH 2/2] Suppress NPM message to run global update
|
||||||
|
|
||||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||||
---
|
---
|
||||||
|
16
nodejs.spec
16
nodejs.spec
@ -20,7 +20,7 @@
|
|||||||
# than a Fedora release lifecycle.
|
# than a Fedora release lifecycle.
|
||||||
%global nodejs_epoch 1
|
%global nodejs_epoch 1
|
||||||
%global nodejs_major 10
|
%global nodejs_major 10
|
||||||
%global nodejs_minor 3
|
%global nodejs_minor 4
|
||||||
%global nodejs_patch 0
|
%global nodejs_patch 0
|
||||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||||
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
||||||
@ -29,9 +29,9 @@
|
|||||||
# == Bundled Dependency Versions ==
|
# == Bundled Dependency Versions ==
|
||||||
# v8 - from deps/v8/include/v8-version.h
|
# v8 - from deps/v8/include/v8-version.h
|
||||||
%global v8_major 6
|
%global v8_major 6
|
||||||
%global v8_minor 6
|
%global v8_minor 7
|
||||||
%global v8_build 346
|
%global v8_build 288
|
||||||
%global v8_patch 32
|
%global v8_patch 43
|
||||||
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
||||||
%global v8_abi %{v8_major}.%{v8_minor}
|
%global v8_abi %{v8_major}.%{v8_minor}
|
||||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||||
@ -121,9 +121,6 @@ Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
|
|||||||
# This does bad things on an RPM-managed npm.
|
# This does bad things on an RPM-managed npm.
|
||||||
Patch2: 0002-Suppress-NPM-message-to-run-global-update.patch
|
Patch2: 0002-Suppress-NPM-message-to-run-global-update.patch
|
||||||
|
|
||||||
# Fix PowerPC builds
|
|
||||||
Patch3: 0003-PATCH-PPC-use-pc-relative-address-to-init-constpool-.patch
|
|
||||||
|
|
||||||
BuildRequires: python2-devel
|
BuildRequires: python2-devel
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
BuildRequires: gcc >= 4.9.4
|
BuildRequires: gcc >= 4.9.4
|
||||||
@ -273,7 +270,6 @@ The API documentation for the Node.js JavaScript runtime.
|
|||||||
rm -rf deps/zlib
|
rm -rf deps/zlib
|
||||||
|
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
|
||||||
|
|
||||||
# Replace any instances of unversioned python' with python2
|
# Replace any instances of unversioned python' with python2
|
||||||
find . -type f -exec sed -i "s~/usr\/bin\/env python~/usr/bin/python2~" {} \;
|
find . -type f -exec sed -i "s~/usr\/bin\/env python~/usr/bin/python2~" {} \;
|
||||||
@ -481,6 +477,10 @@ NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules:%{buildroot}%{_prefix}/lib/nod
|
|||||||
%{_pkgdocdir}/npm/doc
|
%{_pkgdocdir}/npm/doc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 07 2018 Stephen Gallagher <sgallagh@redhat.com> - -
|
||||||
|
- Update to 10.4.0
|
||||||
|
- https://nodejs.org/en/blog/release/v10.4.0/
|
||||||
|
|
||||||
* Wed May 30 2018 Stephen Gallagher <sgallagh@redhat.com> - -
|
* Wed May 30 2018 Stephen Gallagher <sgallagh@redhat.com> - -
|
||||||
- Update to 10.3.0
|
- Update to 10.3.0
|
||||||
- Update npm to 6.1.0
|
- Update npm to 6.1.0
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (node-v10.3.0-stripped.tar.gz) = 0a2fed09a6d0e67288b90207ed85c331bc82655983d8e6c3df5173e6989ab1995fb4787837d5ade65fdb8728f943b2372bc86b3064b4f7270296e89218eff533
|
SHA512 (node-v10.4.0-stripped.tar.gz) = 7119246769a71f6c2b8fb44b23003b6a6efcbdc3934e49523dba91c3c5dd91b9f6a193ce8121fbb35401467e970a6c3ac02a470485f992386cd1be849ba996d1
|
||||||
|
Loading…
Reference in New Issue
Block a user