nodejs18/0001-Disable-running-gyp-on-shared-deps.patch
Stephen Gallagher 11b4e1cf84
Update to 12.3.1
https://nodejs.org/en/blog/release/v12.3.1/
https://nodejs.org/en/blog/release/v12.3.0/

Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
2019-05-25 09:07:44 -04:00

30 lines
964 B
Diff

From f03434acfdb20c85a8e075d71e8b51417dca316a Mon Sep 17 00:00:00 2001
From: Zuzana Svetlikova <zsvetlik@redhat.com>
Date: Thu, 27 Apr 2017 14:25:42 +0200
Subject: [PATCH 1/3] Disable running gyp on shared deps
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 5834df883b0c232d2c9187f20e61f35dff4f6cef..ba3cacad0382dc17c4a911ea0c0bb39ced96c650 100644
--- a/Makefile
+++ b/Makefile
@@ -139,11 +139,11 @@ with-code-cache:
.PHONY: test-code-cache
test-code-cache: with-code-cache
echo "'test-code-cache' target is a noop"
out/Makefile: config.gypi common.gypi node.gyp \
- deps/uv/uv.gyp deps/http_parser/http_parser.gyp deps/zlib/zlib.gyp \
+ deps/http_parser/http_parser.gyp \
tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
$(PYTHON) tools/gyp_node.py -f make
config.gypi: configure configure.py
--
2.21.0