Update to 4.2.6 upstream release

This commit is contained in:
Tom Hughes 2016-02-09 07:19:24 +00:00
parent 3b104874f3
commit b68d4ecbf7
5 changed files with 16 additions and 24 deletions

1
.gitignore vendored
View File

@ -35,3 +35,4 @@
/node-v4.2.2-stripped.tar.gz
/node-v4.2.3-stripped.tar.gz
/node-v4.2.4-stripped.tar.gz
/node-v4.2.6-stripped.tar.gz

View File

@ -1,4 +1,4 @@
From e23b2803b886fb6d001ebcc70aa29713561f316f Mon Sep 17 00:00:00 2001
From 8a53e16138f7fa4371eebde91d3bf216285e75a0 Mon Sep 17 00:00:00 2001
From: Stephen Gallagher <sgallagh@redhat.com>
Date: Tue, 1 Dec 2015 16:35:29 -0500
Subject: [PATCH 1/2] disable running gyp files for bundled deps
@ -8,12 +8,10 @@ Subject: [PATCH 1/2] disable running gyp files for bundled deps
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 02619fac98ddd7bd90648f6493ccf49fcf22c47b..981c3ce4daa8724547979d7646117182399b22db 100644
index 94eb419..a2b682b 100644
--- a/Makefile
+++ b/Makefile
@@ -47,11 +47,11 @@ $(NODE_EXE): config.gypi out/Makefile
$(NODE_G_EXE): config.gypi out/Makefile
@@ -49,7 +49,7 @@ $(NODE_G_EXE): config.gypi out/Makefile
$(MAKE) -C out BUILDTYPE=Debug V=$(V)
ln -fs out/Debug/$(NODE_EXE) $@
@ -22,8 +20,6 @@ index 02619fac98ddd7bd90648f6493ccf49fcf22c47b..981c3ce4daa8724547979d7646117182
$(PYTHON) tools/gyp_node.py -f make
config.gypi: configure
if [ -f $@ ]; then
$(error Stale $@, please re-run ./configure)
--
2.7.0
2.5.0

View File

@ -1,4 +1,4 @@
From 515a1619d3b13a7af52d58dee9a43b981e45c2bb Mon Sep 17 00:00:00 2001
From 58c110a74377171587a6ef28a6d5dff1f29a7d52 Mon Sep 17 00:00:00 2001
From: Stephen Gallagher <sgallagh@redhat.com>
Date: Tue, 1 Dec 2015 16:29:07 -0500
Subject: [PATCH 2/2] Do not bundle CA Certificates
@ -22,12 +22,10 @@ Node.js 4.2
1 file changed, 8 insertions(+), 23 deletions(-)
diff --git a/src/node_crypto.cc b/src/node_crypto.cc
index b03e6444ff8a3b4209d1e7806380e80566da243c..331c155aebfa0a42277dbe48e03a0b866b98bd06 100644
index 7911ce9..60516ad 100644
--- a/src/node_crypto.cc
+++ b/src/node_crypto.cc
@@ -125,11 +125,11 @@ struct ClearErrorOnReturn {
};
@@ -119,7 +119,7 @@ static X509_NAME *cnnic_ev_name =
static uv_mutex_t* locks;
const char* const root_certs[] = {
@ -36,11 +34,7 @@ index b03e6444ff8a3b4209d1e7806380e80566da243c..331c155aebfa0a42277dbe48e03a0b86
};
X509_STORE* root_cert_store;
// Just to generate static methods
@@ -704,36 +704,21 @@ void SecureContext::AddRootCerts(const FunctionCallbackInfo<Value>& args) {
(void) &clear_error_on_return; // Silence compiler warning.
@@ -763,32 +763,17 @@ void SecureContext::AddRootCerts(const FunctionCallbackInfo<Value>& args) {
CHECK_EQ(sc->ca_store_, nullptr);
if (!root_cert_store) {
@ -80,8 +74,6 @@ index b03e6444ff8a3b4209d1e7806380e80566da243c..331c155aebfa0a42277dbe48e03a0b86
}
void SecureContext::SetCiphers(const FunctionCallbackInfo<Value>& args) {
SecureContext* sc = Unwrap<SecureContext>(args.Holder());
--
2.7.0
2.5.0

View File

@ -7,8 +7,8 @@
%endif
Name: nodejs
Version: 4.2.4
Release: 5%{?dist}
Version: 4.2.6
Release: 1%{?dist}
Summary: JavaScript runtime
License: MIT and ASL 2.0 and ISC and BSD
Group: Development/Languages
@ -217,6 +217,9 @@ mv %{buildroot}/%{_datadir}/doc/node/gdbinit %{buildroot}/%{_pkgdocdir}/gdbinit
%{_pkgdocdir}/html
%changelog
* Tue Feb 9 2016 Tom Hughes <tom@compton.nu> - 4.2.6-1
- Update to 4.2.6 upstream release
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.4-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

View File

@ -1 +1 @@
12d2042dd79c39c5365e36d55527542e node-v4.2.4-stripped.tar.gz
23a29533052de7204adba545ab64928f node-v4.2.6-stripped.tar.gz