Update to 16.1.0

- Update to 16.1.0
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.1.0
- Drop upstreamed patch

Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
Stephen Gallagher 2021-05-04 17:10:37 -04:00
parent 3ef3ddba23
commit 9f9d592a89
No known key found for this signature in database
GPG Key ID: 45DB85A568286D11
5 changed files with 16 additions and 60 deletions

View File

@ -1,14 +1,14 @@
From 3e85ce30203fd13ac663680f0103b2a66c864685 Mon Sep 17 00:00:00 2001
From 3aebb3eb39fd81c1355dffef8617a5028bc3f622 Mon Sep 17 00:00:00 2001
From: Zuzana Svetlikova <zsvetlik@redhat.com>
Date: Fri, 17 Apr 2020 12:59:44 +0200
Subject: [PATCH 1/3] Disable running gyp on shared deps
Subject: [PATCH 1/2] Disable running gyp on shared deps
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 26746d94f4ab8c2580bc3304b293f37c273cd8f5..11dd97805dae7c6fb8485bffc42e104a9624ba13 100644
index 50d6795bc349035ae6b46363e6a05fed59dd2cf9..ddf127a0c5d990e08a2d3dfe78d1d611ed51f657 100644
--- a/Makefile
+++ b/Makefile
@@ -137,11 +137,11 @@ endif

View File

@ -1,7 +1,7 @@
From d5009b7659e101c76f782003e184ba72bce4686b Mon Sep 17 00:00:00 2001
From efd1e3e6e56c3874c7c5b19434223d094d598254 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Tue, 19 Mar 2019 23:22:40 -0400
Subject: [PATCH 2/3] Install both binaries and use libdir.
Subject: [PATCH 2/2] Install both binaries and use libdir.
This allows us to build with a shared library for other users while
still providing the normal executable.

View File

@ -1,45 +0,0 @@
From 7f1be47c1bcd021c5b28a468d443dd49bae705c4 Mon Sep 17 00:00:00 2001
From: James Addison <jay@jp-hosting.net>
Date: Tue, 9 Mar 2021 13:08:47 +0000
Subject: [PATCH 3/3] src: add .note.GNU-stack section
This indicates to GNU binutils that it can unset the executable stack
flag on the binary that it is building.
PR-URL: https://github.com/nodejs/node/pull/37688
Refs: https://github.com/nodejs/node/issues/17933
Reviewed-By: Daniel Bevenius <daniel.bevenius@gmail.com>
src: Use %progbits instead of @progbits
While @progbits is preferred for most architectures, there are some
(notably 32-bit ARM) for which it does not. %progbits is effective
everywhere.
See https://bugzilla.redhat.com/show_bug.cgi?id=1950528 for more
details.
Related: https://github.com/nodejs/node/issues/17933
Related: https://github.com/nodejs/node/pull/37688
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
---
src/large_pages/node_text_start.S | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/large_pages/node_text_start.S b/src/large_pages/node_text_start.S
index 3227b62464932ced6d42916a4300ddbd9b4a4fbb..d27dd39cc236f0e6be4e68113bfff7b531a37455 100644
--- a/src/large_pages/node_text_start.S
+++ b/src/large_pages/node_text_start.S
@@ -1,7 +1,7 @@
#if defined(__ELF__)
-.section .note.GNU-stack,"",@progbits
+.section .note.GNU-stack,"",%progbits
#endif
.text
.align 0x2000
.global __node_text_start
.hidden __node_text_start
--
2.31.1

View File

@ -19,7 +19,7 @@
# than a Fedora release lifecycle.
%global nodejs_epoch 1
%global nodejs_major 16
%global nodejs_minor 0
%global nodejs_minor 1
%global nodejs_patch 0
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
@ -36,7 +36,7 @@
%global v8_major 9
%global v8_minor 0
%global v8_build 257
%global v8_patch 17
%global v8_patch 24
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
%global v8_abi %{v8_major}.%{v8_minor}
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
@ -52,7 +52,7 @@
# llhttp - from deps/llhttp/include/llhttp.h
%global llhttp_major 6
%global llhttp_minor 0
%global llhttp_patch 0
%global llhttp_patch 1
%global llhttp_version %{llhttp_major}.%{llhttp_minor}.%{llhttp_patch}
# libuv - from deps/uv/include/uv/version.h
@ -91,8 +91,8 @@
# npm - from deps/npm/package.json
%global npm_epoch 1
%global npm_major 7
%global npm_minor 10
%global npm_patch 0
%global npm_minor 11
%global npm_patch 2
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
# uvwasi - from deps/uvwasi/include/uvwasi.h
@ -145,10 +145,6 @@ Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
# Patch to install both node and libnode.so, using the correct libdir
Patch2: 0002-Install-both-binaries-and-use-libdir.patch
# Patch to disable stack execution. Merged from one upstream patch and
# one upstream proposed patch
Patch3: 0003-src-add-.note.GNU-stack-section.patch
BuildRequires: make
BuildRequires: python3-devel
BuildRequires: python3-setuptools
@ -666,6 +662,11 @@ end
%changelog
* Tue May 04 2021 Stephen Gallagher <sgallagh@redhat.com> - 16.1.0-1
- Update to 16.1.0
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.1.0
- Drop upstreamed patch
* Thu Apr 29 2021 Stephen Gallagher <sgallagh@redhat.com> - 16.0.0-1
- First release of Node.js 16.x

View File

@ -1,2 +1,2 @@
SHA512 (node-v16.0.0-stripped.tar.gz) = 45afd2b674a061f9a11ae270015910b16b79d6702a53d8947d7c4c384e024ac381ed386c4ffef3f19a7ff1b760e45f2caf4d4df41ca05b409ad2a5bae46da49b
SHA512 (node-v16.1.0-stripped.tar.gz) = 2c4e73af9e056f0bd106762c67d019d36b132707a37a673e0a9a9d6fe3188418c647e2dff8851981d9f0a8eca94adc8ff69e561f6cbff4302fc5260c157155fd
SHA512 (icu4c-69_1-src.tgz) = d4aeb781715144ea6e3c6b98df5bbe0490bfa3175221a1d667f3e6851b7bd4a638fa4a37d4a921ccb31f02b5d15a6dded9464d98051964a86f7b1cde0ff0aab7