Merge branch '10' into 11
This commit is contained in:
commit
8c0820b716
@ -1,17 +1,17 @@
|
||||
From def28d29f907050d8bcd94ed2e341d128ffa3fa6 Mon Sep 17 00:00:00 2001
|
||||
From e4d1665c49d00d19be0650f92b98308f3ed251d1 Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
||||
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
||||
Subject: [PATCH 1/3] Disable running gyp on shared deps
|
||||
|
||||
---
|
||||
Makefile | 7 +++----
|
||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 5fc2bb0c58f5532044a14e9f9595b2316f562726..f1c1545caa220d7442d6d92c49412ec7554de123 100644
|
||||
index 3d8ef4dc5764bba4d6ed5bad3cc03a2045c3be86..bb75e85c345662ab5285f6f00be725f33c06cbf5 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -121,14 +121,13 @@ with-code-cache:
|
||||
@@ -122,14 +122,13 @@ with-code-cache:
|
||||
|
||||
.PHONY: test-code-cache
|
||||
test-code-cache: with-code-cache
|
||||
@ -30,5 +30,5 @@ index 5fc2bb0c58f5532044a14e9f9595b2316f562726..f1c1545caa220d7442d6d92c49412ec7
|
||||
@if [ -x config.status ]; then \
|
||||
./config.status; \
|
||||
--
|
||||
2.19.0
|
||||
2.21.0
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
From ab6c18fd9aba942bee3f2f8030273c846b6025a6 Mon Sep 17 00:00:00 2001
|
||||
From aa203e18cd0a5398e5b7e1900ba71a0816c1fd3d Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Tue, 1 May 2018 08:05:30 -0400
|
||||
Subject: [PATCH 2/2] Suppress NPM message to run global update
|
||||
Subject: [PATCH 2/3] Suppress NPM message to run global update
|
||||
|
||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||
---
|
||||
@ -83,5 +83,5 @@ index 6f76b23828531e7af98a7e3cd7d5abfaac09b40c..98edb6f45fe073e03794a2ae6e7aa7f5
|
||||
!err &&
|
||||
npm.config.get('ham-it-up') &&
|
||||
--
|
||||
2.19.0
|
||||
2.21.0
|
||||
|
||||
|
98
0003-Install-both-binaries-and-use-libdir.patch
Normal file
98
0003-Install-both-binaries-and-use-libdir.patch
Normal file
@ -0,0 +1,98 @@
|
||||
From bf276a108cf7710220c3ed2a8bd0685478703c9b Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||
Subject: [PATCH 3/3] Install both binaries and use libdir.
|
||||
|
||||
This allows us to build with a shared library for other users while
|
||||
still providing the normal executable.
|
||||
|
||||
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
---
|
||||
configure.py | 7 +++++++
|
||||
tools/install.py | 29 +++++++++++++----------------
|
||||
2 files changed, 20 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/configure.py b/configure.py
|
||||
index 9f780ab9bca150df7a635af00c2976c1fb8156a7..f1f2b129466334436747c3e7f95b7bb6dc245253 100755
|
||||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -560,10 +560,16 @@ parser.add_option('--shared',
|
||||
action='store_true',
|
||||
dest='shared',
|
||||
help='compile shared library for embedding node in another project. ' +
|
||||
'(This mode is not officially supported for regular applications)')
|
||||
|
||||
+parser.add_option('--libdir',
|
||||
+ action='store',
|
||||
+ dest='libdir',
|
||||
+ default='lib',
|
||||
+ help='a directory to install the shared library into')
|
||||
+
|
||||
parser.add_option('--without-v8-platform',
|
||||
action='store_true',
|
||||
dest='without_v8_platform',
|
||||
default=False,
|
||||
help='do not initialize v8 platform during node.js startup. ' +
|
||||
@@ -1106,10 +1112,11 @@ def configure_node(o):
|
||||
|
||||
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
||||
if options.code_cache_path:
|
||||
o['variables']['node_code_cache_path'] = options.code_cache_path
|
||||
o['variables']['node_shared'] = b(options.shared)
|
||||
+ o['variables']['libdir'] = options.libdir
|
||||
node_module_version = getmoduleversion.get_version()
|
||||
|
||||
if sys.platform == 'darwin':
|
||||
shlib_suffix = '%s.dylib'
|
||||
elif sys.platform.startswith('aix'):
|
||||
diff --git a/tools/install.py b/tools/install.py
|
||||
index 3befec213b1ce68b234f0a2602a8acd302fd8422..e7a6c67c3a72ee7745ba45049552a4e8feee5a61 100755
|
||||
--- a/tools/install.py
|
||||
+++ b/tools/install.py
|
||||
@@ -120,30 +120,27 @@ def subdir_files(path, dest, action):
|
||||
for subdir, files in ret.items():
|
||||
action(files, subdir + '/')
|
||||
|
||||
def files(action):
|
||||
is_windows = sys.platform == 'win32'
|
||||
- output_file = 'node'
|
||||
output_prefix = 'out/Release/'
|
||||
+ output_libprefix = output_prefix
|
||||
|
||||
- if 'false' == variables.get('node_shared'):
|
||||
- if is_windows:
|
||||
- output_file += '.exe'
|
||||
+ if is_windows:
|
||||
+ output_bin = 'node.exe'
|
||||
+ output_lib = 'node.dll'
|
||||
else:
|
||||
- if is_windows:
|
||||
- output_file += '.dll'
|
||||
- else:
|
||||
- output_file = 'lib' + output_file + '.' + variables.get('shlib_suffix')
|
||||
- # GYP will output to lib.target except on OS X, this is hardcoded
|
||||
- # in its source - see the _InstallableTargetInstallPath function.
|
||||
- if sys.platform != 'darwin':
|
||||
- output_prefix += 'lib.target/'
|
||||
+ output_bin = 'node'
|
||||
+ output_lib = 'libnode.' + variables.get('shlib_suffix')
|
||||
+ # GYP will output to lib.target except on OS X, this is hardcoded
|
||||
+ # in its source - see the _InstallableTargetInstallPath function.
|
||||
+ if sys.platform != 'darwin':
|
||||
+ output_libprefix += 'lib.target/'
|
||||
|
||||
- if 'false' == variables.get('node_shared'):
|
||||
- action([output_prefix + output_file], 'bin/' + output_file)
|
||||
- else:
|
||||
- action([output_prefix + output_file], 'lib/' + output_file)
|
||||
+ action([output_prefix + output_bin], 'bin/' + output_bin)
|
||||
+ if 'true' == variables.get('node_shared'):
|
||||
+ action([output_libprefix + output_lib], variables.get('libdir') + '/' + output_lib)
|
||||
|
||||
if 'true' == variables.get('node_use_dtrace'):
|
||||
action(['out/Release/node.d'], 'lib/dtrace/node.d')
|
||||
|
||||
# behave similarly for systemtap
|
||||
--
|
||||
2.21.0
|
||||
|
@ -1,128 +0,0 @@
|
||||
From cefa0fd937cb48a8431e62268b2c9500b104d4e5 Mon Sep 17 00:00:00 2001
|
||||
From: Junliang Yan <jyan@ca.ibm.com>
|
||||
Date: Wed, 9 May 2018 18:39:49 -0400
|
||||
Subject: [PATCH 3/4] [PATCH] PPC: use pc-relative address to init constpool
|
||||
reg
|
||||
|
||||
R=joransiu@ca.ibm.com
|
||||
|
||||
Change-Id: I67364f29d494b09786a14b13743f73bef4b64582
|
||||
Reviewed-on: https://chromium-review.googlesource.com/950242
|
||||
Commit-Queue: Junliang Yan <jyan@ca.ibm.com>
|
||||
Reviewed-by: Joran Siu <joransiu@ca.ibm.com>
|
||||
Cr-Commit-Position: refs/heads/master@{#51750}
|
||||
|
||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||
---
|
||||
deps/v8/src/ppc/macro-assembler-ppc.cc | 14 ++++++++++----
|
||||
deps/v8/src/ppc/macro-assembler-ppc.h | 9 +++++----
|
||||
2 files changed, 15 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/deps/v8/src/ppc/macro-assembler-ppc.cc b/deps/v8/src/ppc/macro-assembler-ppc.cc
|
||||
index 68efa84c72c7f6d781d508183b53ea83024944d1..3192e9cefb1c1b116c5e12b5c52e7971b92a111a 100644
|
||||
--- a/deps/v8/src/ppc/macro-assembler-ppc.cc
|
||||
+++ b/deps/v8/src/ppc/macro-assembler-ppc.cc
|
||||
@@ -166,11 +166,11 @@ void TurboAssembler::Call(Register target) {
|
||||
|
||||
DCHECK_EQ(CallSize(target), SizeOfCodeGeneratedSince(&start));
|
||||
}
|
||||
|
||||
void MacroAssembler::CallJSEntry(Register target) {
|
||||
- DCHECK(target == ip);
|
||||
+ CHECK(target == r5);
|
||||
Call(target);
|
||||
}
|
||||
|
||||
int TurboAssembler::CallSize(Address target, RelocInfo::Mode rmode,
|
||||
Condition cond) {
|
||||
@@ -823,20 +823,27 @@ void TurboAssembler::ShiftRightAlgPair(Register dst_low, Register dst_high,
|
||||
srawi(dst_high, src_high, shift);
|
||||
}
|
||||
}
|
||||
#endif
|
||||
|
||||
-void MacroAssembler::LoadConstantPoolPointerRegisterFromCodeTargetAddress(
|
||||
+void TurboAssembler::LoadConstantPoolPointerRegisterFromCodeTargetAddress(
|
||||
Register code_target_address) {
|
||||
lwz(kConstantPoolRegister,
|
||||
MemOperand(code_target_address,
|
||||
Code::kConstantPoolOffset - Code::kHeaderSize));
|
||||
add(kConstantPoolRegister, kConstantPoolRegister, code_target_address);
|
||||
}
|
||||
|
||||
+void TurboAssembler::LoadPC(Register dst) {
|
||||
+ b(4, SetLK);
|
||||
+ mflr(dst);
|
||||
+}
|
||||
+
|
||||
void TurboAssembler::LoadConstantPoolPointerRegister() {
|
||||
- mov_label_addr(kConstantPoolRegister, ConstantPoolPosition());
|
||||
+ LoadPC(kConstantPoolRegister);
|
||||
+ add_label_offset(kConstantPoolRegister, kConstantPoolRegister,
|
||||
+ ConstantPoolPosition(), -pc_offset() + 4);
|
||||
}
|
||||
|
||||
void TurboAssembler::StubPrologue(StackFrame::Type type) {
|
||||
{
|
||||
ConstantPoolUnavailableScope constant_pool_unavailable(this);
|
||||
@@ -848,11 +855,10 @@ void TurboAssembler::StubPrologue(StackFrame::Type type) {
|
||||
set_constant_pool_available(true);
|
||||
}
|
||||
}
|
||||
|
||||
void TurboAssembler::Prologue() {
|
||||
- DCHECK(base != no_reg);
|
||||
PushStandardFrame(r4);
|
||||
if (FLAG_enable_embedded_constant_pool) {
|
||||
// base contains prologue address
|
||||
LoadConstantPoolPointerRegister();
|
||||
set_constant_pool_available(true);
|
||||
diff --git a/deps/v8/src/ppc/macro-assembler-ppc.h b/deps/v8/src/ppc/macro-assembler-ppc.h
|
||||
index f4d9afd47f150f9cd2e840c20a61e965a5d8f5f5..32e6219c41bbbfe8427e05f2f9a02ff800efcffb 100644
|
||||
--- a/deps/v8/src/ppc/macro-assembler-ppc.h
|
||||
+++ b/deps/v8/src/ppc/macro-assembler-ppc.h
|
||||
@@ -214,10 +214,11 @@ class TurboAssembler : public Assembler {
|
||||
|
||||
void LoadSingle(DoubleRegister dst, const MemOperand& mem,
|
||||
Register scratch = no_reg);
|
||||
void LoadSingleU(DoubleRegister dst, const MemOperand& mem,
|
||||
Register scratch = no_reg);
|
||||
+ void LoadPC(Register dst);
|
||||
|
||||
void StoreDouble(DoubleRegister src, const MemOperand& mem,
|
||||
Register scratch = no_reg);
|
||||
void StoreDoubleU(DoubleRegister src, const MemOperand& mem,
|
||||
Register scratch = no_reg);
|
||||
@@ -639,10 +640,14 @@ class TurboAssembler : public Assembler {
|
||||
|
||||
// Call a code stub.
|
||||
void CallStubDelayed(CodeStub* stub);
|
||||
|
||||
void LoadConstantPoolPointerRegister();
|
||||
+
|
||||
+ // Loads the constant pool pointer (kConstantPoolRegister).
|
||||
+ void LoadConstantPoolPointerRegisterFromCodeTargetAddress(
|
||||
+ Register code_target_address);
|
||||
void AbortConstantPoolBuilding() {
|
||||
#ifdef DEBUG
|
||||
// Avoid DCHECK(!is_linked()) failure in ~Label()
|
||||
bind(ConstantPoolPosition());
|
||||
#endif
|
||||
@@ -733,14 +738,10 @@ class MacroAssembler : public TurboAssembler {
|
||||
// Push and pop the registers that can hold pointers, as defined by the
|
||||
// RegList constant kSafepointSavedRegisters.
|
||||
void PushSafepointRegisters();
|
||||
void PopSafepointRegisters();
|
||||
|
||||
- // Loads the constant pool pointer (kConstantPoolRegister).
|
||||
- void LoadConstantPoolPointerRegisterFromCodeTargetAddress(
|
||||
- Register code_target_address);
|
||||
-
|
||||
// Flush the I-cache from asm code. You should use CpuFeatures::FlushICache
|
||||
// from C.
|
||||
// Does not handle errors.
|
||||
void FlushICache(Register address, size_t size, Register scratch);
|
||||
|
||||
--
|
||||
2.17.0
|
||||
|
126
nodejs.spec
126
nodejs.spec
@ -1,5 +1,3 @@
|
||||
%global with_debug 1
|
||||
|
||||
# bundle dependencies that are not available as Fedora modules
|
||||
# %%{!?_with_bootstrap: %%global bootstrap 1}
|
||||
# use bcond for building modules
|
||||
@ -14,14 +12,17 @@
|
||||
# than a Fedora release lifecycle.
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 11
|
||||
%global nodejs_minor 13
|
||||
%global nodejs_minor 14
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
%global nodejs_soversion 64
|
||||
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
||||
%global nodejs_release 1
|
||||
|
||||
# == Bundled Dependency Versions ==
|
||||
# v8 - from deps/v8/include/v8-version.h
|
||||
# Epoch is set to ensure clean upgrades from the old v8 package
|
||||
%global v8_epoch 1
|
||||
%global v8_major 7
|
||||
%global v8_minor 0
|
||||
%global v8_build 276
|
||||
@ -43,6 +44,12 @@
|
||||
%global http_parser_patch 0
|
||||
%global http_parser_version %{http_parser_major}.%{http_parser_minor}.%{http_parser_patch}
|
||||
|
||||
# llhttp - from deps/llhttp/include/llhttp.h
|
||||
%global llhttp_major 1
|
||||
%global llhttp_minor 1
|
||||
%global llhttp_patch 0
|
||||
%global llhttp_version %{llhttp_major}.%{llhttp_minor}.%{llhttp_patch}
|
||||
|
||||
# libuv - from deps/uv/include/uv/version.h
|
||||
%global libuv_major 1
|
||||
%global libuv_minor 27
|
||||
@ -117,11 +124,15 @@ Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
|
||||
# This does bad things on an RPM-managed npm.
|
||||
Patch2: 0002-Suppress-NPM-message-to-run-global-update.patch
|
||||
|
||||
# Patch to install both node and libnode.so, using the correct libdir
|
||||
Patch3: 0003-Install-both-binaries-and-use-libdir.patch
|
||||
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: gcc >= 4.9.4
|
||||
BuildRequires: gcc-c++ >= 4.9.4
|
||||
BuildRequires: chrpath
|
||||
|
||||
#%if ! 0%%{?bootstrap}
|
||||
%if %{with bootstrap}
|
||||
@ -131,12 +142,19 @@ Provides: bundled(nghttp2) = %{nghttp2_version}
|
||||
%else
|
||||
BuildRequires: nodejs-packaging
|
||||
BuildRequires: systemtap-sdt-devel
|
||||
BuildRequires: http-parser-devel >= 2.7.0
|
||||
Requires: http-parser >= 2.7.0
|
||||
BuildRequires: http-parser-devel >= 2.9.0
|
||||
Requires: http-parser >= 2.9.0
|
||||
BuildRequires: libuv-devel >= 1:%{libuv_version}
|
||||
Requires: libuv >= 1:%{libuv_version}
|
||||
BuildRequires: libnghttp2-devel >= %{nghttp2_version}
|
||||
Requires: libnghttp2 >= %{nghttp2_version}
|
||||
|
||||
# Temporarily bundle http-parser and llhttp because the latter
|
||||
# isn't packaged yet and they are controlled by the same
|
||||
# configure flag.
|
||||
Provides: bundled(http-parser) = %{http_parser_version}
|
||||
Provides: bundled(llhttp) = %{llhttp_version}
|
||||
|
||||
%endif
|
||||
|
||||
|
||||
@ -149,6 +167,9 @@ BuildRequires: openssl-devel
|
||||
# we need the system certificate store
|
||||
Requires: ca-certificates
|
||||
|
||||
Requires: nodejs-libs%{?_isa} = %{epoch}:%{nodejs_version}-%{nodejs_release}%{?dist}
|
||||
|
||||
|
||||
#we need ABI virtual provides where SONAMEs aren't enough/not present so deps
|
||||
#break when binary compatibility is broken
|
||||
Provides: nodejs(abi) = %{nodejs_abi}
|
||||
@ -229,6 +250,36 @@ Requires: libuv-devel%{?_isa}
|
||||
%description devel
|
||||
Development headers for the Node.js JavaScript runtime.
|
||||
|
||||
%package libs
|
||||
Summary: Node.js and v8 libraries
|
||||
|
||||
# Compatibility for obsolete v8 package
|
||||
%if 0%{?__isa_bits} == 64
|
||||
Provides: libv8.so.%{v8_major}()(64bit)
|
||||
Provides: libv8_libbase.so.%{v8_major}()(64bit)
|
||||
Provides: libv8_libplatform.so.%{v8_major}()(64bit)
|
||||
%else # 32-bits
|
||||
Provides: libv8.so.%{v8_major}
|
||||
Provides: libv8_libbase.so.%{v8_major}
|
||||
Provides: libv8_libplatform.so.%{v8_major}
|
||||
%endif
|
||||
|
||||
Provides: v8 = %{v8_epoch}:%{v8_version}-%{nodejs_release}%{?dist}
|
||||
Provides: v8%{?_isa} = %{v8_epoch}:%{v8_version}-%{nodejs_release}%{?dist}
|
||||
Obsoletes: v8 < 1:6.7.17-10
|
||||
|
||||
%description libs
|
||||
Libraries to support Node.js and provide stable v8 interfaces.
|
||||
|
||||
%package -n v8-devel
|
||||
Summary: v8 - development headers
|
||||
Epoch: %{v8_epoch}
|
||||
Version: %{v8_version}
|
||||
Requires: %{name}-devel%{?_isa} = %{epoch}:%{nodejs_version}-%{nodejs_release}%{?dist}
|
||||
|
||||
%description -n v8-devel
|
||||
Development headers for the v8 runtime.
|
||||
|
||||
%package -n npm
|
||||
Summary: Node.js Package Manager
|
||||
Epoch: %{npm_epoch}
|
||||
@ -266,14 +317,11 @@ The API documentation for the Node.js JavaScript runtime.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n node-v%{nodejs_version}
|
||||
%autosetup -p1 -n node-v%{nodejs_version}
|
||||
|
||||
# remove bundled dependencies that we aren't building
|
||||
%patch1 -p1
|
||||
rm -rf deps/zlib
|
||||
|
||||
%patch2 -p1
|
||||
|
||||
# Replace any instances of unversioned python' with python2
|
||||
pathfix.py -i %{__python2} -pn $(find -type f)
|
||||
find . -type f -exec sed -i "s~/usr\/bin\/env python~/usr/bin/python2~" {} \;
|
||||
@ -309,6 +357,8 @@ export LDFLAGS="%{build_ldflags}"
|
||||
#%if ! 0%%{?bootstrap}
|
||||
%if %{with bootstrap}
|
||||
./configure --prefix=%{_prefix} \
|
||||
--shared \
|
||||
--libdir=%{_lib} \
|
||||
--shared-openssl \
|
||||
--shared-zlib \
|
||||
--without-dtrace \
|
||||
@ -317,10 +367,11 @@ export LDFLAGS="%{build_ldflags}"
|
||||
--openssl-use-def-ca-store
|
||||
%else
|
||||
./configure --prefix=%{_prefix} \
|
||||
--shared \
|
||||
--libdir=%{_lib} \
|
||||
--shared-openssl \
|
||||
--shared-zlib \
|
||||
--shared-libuv \
|
||||
--shared-http-parser \
|
||||
--shared-nghttp2 \
|
||||
--with-dtrace \
|
||||
--with-intl=%{icu_flag} \
|
||||
@ -328,12 +379,7 @@ export LDFLAGS="%{build_ldflags}"
|
||||
--openssl-use-def-ca-store
|
||||
%endif
|
||||
|
||||
%if %{?with_debug} == 1
|
||||
# Setting BUILDTYPE=Debug builds both release and debug binaries
|
||||
make BUILDTYPE=Debug %{?_smp_mflags}
|
||||
%else
|
||||
make BUILDTYPE=Release %{?_smp_mflags}
|
||||
%endif
|
||||
|
||||
|
||||
%install
|
||||
@ -343,11 +389,20 @@ rm -rf %{buildroot}
|
||||
|
||||
# Set the binary permissions properly
|
||||
chmod 0755 %{buildroot}/%{_bindir}/node
|
||||
chrpath --delete %{buildroot}%{_bindir}/node
|
||||
|
||||
%if %{?with_debug} == 1
|
||||
# Install the debug binary and set its permissions
|
||||
install -Dpm0755 out/Debug/node %{buildroot}/%{_bindir}/node_g
|
||||
%endif
|
||||
# Install library symlink
|
||||
ln -s %{_libdir}/libnode.so.%{nodejs_soversion} %{buildroot}%{_libdir}/libnode.so
|
||||
|
||||
# Install v8 compatibility symlinks
|
||||
for header in %{buildroot}%{_includedir}/node/libplatform %{buildroot}%{_includedir}/node/v8*.h; do
|
||||
header=$(basename ${header})
|
||||
ln -s %{_includedir}/node/${header} %{buildroot}%{_includedir}/${header}
|
||||
done
|
||||
for soname in libv8 libv8_libbase libv8_libplatform; do
|
||||
ln -s %{_libdir}/libnode.so.%{nodejs_soversion} %{buildroot}%{_libdir}/${soname}.so
|
||||
ln -s %{_libdir}/libnode.so.%{nodejs_soversion} %{buildroot}%{_libdir}/${soname}.so.%{v8_major}
|
||||
done
|
||||
|
||||
# own the sitelib directory
|
||||
mkdir -p %{buildroot}%{_prefix}/lib/node_modules
|
||||
@ -405,18 +460,22 @@ find %{buildroot}%{_prefix}/lib/node_modules/npm \
|
||||
-executable -type f \
|
||||
-exec chmod -x {} \;
|
||||
|
||||
# The above command is a little overzealous. Add a few permissions back.
|
||||
chmod 0755 %{buildroot}%{_prefix}/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin/node-gyp
|
||||
chmod 0755 %{buildroot}%{_prefix}/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js
|
||||
|
||||
|
||||
%check
|
||||
# Fail the build if the versions don't match
|
||||
%{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.node, '%{nodejs_version}')"
|
||||
%{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.v8.replace(/-node\.\d+$/, ''), '%{v8_version}')"
|
||||
%{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.ares.replace(/-DEV$/, ''), '%{c_ares_version}')"
|
||||
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.node, '%{nodejs_version}')"
|
||||
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.v8.replace(/-node\.\d+$/, ''), '%{v8_version}')"
|
||||
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.ares.replace(/-DEV$/, ''), '%{c_ares_version}')"
|
||||
|
||||
# Ensure we have punycode and that the version matches
|
||||
%{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"punycode\").version, '%{punycode_version}')"
|
||||
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"punycode\").version, '%{punycode_version}')"
|
||||
|
||||
# Ensure we have npm and that the version matches
|
||||
NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules:%{buildroot}%{_prefix}/lib/node_modules/npm/node_modules %{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"npm\").version, '%{npm_version}')"
|
||||
NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules:%{buildroot}%{_prefix}/lib/node_modules/npm/node_modules LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"npm\").version, '%{npm_version}')"
|
||||
|
||||
|
||||
%pretrans -n npm -p <lua>
|
||||
@ -458,14 +517,27 @@ end
|
||||
|
||||
|
||||
%files devel
|
||||
%if %{?with_debug} == 1
|
||||
%{_bindir}/node_g
|
||||
%endif
|
||||
%{_includedir}/node
|
||||
%{_libdir}/libnode.so
|
||||
%{_datadir}/node/common.gypi
|
||||
%{_pkgdocdir}/gdbinit
|
||||
|
||||
|
||||
%files libs
|
||||
%{_libdir}/libnode.so.%{nodejs_soversion}
|
||||
%{_libdir}/libv8.so.%{v8_major}
|
||||
%{_libdir}/libv8_libbase.so.%{v8_major}
|
||||
%{_libdir}/libv8_libplatform.so.%{v8_major}
|
||||
|
||||
|
||||
%files -n v8-devel
|
||||
%{_includedir}/libplatform
|
||||
%{_includedir}/v8*.h
|
||||
%{_libdir}/libv8.so
|
||||
%{_libdir}/libv8_libbase.so
|
||||
%{_libdir}/libv8_libplatform.so
|
||||
|
||||
|
||||
%files -n npm
|
||||
%{_bindir}/npm
|
||||
%{_bindir}/npx
|
||||
|
@ -1,2 +1,2 @@
|
||||
[koji]
|
||||
targets = master f29
|
||||
targets = master f30 f29
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (node-v11.13.0-stripped.tar.gz) = e64caa043c324612c96f7b6c20876474d4f3bea6fcc0838bdd7aaa9d514b12506605312b3391fa79caba2bbf297c10bfa2f46fbde2399cd025d745f745c328c2
|
||||
SHA512 (node-v11.14.0-stripped.tar.gz) = a54c5b885fdbff8de7233f2d88667a0638676fb3461cc99e50e5a022170233f10c6a55cd86e4321fd143f48654dcceca924807aed574558e47e4c821780755f2
|
||||
|
Loading…
Reference in New Issue
Block a user