Update to 10.10.0
- https://nodejs.org/en/blog/release/v10.10.0/ - Fix issue with npm permissions Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
8392e14d23
commit
54ae556d2b
1
.gitignore
vendored
1
.gitignore
vendored
@ -104,3 +104,4 @@
|
||||
/node-v10.7.0-stripped.tar.gz
|
||||
/node-v10.8.0-stripped.tar.gz
|
||||
/node-v10.9.0-stripped.tar.gz
|
||||
/node-v10.10.0-stripped.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 3775a1669913db89c042859fd87c349fb5459e55 Mon Sep 17 00:00:00 2001
|
||||
From dc60fa79586e5e8681f019e80080aebc227d0c03 Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
||||
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
||||
@ -8,10 +8,10 @@ Subject: [PATCH 1/2] Disable running gyp on shared deps
|
||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 231948c15b95bdcdf5cbe2ada9dcb54207cde1cc..ce48995b92feb55d2c307296f3899937d60b16ae 100644
|
||||
index 7f9a57804b77606a3bec03f6be707969d71d3562..dd68e1ba2d3928f46c5d1f8991ded98bc1465323 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -109,14 +109,13 @@ with-code-cache:
|
||||
@@ -121,14 +121,13 @@ with-code-cache:
|
||||
|
||||
.PHONY: test-code-cache
|
||||
test-code-cache: with-code-cache
|
||||
@ -30,5 +30,5 @@ index 231948c15b95bdcdf5cbe2ada9dcb54207cde1cc..ce48995b92feb55d2c307296f3899937
|
||||
@if [ -x config.status ]; then \
|
||||
./config.status; \
|
||||
--
|
||||
2.18.0
|
||||
2.19.0.rc1
|
||||
|
||||
|
@ -1,32 +1,42 @@
|
||||
From 5fa6ec054f98e7e2e480feab792d51ff4100f1d9 Mon Sep 17 00:00:00 2001
|
||||
From 6fa6df3e7ec585d1bf1386dcf29f608a039bbbe9 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Tue, 1 May 2018 08:05:30 -0400
|
||||
Subject: [PATCH 2/2] Suppress NPM message to run global update
|
||||
|
||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||
---
|
||||
deps/npm/bin/npm-cli.js | 49 -----------------------------------------
|
||||
1 file changed, 49 deletions(-)
|
||||
deps/npm/bin/npm-cli.js | 54 -----------------------------------------
|
||||
1 file changed, 54 deletions(-)
|
||||
|
||||
diff --git a/deps/npm/bin/npm-cli.js b/deps/npm/bin/npm-cli.js
|
||||
index a38009d276e3bb7cb26e9536b62596c336ff8fb5..98edb6f45fe073e03794a2ae6e7aa7f5500723ee 100755
|
||||
index 6f76b23828531e7af98a7e3cd7d5abfaac09b40c..98edb6f45fe073e03794a2ae6e7aa7f5500723ee 100755
|
||||
--- a/deps/npm/bin/npm-cli.js
|
||||
+++ b/deps/npm/bin/npm-cli.js
|
||||
@@ -72,59 +72,10 @@
|
||||
@@ -67,69 +67,15 @@
|
||||
if (conf.usage && npm.command !== 'help') {
|
||||
npm.argv.unshift(npm.command)
|
||||
npm.command = 'help'
|
||||
}
|
||||
|
||||
- var isGlobalNpmUpdate = conf.global && ['install', 'update'].includes(npm.command) && npm.argv.includes('npm')
|
||||
-
|
||||
// now actually fire up npm and run the command.
|
||||
// this is how to use npm programmatically:
|
||||
conf._exit = true
|
||||
npm.load(conf, function (er) {
|
||||
if (er) return errorHandler(er)
|
||||
- if (
|
||||
- !isGlobalNpmUpdate &&
|
||||
- npm.config.get('update-notifier') &&
|
||||
- !unsupported.checkVersion(process.version).unsupported
|
||||
- ) {
|
||||
- const pkg = require('../package.json')
|
||||
- let notifier = require('update-notifier')({pkg})
|
||||
- const isCI = require('ci-info').isCI
|
||||
- if (
|
||||
- notifier.update &&
|
||||
- notifier.update.latest !== pkg.version
|
||||
- notifier.update.latest !== pkg.version &&
|
||||
- !isCI
|
||||
- ) {
|
||||
- const color = require('ansicolors')
|
||||
- const useColor = npm.config.get('color')
|
||||
@ -73,5 +83,5 @@ index a38009d276e3bb7cb26e9536b62596c336ff8fb5..98edb6f45fe073e03794a2ae6e7aa7f5
|
||||
!err &&
|
||||
npm.config.get('ham-it-up') &&
|
||||
--
|
||||
2.18.0
|
||||
2.19.0.rc1
|
||||
|
||||
|
24
nodejs.spec
24
nodejs.spec
@ -20,18 +20,18 @@
|
||||
# than a Fedora release lifecycle.
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 10
|
||||
%global nodejs_minor 9
|
||||
%global nodejs_minor 10
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
||||
%global nodejs_release 2
|
||||
%global nodejs_release 1
|
||||
|
||||
# == Bundled Dependency Versions ==
|
||||
# v8 - from deps/v8/include/v8-version.h
|
||||
%global v8_major 6
|
||||
%global v8_minor 8
|
||||
%global v8_build 275
|
||||
%global v8_patch 24
|
||||
%global v8_patch 30
|
||||
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
||||
%global v8_abi %{v8_major}.%{v8_minor}
|
||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||
@ -51,13 +51,13 @@
|
||||
|
||||
# libuv - from deps/uv/include/uv/version.h
|
||||
%global libuv_major 1
|
||||
%global libuv_minor 22
|
||||
%global libuv_minor 23
|
||||
%global libuv_patch 0
|
||||
%global libuv_version %{libuv_major}.%{libuv_minor}.%{libuv_patch}
|
||||
|
||||
# nghttp2 - from deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
|
||||
%global nghttp2_major 1
|
||||
%global nghttp2_minor 32
|
||||
%global nghttp2_minor 33
|
||||
%global nghttp2_patch 0
|
||||
%global nghttp2_version %{nghttp2_major}.%{nghttp2_minor}.%{nghttp2_patch}
|
||||
|
||||
@ -84,8 +84,8 @@
|
||||
# npm - from deps/npm/package.json
|
||||
%global npm_epoch 1
|
||||
%global npm_major 6
|
||||
%global npm_minor 2
|
||||
%global npm_patch 0
|
||||
%global npm_minor 4
|
||||
%global npm_patch 1
|
||||
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
||||
|
||||
# In order to avoid needing to keep incrementing the release version for the
|
||||
@ -405,7 +405,10 @@ rm -f %{buildroot}/%{_defaultdocdir}/node/lldb_commands.py \
|
||||
|
||||
# Some NPM bundled deps are executable but should not be. This causes
|
||||
# unnecessary automatic dependencies to be added. Make them not executable.
|
||||
find %{buildroot}%{_prefix}/lib/node_modules/npm -type f -executable -exec chmod -x {} \;
|
||||
# Skip the npm bin directory or the npm binary will not work.
|
||||
find %{buildroot}%{_prefix}/lib/node_modules/npm \
|
||||
-path bin -o -prune \
|
||||
-type f -executable -exec chmod -x {} \;
|
||||
|
||||
|
||||
%check
|
||||
@ -489,6 +492,11 @@ end
|
||||
%{_pkgdocdir}/npm/doc
|
||||
|
||||
%changelog
|
||||
* Tue Sep 11 2018 Stephen Gallagher <sgallagh@redhat.com> - 1:10.10.0-1
|
||||
- Update to 10.10.0
|
||||
- https://nodejs.org/en/blog/release/v10.10.0/
|
||||
- Fix issue with npm permissions
|
||||
|
||||
* Tue Aug 21 2018 Stephen Gallagher <sgallagh@redhat.com> - 1:10.9.0-2
|
||||
- Clean up automatic dependencies for npm
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (node-v10.9.0-stripped.tar.gz) = 74d6aa97b5f30ee7b6e8fd01c1bbcba7c7f70e26e99eb5a3f7b59fa465eb461e62d72d5bf4af9d39d9004df918a4bc1dc24f08b40d335e983e3171c003091a47
|
||||
SHA512 (node-v10.10.0-stripped.tar.gz) = 3202ce37c132abca96219ff296059d424fdd585b415db637ebd1250fb06a7efe8f8e6a3ecc0b985e7500055d1e7d6c92231eedd266f35767e324d9fd656d853d
|
||||
|
Loading…
Reference in New Issue
Block a user