Merge branch '10'

This commit is contained in:
Stephen Gallagher 2019-04-09 21:26:29 -04:00
commit 51d8606600
No known key found for this signature in database
GPG Key ID: 7A25556236BAA3A3
4 changed files with 34 additions and 26 deletions

View File

@ -1,4 +1,4 @@
From 443fef828092b315a207a194f5fe74e52e451996 Mon Sep 17 00:00:00 2001
From 223cfda05cf681b8dfe6f24fbb7d5360d1bfdeee Mon Sep 17 00:00:00 2001
From: Zuzana Svetlikova <zsvetlik@redhat.com>
Date: Thu, 27 Apr 2017 14:25:42 +0200
Subject: [PATCH 1/3] Disable running gyp on shared deps
@ -8,7 +8,7 @@ Subject: [PATCH 1/3] Disable running gyp on shared deps
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/Makefile b/Makefile
index 3a343301d640bc7fd41e9680c74455bb260a950d..d2b9c13ee3e53d957ed32476e40fb09e41fcfded 100644
index 4e7263924cf19ac3a3a3670d28d835b21820fd6c..78ffc37bf1a39ad8f8a430a507a2fbffb9029a20 100644
--- a/Makefile
+++ b/Makefile
@@ -121,14 +121,13 @@ with-code-cache:
@ -30,5 +30,5 @@ index 3a343301d640bc7fd41e9680c74455bb260a950d..d2b9c13ee3e53d957ed32476e40fb09e
@if [ -x config.status ]; then \
./config.status; \
--
2.20.1
2.21.0

View File

@ -1,4 +1,4 @@
From 0fd4649d1943f45cb06bda6febdc7ffa7d5859b2 Mon Sep 17 00:00:00 2001
From 945b762887c65c2c70024de259e27db8a0a31859 Mon Sep 17 00:00:00 2001
From: Stephen Gallagher <sgallagh@redhat.com>
Date: Tue, 1 May 2018 08:05:30 -0400
Subject: [PATCH 2/3] Suppress NPM message to run global update
@ -83,5 +83,5 @@ index 6f76b23828531e7af98a7e3cd7d5abfaac09b40c..98edb6f45fe073e03794a2ae6e7aa7f5
!err &&
npm.config.get('ham-it-up') &&
--
2.20.1
2.21.0

View File

@ -1,7 +1,7 @@
From c38964d69ebb93e2273eca4bdcc4370fa26926f8 Mon Sep 17 00:00:00 2001
From ec52fb7c987b3fe68560ae878b4b0f522f01f8a5 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Tue, 19 Mar 2019 23:22:40 -0400
Subject: [PATCH] Install both binaries and use libdir.
Subject: [PATCH 3/3] Install both binaries and use libdir.
This allows us to build with a shared library for other users while
still providing the normal executable.
@ -9,14 +9,16 @@ still providing the normal executable.
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---
configure.py | 7 +++++++
tools/install.py | 31 ++++++++++++++-----------------
2 files changed, 21 insertions(+), 17 deletions(-)
tools/install.py | 29 +++++++++++++----------------
2 files changed, 20 insertions(+), 16 deletions(-)
diff --git a/configure.py b/configure.py
index b62be2302c..0924fa96dc 100755
index 0ad986ab82e29fdc436794b7f24e49afe1239dca..a58420fc618fe9ad79dcdc27bb6758f34ffaa481 100755
--- a/configure.py
+++ b/configure.py
@@ -552,6 +552,12 @@ parser.add_option('--shared',
@@ -550,10 +550,16 @@ parser.add_option('--shared',
action='store_true',
dest='shared',
help='compile shared library for embedding node in another project. ' +
'(This mode is not officially supported for regular applications)')
@ -29,7 +31,11 @@ index b62be2302c..0924fa96dc 100755
parser.add_option('--without-v8-platform',
action='store_true',
dest='without_v8_platform',
@@ -1094,6 +1100,7 @@ def configure_node(o):
default=False,
help='do not initialize v8 platform during node.js startup. ' +
@@ -1093,10 +1099,11 @@ def configure_node(o):
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
if options.code_cache_path:
o['variables']['node_code_cache_path'] = options.code_cache_path
o['variables']['node_shared'] = b(options.shared)
@ -37,11 +43,15 @@ index b62be2302c..0924fa96dc 100755
node_module_version = getmoduleversion.get_version()
if sys.platform == 'darwin':
shlib_suffix = '%s.dylib'
elif sys.platform.startswith('aix'):
diff --git a/tools/install.py b/tools/install.py
index ce9ceeee1d..5ac67b714e 100755
index 028c32ecbbdf9625238dfcc2baef66df9408b539..bf443c4d15a3b3ebf1e10a5dd802e9c5999691e5 100755
--- a/tools/install.py
+++ b/tools/install.py
@@ -116,26 +116,23 @@ def subdir_files(path, dest, action):
@@ -115,30 +115,27 @@ def subdir_files(path, dest, action):
for subdir, files in ret.items():
action(files, subdir + '/')
def files(action):
is_windows = sys.platform == 'win32'
@ -64,24 +74,25 @@ index ce9ceeee1d..5ac67b714e 100755
- # in its source - see the _InstallableTargetInstallPath function.
- if sys.platform != 'darwin':
- output_prefix += 'lib.target/'
-
- if 'false' == variables.get('node_shared'):
- action([output_prefix + output_file], 'bin/' + output_file)
- else:
- action([output_prefix + output_file], 'lib/' + output_file)
+ output_bin = 'node'
+ output_lib = 'libnode.' + variables.get('shlib_suffix')
+ # GYP will output to lib.target except on OS X, this is hardcoded
+ # in its source - see the _InstallableTargetInstallPath function.
+ if sys.platform != 'darwin':
+ output_libprefix += 'lib.target/'
+
- if 'false' == variables.get('node_shared'):
- action([output_prefix + output_file], 'bin/' + output_file)
- else:
- action([output_prefix + output_file], 'lib/' + output_file)
+ action([output_prefix + output_bin], 'bin/' + output_bin)
+ if 'true' == variables.get('node_shared'):
+ action([output_libprefix + output_lib], variables.get('libdir') + '/' + output_lib)
if 'true' == variables.get('node_use_dtrace'):
action(['out/Release/node.d'], 'lib/dtrace/node.d')
# behave similarly for systemtap
--
2.20.1
2.21.0

View File

@ -119,12 +119,8 @@ Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
# This does bad things on an RPM-managed npm.
Patch2: 0002-Suppress-NPM-message-to-run-global-update.patch
# Upstream patch to fix debug generation on PowerPC
Patch3: 0003-deps-V8-cherry-pick-d0468de.patch
# Patch to install both node and libnode.so, using the correct libdir
Patch5: 0001-Install-both-binaries-and-use-libdir.patch
Patch3: 0003-Install-both-binaries-and-use-libdir.patch
BuildRequires: python2-devel
BuildRequires: python3-devel
@ -555,6 +551,7 @@ end
* Tue Apr 09 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:10.15.3-1
- Update to 10.15.3
- https://nodejs.org/en/blog/release/v10.15.3/
- Drop upstreamed patch
* Tue Apr 09 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:10.15.2-3
- Separate nodejs-libs out to its own subpackage