Update to 10.3.0

Update npm to 6.1.0

https://nodejs.org/en/blog/release/v10.3.0/

Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
Stephen Gallagher 2018-05-30 10:26:09 -04:00
parent 3c76939ae2
commit 22609d8c1b
No known key found for this signature in database
GPG Key ID: 7A25556236BAA3A3
7 changed files with 95 additions and 32 deletions

1
.gitignore vendored
View File

@ -96,3 +96,4 @@
/node-v10.1.0-stripped.tar.gz
/node-v10.2.0-stripped.tar.gz
/node-v10.2.1-stripped.tar.gz
/node-v10.3.0-stripped.tar.gz

View File

@ -1,14 +1,14 @@
From 078957089ba07fe1e31a3e5ef718bc37da6d911c Mon Sep 17 00:00:00 2001
From 03d9247890c2755710a8208974d2919b6a217a63 Mon Sep 17 00:00:00 2001
From: Zuzana Svetlikova <zsvetlik@redhat.com>
Date: Thu, 27 Apr 2017 14:25:42 +0200
Subject: [PATCH] Disable running gyp on shared deps
Subject: [PATCH 1/4] Disable running gyp on shared deps
---
Makefile | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/Makefile b/Makefile
index f499788d9d86cc9b7a06c5f918ea1aea2ebd3a8c..4b5b8c9834fa8389511d43ffead2b8233137c499 100644
index a7099947c72a783a4b9d96c950ac084153532d94..bfd205d0992d4bb4b901a1f3d5595e01e6f88bf8 100644
--- a/Makefile
+++ b/Makefile
@@ -89,14 +89,13 @@ $(NODE_EXE): config.gypi out/Makefile

View File

@ -0,0 +1,74 @@
From 396550f6e26912fe6ef774bc60e24ef73e2f5366 Mon Sep 17 00:00:00 2001
From: Stephen Gallagher <sgallagh@redhat.com>
Date: Tue, 1 May 2018 08:05:30 -0400
Subject: [PATCH 2/4] Suppress NPM message to run global update
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
---
deps/npm/bin/npm-cli.js | 46 -----------------------------------------
1 file changed, 46 deletions(-)
diff --git a/deps/npm/bin/npm-cli.js b/deps/npm/bin/npm-cli.js
index d7c14bc4b2cd0206448163c3a9bed765bde7fae7..98edb6f45fe073e03794a2ae6e7aa7f5500723ee 100755
--- a/deps/npm/bin/npm-cli.js
+++ b/deps/npm/bin/npm-cli.js
@@ -72,56 +72,10 @@
// now actually fire up npm and run the command.
// this is how to use npm programmatically:
conf._exit = true
npm.load(conf, function (er) {
if (er) return errorHandler(er)
- if (!unsupported.checkVersion(process.version).unsupported) {
- const pkg = require('../package.json')
- let notifier = require('update-notifier')({pkg})
- if (
- notifier.update &&
- notifier.update.latest !== pkg.version
- ) {
- const color = require('ansicolors')
- const useColor = npm.config.get('color')
- const useUnicode = npm.config.get('unicode')
- const old = notifier.update.current
- const latest = notifier.update.latest
- let type = notifier.update.type
- if (useColor) {
- switch (type) {
- case 'major':
- type = color.red(type)
- break
- case 'minor':
- type = color.yellow(type)
- break
- case 'patch':
- type = color.green(type)
- break
- }
- }
- const changelog = `https://github.com/npm/npm/releases/tag/v${latest}`
- notifier.notify({
- message: `New ${type} version of ${pkg.name} available! ${
- useColor ? color.red(old) : old
- } ${useUnicode ? '→' : '->'} ${
- useColor ? color.green(latest) : latest
- }\n` +
- `${
- useColor ? color.yellow('Changelog:') : 'Changelog:'
- } ${
- useColor ? color.cyan(changelog) : changelog
- }\n` +
- `Run ${
- useColor
- ? color.green(`npm install -g ${pkg.name}`)
- : `npm i -g ${pkg.name}`
- } to update!`
- })
- }
- }
npm.commands[npm.command](npm.argv, function (err) {
// https://genius.com/Lin-manuel-miranda-your-obedient-servant-lyrics
if (
!err &&
npm.config.get('ham-it-up') &&
--
2.17.0

View File

@ -1,7 +1,7 @@
From a0048de40ceb91e0bf7b0ffd6eb5054c41b3a4a6 Mon Sep 17 00:00:00 2001
From cefa0fd937cb48a8431e62268b2c9500b104d4e5 Mon Sep 17 00:00:00 2001
From: Junliang Yan <jyan@ca.ibm.com>
Date: Wed, 9 May 2018 18:39:49 -0400
Subject: [PATCH 3/3] [PATCH] PPC: use pc-relative address to init constpool
Subject: [PATCH 3/4] [PATCH] PPC: use pc-relative address to init constpool
reg
R=joransiu@ca.ibm.com

View File

@ -1,16 +0,0 @@
diff '--color=auto' -ruN node-v9.11.1.orig/deps/npm/bin/npm-cli.js node-v9.11.1/deps/npm/bin/npm-cli.js
--- node-v9.11.1.orig/deps/npm/bin/npm-cli.js 2018-04-05 00:34:51.000000000 -0400
+++ node-v9.11.1/deps/npm/bin/npm-cli.js 2018-04-09 16:57:31.595166069 -0400
@@ -25,12 +25,6 @@
unsupported.checkForUnsupportedNode()
- if (!unsupported.checkVersion(process.version).unsupported) {
- var updater = require('update-notifier')
- var pkg = require('../package.json')
- updater({pkg: pkg}).notify({defer: true})
- }
-
var path = require('path')
var npm = require('../lib/npm.js')
var npmconf = require('../lib/config/core.js')

View File

@ -20,11 +20,11 @@
# than a Fedora release lifecycle.
%global nodejs_epoch 1
%global nodejs_major 10
%global nodejs_minor 2
%global nodejs_patch 1
%global nodejs_minor 3
%global nodejs_patch 0
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
%global nodejs_release 2
%global nodejs_release 1
# == Bundled Dependency Versions ==
# v8 - from deps/v8/include/v8-version.h
@ -76,8 +76,8 @@
# npm - from deps/npm/package.json
%global npm_epoch 1
%global npm_major 5
%global npm_minor 6
%global npm_major 6
%global npm_minor 1
%global npm_patch 0
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
@ -115,14 +115,14 @@ Source100: %{name}-tarball.sh
Source7: nodejs_native.attr
# Disable running gyp on bundled deps we don't use
Patch1: 0001-Disable-running-gyp-files-for-bundled-deps.patch
Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
# Suppress the message from npm to run `npm -g update npm`
# This does bad things on an RPM-managed npm.
Patch3: no-npm-update-msg.patch
Patch2: 0002-Suppress-NPM-message-to-run-global-update.patch
# Fix PowerPC builds
Patch4: 0003-PATCH-PPC-use-pc-relative-address-to-init-constpool-.patch
Patch3: 0003-PATCH-PPC-use-pc-relative-address-to-init-constpool-.patch
BuildRequires: python2-devel
BuildRequires: zlib-devel
@ -272,9 +272,8 @@ The API documentation for the Node.js JavaScript runtime.
%patch1 -p1
rm -rf deps/zlib
%patch2 -p1
%patch3 -p1
%patch4 -p1
# Replace any instances of unversioned python' with python2
find . -type f -exec sed -i "s~/usr\/bin\/env python~/usr/bin/python2~" {} \;
@ -487,6 +486,11 @@ NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules:%{buildroot}%{_prefix}/lib/nod
%{_pkgdocdir}/npm/doc
%changelog
* Wed May 30 2018 Stephen Gallagher <sgallagh@redhat.com> - -
- Update to 10.3.0
- Update npm to 6.1.0
- https://nodejs.org/en/blog/release/v10.3.0/
* Tue May 29 2018 Stephen Gallagher <sgallagh@redhat.com> - 1:10.2.1-2
- Fix up bare 'python' to be python2
- Drop redundant entry in docs section

View File

@ -1 +1 @@
SHA512 (node-v10.2.1-stripped.tar.gz) = 21c6e8d3eee67c0d4b0a7b456b7706fed924da388ddaf8c4987215df1402ca172f417c202cbf262f68454efdbde984455280c8f868ea1c1798f86325a04ed8b7
SHA512 (node-v10.3.0-stripped.tar.gz) = 0a2fed09a6d0e67288b90207ed85c331bc82655983d8e6c3df5173e6989ab1995fb4787837d5ade65fdb8728f943b2372bc86b3064b4f7270296e89218eff533