Update to 10.8.0

https://nodejs.org/en/blog/release/v10.8.0/

Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
Stephen Gallagher 2018-08-07 10:49:16 -04:00
parent 273c4600f6
commit 05992d4967
No known key found for this signature in database
GPG Key ID: 7A25556236BAA3A3
5 changed files with 21 additions and 13 deletions

1
.gitignore vendored
View File

@ -102,3 +102,4 @@
/node-v10.5.0-stripped.tar.gz
/node-v10.6.0-stripped.tar.gz
/node-v10.7.0-stripped.tar.gz
/node-v10.8.0-stripped.tar.gz

View File

@ -1,4 +1,4 @@
From 77feac7fbcc5eb43f086d937162a84406cc835af Mon Sep 17 00:00:00 2001
From 89c2a359e3c813dd9c3e076f0f91e4fcc46d0274 Mon Sep 17 00:00:00 2001
From: Zuzana Svetlikova <zsvetlik@redhat.com>
Date: Thu, 27 Apr 2017 14:25:42 +0200
Subject: [PATCH 1/2] Disable running gyp on shared deps
@ -8,7 +8,7 @@ Subject: [PATCH 1/2] Disable running gyp on shared deps
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/Makefile b/Makefile
index c75194dbaa15662ffef7ab6cb1b7dae6a647bfcf..636da9323830de6064a6807b3700c2111077db33 100644
index 81dbd9f4d19434c39ab58ff377b0205c7beee557..0db2f5490701068e930d6f108ec4f0447a9fab19 100644
--- a/Makefile
+++ b/Makefile
@@ -105,14 +105,13 @@ with-code-cache:

View File

@ -1,24 +1,27 @@
From 6c121f7eacbeaf07e51ec761b1794ebd00ffcc1b Mon Sep 17 00:00:00 2001
From b88de8b58be60c6fc741e4d7d408fc2071e2722a Mon Sep 17 00:00:00 2001
From: Stephen Gallagher <sgallagh@redhat.com>
Date: Tue, 1 May 2018 08:05:30 -0400
Subject: [PATCH 2/2] Suppress NPM message to run global update
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
---
deps/npm/bin/npm-cli.js | 46 -----------------------------------------
1 file changed, 46 deletions(-)
deps/npm/bin/npm-cli.js | 49 -----------------------------------------
1 file changed, 49 deletions(-)
diff --git a/deps/npm/bin/npm-cli.js b/deps/npm/bin/npm-cli.js
index d7c14bc4b2cd0206448163c3a9bed765bde7fae7..98edb6f45fe073e03794a2ae6e7aa7f5500723ee 100755
index a38009d276e3bb7cb26e9536b62596c336ff8fb5..98edb6f45fe073e03794a2ae6e7aa7f5500723ee 100755
--- a/deps/npm/bin/npm-cli.js
+++ b/deps/npm/bin/npm-cli.js
@@ -72,56 +72,10 @@
@@ -72,59 +72,10 @@
// now actually fire up npm and run the command.
// this is how to use npm programmatically:
conf._exit = true
npm.load(conf, function (er) {
if (er) return errorHandler(er)
- if (!unsupported.checkVersion(process.version).unsupported) {
- if (
- npm.config.get('update-notifier') &&
- !unsupported.checkVersion(process.version).unsupported
- ) {
- const pkg = require('../package.json')
- let notifier = require('update-notifier')({pkg})
- if (
@ -44,7 +47,7 @@ index d7c14bc4b2cd0206448163c3a9bed765bde7fae7..98edb6f45fe073e03794a2ae6e7aa7f5
- break
- }
- }
- const changelog = `https://github.com/npm/npm/releases/tag/v${latest}`
- const changelog = `https://github.com/npm/cli/releases/tag/v${latest}`
- notifier.notify({
- message: `New ${type} version of ${pkg.name} available! ${
- useColor ? color.red(old) : old

View File

@ -20,11 +20,11 @@
# than a Fedora release lifecycle.
%global nodejs_epoch 1
%global nodejs_major 10
%global nodejs_minor 7
%global nodejs_minor 8
%global nodejs_patch 0
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
%global nodejs_release 4
%global nodejs_release 1
# == Bundled Dependency Versions ==
# v8 - from deps/v8/include/v8-version.h
@ -84,7 +84,7 @@
# npm - from deps/npm/package.json
%global npm_epoch 1
%global npm_major 6
%global npm_minor 1
%global npm_minor 2
%global npm_patch 0
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
@ -484,6 +484,10 @@ end
%{_pkgdocdir}/npm/doc
%changelog
* Tue Aug 07 2018 Stephen Gallagher <sgallagh@redhat.com> - 1:10.8.0-1
- Update to 10.8.0
- https://nodejs.org/en/blog/release/v10.8.0/
* Fri Jul 20 2018 Stephen Gallagher <sgallagh@redhat.com> - 1:10.7.0-4
- Fix npm upgrade scriptlet
- Fix unexpected trailing .1 in npm release field

View File

@ -1 +1 @@
SHA512 (node-v10.7.0-stripped.tar.gz) = 7961c20e5213ae8ff6440cd2f0326b058459b6b74e0a704a1ea33644948f19f43a33c460191ecad8e1b00003d815adfca390d1fc3b2f5732338d0c1d98fb73f2
SHA512 (node-v10.8.0-stripped.tar.gz) = 882fe7290f18748de1d06ecf90ab0ce360cb6edd555ee07b3a9a09973dc47b0b84d195260e63aafc8f9dacf07c865e0c1a0329e46f5d13abb39bc05eafd21a2d