Update to 14.17.5
https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V14.md#14.17.5 Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
65247479bf
commit
c17aa05935
@ -1,4 +1,4 @@
|
|||||||
From 127b33d367348142c37cdc881abf4e50874c76f4 Mon Sep 17 00:00:00 2001
|
From 9602f6d0571940e2e50d2524369ff70e86b93a30 Mon Sep 17 00:00:00 2001
|
||||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||||
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
||||||
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
||||||
@ -8,10 +8,10 @@ Subject: [PATCH 1/2] Disable running gyp on shared deps
|
|||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index ebe2fc0c83556fba1c6ca043f0b5737592f85af6..6573eeb4f3c258a95fcba5e47c732cd6a690e2b2 100644
|
index 25dd8b3eb13e2aafc6a014bfd5f2a00df8d56a48..36dd400d45e91e9e680524556f4184f1022cf0c6 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -136,11 +136,11 @@ endif
|
@@ -141,11 +141,11 @@ endif
|
||||||
.PHONY: test-code-cache
|
.PHONY: test-code-cache
|
||||||
with-code-cache test-code-cache:
|
with-code-cache test-code-cache:
|
||||||
$(warning '$@' target is a noop)
|
$(warning '$@' target is a noop)
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From e8ad1913c32afaf3b119a271171add9455a68fa7 Mon Sep 17 00:00:00 2001
|
From 1355aa83d696a7ffc5c620d8990e9373d33bee4a Mon Sep 17 00:00:00 2001
|
||||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||||
Subject: [PATCH 2/2] Install both binaries and use libdir.
|
Subject: [PATCH 2/2] Install both binaries and use libdir.
|
||||||
@ -13,7 +13,7 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
|||||||
2 files changed, 16 insertions(+), 12 deletions(-)
|
2 files changed, 16 insertions(+), 12 deletions(-)
|
||||||
|
|
||||||
diff --git a/configure.py b/configure.py
|
diff --git a/configure.py b/configure.py
|
||||||
index c56559626df228f6963a49822bb4256bc0f75a5c..71a3fecb4d98927feb371bcb3a726204853c4a08 100755
|
index 9dc5d12cbdbd7c9ae31673f1b8efa3aeb3b0681a..2ade6ce4f23df4d0ec05d53344160a2300864a23 100755
|
||||||
--- a/configure.py
|
--- a/configure.py
|
||||||
+++ b/configure.py
|
+++ b/configure.py
|
||||||
@@ -629,10 +629,16 @@ parser.add_option('--shared',
|
@@ -629,10 +629,16 @@ parser.add_option('--shared',
|
||||||
@ -33,7 +33,7 @@ index c56559626df228f6963a49822bb4256bc0f75a5c..71a3fecb4d98927feb371bcb3a726204
|
|||||||
dest='without_v8_platform',
|
dest='without_v8_platform',
|
||||||
default=False,
|
default=False,
|
||||||
help='do not initialize v8 platform during node.js startup. ' +
|
help='do not initialize v8 platform during node.js startup. ' +
|
||||||
@@ -1205,10 +1211,11 @@ def configure_node(o):
|
@@ -1214,10 +1220,11 @@ def configure_node(o):
|
||||||
o['variables']['debug_nghttp2'] = 'false'
|
o['variables']['debug_nghttp2'] = 'false'
|
||||||
|
|
||||||
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
||||||
|
@ -20,7 +20,7 @@
|
|||||||
%global nodejs_epoch 1
|
%global nodejs_epoch 1
|
||||||
%global nodejs_major 14
|
%global nodejs_major 14
|
||||||
%global nodejs_minor 17
|
%global nodejs_minor 17
|
||||||
%global nodejs_patch 4
|
%global nodejs_patch 5
|
||||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||||
%global nodejs_soversion 83
|
%global nodejs_soversion 83
|
||||||
@ -46,7 +46,7 @@
|
|||||||
# https://github.com/nodejs/node/pull/9332
|
# https://github.com/nodejs/node/pull/9332
|
||||||
%global c_ares_major 1
|
%global c_ares_major 1
|
||||||
%global c_ares_minor 17
|
%global c_ares_minor 17
|
||||||
%global c_ares_patch 1
|
%global c_ares_patch 2
|
||||||
%global c_ares_version %{c_ares_major}.%{c_ares_minor}.%{c_ares_patch}
|
%global c_ares_version %{c_ares_major}.%{c_ares_minor}.%{c_ares_patch}
|
||||||
|
|
||||||
# llhttp - from deps/llhttp/include/llhttp.h
|
# llhttp - from deps/llhttp/include/llhttp.h
|
||||||
@ -668,6 +668,10 @@ end
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 11 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:14.17.5-1
|
||||||
|
- Update to 14.17.5
|
||||||
|
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V14.md#14.17.5
|
||||||
|
|
||||||
* Mon Aug 02 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:14.17.4-1
|
* Mon Aug 02 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:14.17.4-1
|
||||||
- Update to 14.17.2
|
- Update to 14.17.2
|
||||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V14.md#14.17.4
|
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V14.md#14.17.4
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (node-v14.17.4-stripped.tar.gz) = 38141391bc4fc0171e64a192820b4bbbc0102b5725f4d115dcaf5775bcfab5d25d652559334fe4eccf389f0c14181364ef57d9182eaa453d92e04a46516f237a
|
SHA512 (node-v14.17.5-stripped.tar.gz) = 7f547f205bdf590f9f5b45d418a2edf7d239c85bb208add8cc09762d0f5cccbba85bbd46856a0a894a485919fd93b0d690adcc8c1ede149e76abaf80d8072fea
|
||||||
SHA512 (icu4c-69_1-src.tgz) = d4aeb781715144ea6e3c6b98df5bbe0490bfa3175221a1d667f3e6851b7bd4a638fa4a37d4a921ccb31f02b5d15a6dded9464d98051964a86f7b1cde0ff0aab7
|
SHA512 (icu4c-69_1-src.tgz) = d4aeb781715144ea6e3c6b98df5bbe0490bfa3175221a1d667f3e6851b7bd4a638fa4a37d4a921ccb31f02b5d15a6dded9464d98051964a86f7b1cde0ff0aab7
|
||||||
|
Loading…
Reference in New Issue
Block a user