Update to 14.17.2
https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V14.md#14.17.2 https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V14.md#14.17.1 Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
3d8af661ad
commit
9e196c1854
@ -1,14 +1,14 @@
|
||||
From 867d8911b63b9837d89cd6ba65ea6ebccd7f77e7 Mon Sep 17 00:00:00 2001
|
||||
From 127b33d367348142c37cdc881abf4e50874c76f4 Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
||||
Subject: [PATCH 1/3] Disable running gyp on shared deps
|
||||
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
||||
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 5bb5d7df5f87e2b1d640e027fd4d0c21975959f7..fc812607ac76fadbbc9f4670a479a040a5024780 100644
|
||||
index ebe2fc0c83556fba1c6ca043f0b5737592f85af6..6573eeb4f3c258a95fcba5e47c732cd6a690e2b2 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -136,11 +136,11 @@ endif
|
||||
|
@ -1,7 +1,7 @@
|
||||
From ea59ced68789dc24c95572b84091afcebe9acb98 Mon Sep 17 00:00:00 2001
|
||||
From e8ad1913c32afaf3b119a271171add9455a68fa7 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||
Subject: [PATCH 2/3] Install both binaries and use libdir.
|
||||
Subject: [PATCH 2/2] Install both binaries and use libdir.
|
||||
|
||||
This allows us to build with a shared library for other users while
|
||||
still providing the normal executable.
|
||||
@ -13,10 +13,10 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
2 files changed, 16 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/configure.py b/configure.py
|
||||
index a477bd1c9578d03cd81456c513486620435749ee..3067eb9fc3e5c3eb22eb4ff3d20f87415b115bb8 100755
|
||||
index c56559626df228f6963a49822bb4256bc0f75a5c..71a3fecb4d98927feb371bcb3a726204853c4a08 100755
|
||||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -624,10 +624,16 @@ parser.add_option('--shared',
|
||||
@@ -629,10 +629,16 @@ parser.add_option('--shared',
|
||||
action='store_true',
|
||||
dest='shared',
|
||||
help='compile shared library for embedding node in another project. ' +
|
||||
@ -33,7 +33,7 @@ index a477bd1c9578d03cd81456c513486620435749ee..3067eb9fc3e5c3eb22eb4ff3d20f8741
|
||||
dest='without_v8_platform',
|
||||
default=False,
|
||||
help='do not initialize v8 platform during node.js startup. ' +
|
||||
@@ -1200,10 +1206,11 @@ def configure_node(o):
|
||||
@@ -1205,10 +1211,11 @@ def configure_node(o):
|
||||
o['variables']['debug_nghttp2'] = 'false'
|
||||
|
||||
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
||||
|
@ -1,45 +0,0 @@
|
||||
From 7388d30b111414507b1353da12529f23daec4ee3 Mon Sep 17 00:00:00 2001
|
||||
From: James Addison <jay@jp-hosting.net>
|
||||
Date: Tue, 9 Mar 2021 13:08:47 +0000
|
||||
Subject: [PATCH 3/3] src: add .note.GNU-stack section
|
||||
|
||||
This indicates to GNU binutils that it can unset the executable stack
|
||||
flag on the binary that it is building.
|
||||
|
||||
PR-URL: https://github.com/nodejs/node/pull/37688
|
||||
Refs: https://github.com/nodejs/node/issues/17933
|
||||
Reviewed-By: Daniel Bevenius <daniel.bevenius@gmail.com>
|
||||
|
||||
src: Use %progbits instead of @progbits
|
||||
|
||||
While @progbits is preferred for most architectures, there are some
|
||||
(notably 32-bit ARM) for which it does not. %progbits is effective
|
||||
everywhere.
|
||||
|
||||
See https://bugzilla.redhat.com/show_bug.cgi?id=1950528 for more
|
||||
details.
|
||||
|
||||
Related: https://github.com/nodejs/node/issues/17933
|
||||
Related: https://github.com/nodejs/node/pull/37688
|
||||
|
||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||
---
|
||||
src/large_pages/node_text_start.S | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/large_pages/node_text_start.S b/src/large_pages/node_text_start.S
|
||||
index 3227b62464932ced6d42916a4300ddbd9b4a4fbb..d27dd39cc236f0e6be4e68113bfff7b531a37455 100644
|
||||
--- a/src/large_pages/node_text_start.S
|
||||
+++ b/src/large_pages/node_text_start.S
|
||||
@@ -1,7 +1,7 @@
|
||||
#if defined(__ELF__)
|
||||
-.section .note.GNU-stack,"",@progbits
|
||||
+.section .note.GNU-stack,"",%progbits
|
||||
#endif
|
||||
.text
|
||||
.align 0x2000
|
||||
.global __node_text_start
|
||||
.hidden __node_text_start
|
||||
--
|
||||
2.31.1
|
||||
|
16
nodejs.spec
16
nodejs.spec
@ -20,7 +20,7 @@
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 14
|
||||
%global nodejs_minor 17
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_patch 2
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||
%global nodejs_soversion 83
|
||||
@ -68,8 +68,8 @@
|
||||
%global nghttp2_version %{nghttp2_major}.%{nghttp2_minor}.%{nghttp2_patch}
|
||||
|
||||
# ICU - from tools/icu/current_ver.dep
|
||||
%global icu_major 68
|
||||
%global icu_minor 2
|
||||
%global icu_major 69
|
||||
%global icu_minor 1
|
||||
%global icu_version %{icu_major}.%{icu_minor}
|
||||
|
||||
%global icudatadir %{nodejs_datadir}/icudata
|
||||
@ -145,10 +145,6 @@ Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
|
||||
# Patch to install both node and libnode.so, using the correct libdir
|
||||
Patch2: 0002-Install-both-binaries-and-use-libdir.patch
|
||||
|
||||
# Patch to disable stack execution. Merged from one upstream patch and
|
||||
# one upstream proposed patch
|
||||
Patch3: 0003-src-add-.note.GNU-stack-section.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-setuptools
|
||||
@ -669,6 +665,12 @@ end
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jul 01 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:14.17.2-1
|
||||
- Update to 14.17.2
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V14.md#14.17.2
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V14.md#14.17.1
|
||||
|
||||
|
||||
* Mon May 17 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:14.17.0-2
|
||||
- Update to 14.17.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V14.md#14.17.0
|
||||
|
@ -1,2 +1,2 @@
|
||||
[koji]
|
||||
targets = rawhide f34 f33
|
||||
targets = f34 f33
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (node-v14.17.0-stripped.tar.gz) = eb1109d13da376df49f3d0b25c21573585c9aec589e9175e182491211bc5b3fd54980f8002ae85544fa9127b95584c030c8f121b6e2520d5f0feb84ef6dab104
|
||||
SHA512 (icu4c-68_2-src.tgz) = 24f3b7981667b37df58118f56ae76a09b719358c1efa8d6f044d28ef8df1c722a894957acadfb3c37aee39ac845893924fc3370d6bbe09875aec8d937059f84b
|
||||
SHA512 (node-v14.17.2-stripped.tar.gz) = a4007cf055d1a8bdea52eadda4650de0b71bdb94357070db52e14858c8d5d9192bae88ba98c418a985e63e856d84a6558e144d341d63652b2e8b4ac48f341c24
|
||||
SHA512 (icu4c-69_1-src.tgz) = d4aeb781715144ea6e3c6b98df5bbe0490bfa3175221a1d667f3e6851b7bd4a638fa4a37d4a921ccb31f02b5d15a6dded9464d98051964a86f7b1cde0ff0aab7
|
||||
|
Loading…
Reference in New Issue
Block a user