diff --git a/.gitignore b/.gitignore
index 96ed4be..c1e6f38 100644
--- a/.gitignore
+++ b/.gitignore
@@ -86,3 +86,4 @@
 /node-v8.9.4-stripped.tar.gz
 /node-v9.5.0-stripped.tar.gz
 /node-v9.6.1-stripped.tar.gz
+/node-v9.7.0-stripped.tar.gz
diff --git a/nodejs.spec b/nodejs.spec
index f3d550e..78d5284 100644
--- a/nodejs.spec
+++ b/nodejs.spec
@@ -21,8 +21,8 @@
 # than a Fedora release lifecycle.
 %global nodejs_epoch 1
 %global nodejs_major 9
-%global nodejs_minor 6
-%global nodejs_patch 1
+%global nodejs_minor 7
+%global nodejs_patch 0
 %global nodejs_abi %{nodejs_major}.%{nodejs_minor}
 %global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
 %global nodejs_release 1
@@ -53,7 +53,7 @@
 # libuv - from deps/uv/include/uv-version.h
 %global libuv_major 1
 %global libuv_minor 19
-%global libuv_patch 1
+%global libuv_patch 2
 %global libuv_version %{libuv_major}.%{libuv_minor}.%{libuv_patch}
 
 # nghttp2 - from deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
@@ -283,6 +283,11 @@ export CXXFLAGS='%{optflags} -g \
 export CFLAGS="$(echo ${CFLAGS} | tr '\n\\' '  ')"
 export CXXFLAGS="$(echo ${CXXFLAGS} | tr '\n\\' '  ')"
 
+# Work around Fedora 28 issue:
+# https://fedoraproject.org/wiki/Changes/Avoid_usr_bin_python_in_RPM_Build#Quick_Opt-Out
+# Tracking BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1550564
+export PYTHON_DISALLOW_AMBIGUOUS_VERSION=0
+
 #%if ! 0%%{?bootstrap}
 %if %{with bootstrap}
 ./configure --prefix=%{_prefix} \
@@ -316,6 +321,11 @@ make BUILDTYPE=Release %{?_smp_mflags}
 
 
 %install
+# Work around Fedora 28 build issue:
+# https://fedoraproject.org/wiki/Changes/Avoid_usr_bin_python_in_RPM_Build#Quick_Opt-Out
+# Tracking BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1550564
+export PYTHON_DISALLOW_AMBIGUOUS_VERSION=0
+
 rm -rf %{buildroot}
 
 ./tools/install.py install %{buildroot} %{_prefix}
@@ -459,6 +469,11 @@ NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules %{buildroot}/%{_bindir}/node -
 %{_pkgdocdir}/npm/doc
 
 %changelog
+* Thu Mar 01 2018 Stephen Gallagher <sgallagh@redhat.com> - 1:9.7.0-1
+- Update to 9.7.0
+- https://nodejs.org/en/blog/release/v9.7.0/
+- Work around F28 build issue
+
 * Sun Feb 25 2018 Stephen Gallagher <sgallagh@redhat.com> - 1:9.6.1-1
 - Update to 9.6.1
 - https://nodejs.org/en/blog/release/v9.6.1/
diff --git a/sources b/sources
index 8ad63db..7bb78fc 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (node-v9.6.1-stripped.tar.gz) = b14fd53548f2a51699264a239814f9d6f2b5d64480a3dd4618c051dd8a387e8aa74a57822a6d547336bc2d7d289fb49e9dd1707148355b0d8bb0f064c30af92f
+SHA512 (node-v9.7.0-stripped.tar.gz) = 99cb62e0be94689d5e665da94edc5f24fab135e7751a3501802ea902d20c2bca12e3368da5aec613e366b828f211e7f3b826b0f77ab734ffdf141f184de5aba7