Update to Node.js 16.15.1
Convert to %autochangelog Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
42ee482d06
commit
13f0076734
@ -1,4 +1,4 @@
|
||||
From dd952f69bcbf0a9947a0629e44c49003dcb9f77f Mon Sep 17 00:00:00 2001
|
||||
From f27e4dbb4116fc2d12426c46b5c5cf374e89d17d Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
||||
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
||||
@ -8,12 +8,10 @@ Subject: [PATCH 1/2] Disable running gyp on shared deps
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 688ebc550e9d6677f468bb791b5d06d5507d3ab5..b34b49db53a4b0cb4a3867921f5c6fb71ae34bf1 100644
|
||||
index 3c48653d05c0c606884681c358228d5b86f73c41..8b5a93b41bffcacbded410a402beb5f7ff8ee41b 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -145,11 +145,11 @@ endif
|
||||
.PHONY: test-code-cache
|
||||
with-code-cache test-code-cache:
|
||||
@@ -147,7 +147,7 @@ with-code-cache test-code-cache:
|
||||
$(warning '$@' target is a noop)
|
||||
|
||||
out/Makefile: config.gypi common.gypi node.gyp \
|
||||
@ -22,8 +20,6 @@ index 688ebc550e9d6677f468bb791b5d06d5507d3ab5..b34b49db53a4b0cb4a3867921f5c6fb7
|
||||
tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
|
||||
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
||||
$(PYTHON) tools/gyp_node.py -f make
|
||||
|
||||
# node_version.h is listed because the N-API version is taken from there
|
||||
--
|
||||
2.34.1
|
||||
2.35.1
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From a1c35106e7e9ab3d4a01779079cf9788a2fe777a Mon Sep 17 00:00:00 2001
|
||||
From d34c55cf80731ac2e6de6cb88166e47d93f6cf81 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||
Subject: [PATCH 2/2] Install both binaries and use libdir.
|
||||
@ -14,12 +14,10 @@ Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||
2 files changed, 16 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/configure.py b/configure.py
|
||||
index 47137d8912dd1439962127a3c1f417eb78572021..c59037a39fcefdfe173d16a7aa9622a32a3c29e7 100755
|
||||
index 95b31769cb5756578d66193716c638f504bd44aa..6e8af30df82b988364f8a1f0a27aabda9c606cab 100755
|
||||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -731,10 +731,16 @@ parser.add_argument('--shared',
|
||||
dest='shared',
|
||||
default=None,
|
||||
@@ -733,6 +733,12 @@ parser.add_argument('--shared',
|
||||
help='compile shared library for embedding node in another project. ' +
|
||||
'(This mode is not officially supported for regular applications)')
|
||||
|
||||
@ -32,11 +30,7 @@ index 47137d8912dd1439962127a3c1f417eb78572021..c59037a39fcefdfe173d16a7aa9622a3
|
||||
parser.add_argument('--without-v8-platform',
|
||||
action='store_true',
|
||||
dest='without_v8_platform',
|
||||
default=False,
|
||||
help='do not initialize v8 platform during node.js startup. ' +
|
||||
@@ -1332,10 +1338,11 @@ def configure_node(o):
|
||||
o['variables']['debug_nghttp2'] = 'false'
|
||||
|
||||
@@ -1342,6 +1348,7 @@ def configure_node(o):
|
||||
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
||||
|
||||
o['variables']['node_shared'] = b(options.shared)
|
||||
@ -44,15 +38,11 @@ index 47137d8912dd1439962127a3c1f417eb78572021..c59037a39fcefdfe173d16a7aa9622a3
|
||||
node_module_version = getmoduleversion.get_version()
|
||||
|
||||
if options.dest_os == 'android':
|
||||
shlib_suffix = 'so'
|
||||
elif sys.platform == 'darwin':
|
||||
diff --git a/tools/install.py b/tools/install.py
|
||||
index eafcb19bf8b29f87c39b0fe7d3c3fd2d175a7b7b..71b5371578711fcc9a1b80069850f0b61bdfebe2 100755
|
||||
index 8a050dfa7c8b771ceb30fd2b74dc47f3de96834c..40357ad1f539b2463393bf618243777c72294015 100755
|
||||
--- a/tools/install.py
|
||||
+++ b/tools/install.py
|
||||
@@ -128,26 +128,23 @@ def subdir_files(path, dest, action):
|
||||
for subdir, files_in_path in ret.items():
|
||||
action(files_in_path, subdir + '/')
|
||||
@@ -130,22 +130,19 @@ def subdir_files(path, dest, action):
|
||||
|
||||
def files(action):
|
||||
is_windows = sys.platform == 'win32'
|
||||
@ -84,8 +74,6 @@ index eafcb19bf8b29f87c39b0fe7d3c3fd2d175a7b7b..71b5371578711fcc9a1b80069850f0b6
|
||||
|
||||
if 'true' == variables.get('node_use_dtrace'):
|
||||
action(['out/Release/node.d'], 'lib/dtrace/node.d')
|
||||
|
||||
# behave similarly for systemtap
|
||||
--
|
||||
2.34.1
|
||||
2.35.1
|
||||
|
||||
|
159
changelog
Normal file
159
changelog
Normal file
@ -0,0 +1,159 @@
|
||||
* Mon Jun 13 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.15.1-1
|
||||
- Update to Node.js 16.15.1
|
||||
- Re-enable LTO build
|
||||
|
||||
* Fri May 06 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.15.0-3
|
||||
- Fix incorrect epoch in v8-devel dependency
|
||||
|
||||
* Fri Apr 29 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.15.0-2
|
||||
- Fix file conflicts.
|
||||
- Make dependency on nodejs-libs more strict.
|
||||
|
||||
* Wed Apr 27 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.15.0-1
|
||||
- Update to Node.js 16.15.0
|
||||
- Stop carrying full ICU sources now that the binary data is available
|
||||
- Properly version the v8 virtual Provides
|
||||
- Bundle nghttp2
|
||||
|
||||
* Mon Apr 04 2022 Jan Staněk <jstanek@redhat.com> - 16.14.1-2
|
||||
- Unify configure.py calls into single command
|
||||
- Refactor bootstrap-related parts
|
||||
- Decouple dependency bundling from bootstrapping
|
||||
|
||||
* Thu Mar 17 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.14.1-1
|
||||
- Update to Node.js 16.14.1
|
||||
- Drop corepack
|
||||
|
||||
* Thu Mar 03 2022 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:16.14.0-3
|
||||
- Build without corepack
|
||||
|
||||
* Wed Feb 09 2022 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:16.14.0-2
|
||||
- Replace explicit version of npm in %%check with variable and make build fail
|
||||
if it doesn't match
|
||||
|
||||
* Tue Feb 08 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.14.0-1
|
||||
- Update to Node.js 16.14.0
|
||||
|
||||
* Thu Feb 03 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.2-8
|
||||
- Update npm to 8.3.1 (CVE-2021-43616)
|
||||
|
||||
* Wed Feb 02 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.2-7
|
||||
- Fix incorrect version Provides: for npm (bz#2049873)
|
||||
|
||||
* Mon Jan 31 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.2-6
|
||||
- Rebuild for more architectures
|
||||
|
||||
* Mon Jan 31 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.2-5
|
||||
- Tweak some dependencies on EPEL 7 (bz2048589)
|
||||
- Add Provides: bundled(zlib)
|
||||
|
||||
* Wed Jan 19 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.2-3
|
||||
- Bundle zlib on EPEL 7
|
||||
|
||||
* Mon Jan 17 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.2-2
|
||||
- Add support for building on EPEL 7
|
||||
|
||||
* Tue Jan 11 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.2-1
|
||||
- Improper handling of URI Subject Alternative Names (Medium)(CVE-2021-44531)
|
||||
- Certificate Verification Bypass via String Injection (Medium)(CVE-2021-44532)
|
||||
- Incorrect handling of certificate subject and issuer fields (Medium)(CVE-2021-44533)
|
||||
- Prototype pollution via `console.table` properties (Low)(CVE-2022-21824)
|
||||
|
||||
* Thu Dec 02 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.1-2
|
||||
- Enable building for EPEL 8 modules
|
||||
|
||||
* Thu Dec 02 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.1-1
|
||||
- Update to 16.13.1
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.13.1
|
||||
|
||||
* Thu Nov 25 2021 Honza Horak <hhorak@redhat.com> - 1:16.13.0-3
|
||||
- Make sure binary node-gyp is executable
|
||||
Resolves: #2026615
|
||||
|
||||
* Mon Nov 01 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.0-1
|
||||
- Update to 16.13.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.13.0
|
||||
- Add support for epel8
|
||||
|
||||
* Mon Oct 25 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.12.0-1
|
||||
- Update to 16.12.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.12.0
|
||||
|
||||
* Wed Oct 13 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.11.1-1
|
||||
- Update to 16.11.1
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.11.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.11.1
|
||||
|
||||
* Thu Sep 23 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.10.0-1
|
||||
- Update to 16.10.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.10.0
|
||||
|
||||
* Tue Sep 14 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.9.1-4
|
||||
- Correct the bad merge of corepack fix
|
||||
|
||||
* Tue Sep 14 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.9.1-3
|
||||
- Drop auto-dependency on PowerShell introduced by corepack
|
||||
|
||||
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 1:16.9.1-2
|
||||
- Rebuilt with OpenSSL 3.0.0
|
||||
|
||||
* Mon Sep 13 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.9.1-1
|
||||
- Update to 16.9.1
|
||||
- Add experimental 'corepack' tool
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.9.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.9.1
|
||||
|
||||
* Tue Aug 31 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.8.0-1
|
||||
- Update to 16.8.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.8.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.7.0
|
||||
|
||||
* Wed Aug 11 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.6.2-1
|
||||
- Update to 16.6.2
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.6.2
|
||||
|
||||
* Tue Aug 03 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.6.1-1
|
||||
- Update to 16.6.1
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.6.1
|
||||
- Fixes v8 regression introduced in 16.6.0
|
||||
|
||||
* Mon Aug 02 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.6.0-1
|
||||
- Update to 16.6.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.6.0
|
||||
|
||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1:16.5.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Tue Jul 20 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.5.0-1
|
||||
- Update to 16.5.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.5.0
|
||||
|
||||
* Fri Jul 02 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.4.1-2
|
||||
- Re-add support for v8 development headers
|
||||
|
||||
* Thu Jul 01 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.4.1-1
|
||||
- Update to 16.4.1
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.4.1
|
||||
|
||||
* Wed Jun 23 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.4.0-1
|
||||
- Update to 16.4.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.4.0
|
||||
|
||||
* Fri Jun 04 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.3.0-1
|
||||
- Update to 16.3.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.3.0
|
||||
|
||||
|
||||
* Wed May 19 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.2.0-1
|
||||
- Update to 16.2.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.2.0
|
||||
- Fix changelog version numbers
|
||||
|
||||
* Tue May 04 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.1.0-1
|
||||
- Update to 16.1.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.1.0
|
||||
- Drop upstreamed patch
|
||||
|
||||
* Thu Apr 29 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.0.0-1
|
||||
- First release of Node.js 16.x
|
||||
|
175
nodejs.spec
175
nodejs.spec
@ -29,9 +29,11 @@
|
||||
%endif
|
||||
|
||||
|
||||
# LTO is currently broken on Node.js builds
|
||||
# Node.js has its own flag to enable LTO and it conflicts
|
||||
# with Fedora's approach.
|
||||
%define _lto_cflags %{nil}
|
||||
|
||||
|
||||
# Heavy-handed approach to avoiding issues with python
|
||||
# bytecompiling files in the node_modules/ directory
|
||||
%global __python %{__python3}
|
||||
@ -40,7 +42,7 @@
|
||||
# This is used by both the nodejs package and the npm subpackage that
|
||||
# has a separate version - the name is special so that rpmdev-bumpspec
|
||||
# will bump this rather than adding .1 to the end.
|
||||
%global baserelease 3
|
||||
%global baserelease 1
|
||||
|
||||
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||
|
||||
@ -52,7 +54,7 @@
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 16
|
||||
%global nodejs_minor 15
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_patch 1
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||
%global nodejs_soversion 93
|
||||
@ -108,7 +110,7 @@
|
||||
|
||||
# npm - from deps/npm/package.json
|
||||
%global npm_epoch 1
|
||||
%global npm_version 8.5.5
|
||||
%global npm_version 8.11.0
|
||||
|
||||
# In order to avoid needing to keep incrementing the release version for the
|
||||
# main package forever, we will just construct one for npm that is guaranteed
|
||||
@ -425,12 +427,6 @@ find . -type f -exec sed -i "s~python -c~python3 -c~" {} \;
|
||||
. /opt/rh/devtoolset-11/enable
|
||||
%endif
|
||||
|
||||
# When compiled on armv7hl this package generates an out of range
|
||||
# reference to the literal pool. This is most likely a GCC issue.
|
||||
%ifarch armv7hl
|
||||
%define _lto_cflags %{nil}
|
||||
%endif
|
||||
|
||||
%ifarch s390 s390x %{arm} %ix86
|
||||
# Decrease debuginfo verbosity to reduce memory consumption during final
|
||||
# library linking
|
||||
@ -466,7 +462,8 @@ export LDFLAGS="%{build_ldflags}"
|
||||
--with-intl=small-icu \
|
||||
--with-icu-default-data-dir=%{icudatadir} \
|
||||
--without-corepack \
|
||||
--openssl-use-def-ca-store
|
||||
--openssl-use-def-ca-store \
|
||||
--enable-lto
|
||||
|
||||
%make_build BUILDTYPE=Release
|
||||
|
||||
@ -683,158 +680,4 @@ end
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri May 06 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.15.0-3
|
||||
- Fix incorrect epoch in v8-devel dependency
|
||||
|
||||
* Fri Apr 29 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.15.0-2
|
||||
- Fix file conflicts.
|
||||
- Make dependency on nodejs-libs more strict.
|
||||
|
||||
* Wed Apr 27 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.15.0-1
|
||||
- Update to Node.js 16.15.0
|
||||
- Stop carrying full ICU sources now that the binary data is available
|
||||
- Properly version the v8 virtual Provides
|
||||
- Bundle nghttp2
|
||||
|
||||
* Mon Apr 04 2022 Jan Staněk <jstanek@redhat.com> - 16.14.1-2
|
||||
- Unify configure.py calls into single command
|
||||
- Refactor bootstrap-related parts
|
||||
- Decouple dependency bundling from bootstrapping
|
||||
|
||||
* Thu Mar 17 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.14.1-1
|
||||
- Update to Node.js 16.14.1
|
||||
- Drop corepack
|
||||
|
||||
* Thu Mar 03 2022 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:16.14.0-3
|
||||
- Build without corepack
|
||||
|
||||
* Wed Feb 09 2022 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:16.14.0-2
|
||||
- Replace explicit version of npm in %%check with variable and make build fail
|
||||
if it doesn't match
|
||||
|
||||
* Tue Feb 08 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.14.0-1
|
||||
- Update to Node.js 16.14.0
|
||||
|
||||
* Thu Feb 03 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.2-8
|
||||
- Update npm to 8.3.1 (CVE-2021-43616)
|
||||
|
||||
* Wed Feb 02 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.2-7
|
||||
- Fix incorrect version Provides: for npm (bz#2049873)
|
||||
|
||||
* Mon Jan 31 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.2-6
|
||||
- Rebuild for more architectures
|
||||
|
||||
* Mon Jan 31 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.2-5
|
||||
- Tweak some dependencies on EPEL 7 (bz2048589)
|
||||
- Add Provides: bundled(zlib)
|
||||
|
||||
* Wed Jan 19 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.2-3
|
||||
- Bundle zlib on EPEL 7
|
||||
|
||||
* Mon Jan 17 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.2-2
|
||||
- Add support for building on EPEL 7
|
||||
|
||||
* Tue Jan 11 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.2-1
|
||||
- Improper handling of URI Subject Alternative Names (Medium)(CVE-2021-44531)
|
||||
- Certificate Verification Bypass via String Injection (Medium)(CVE-2021-44532)
|
||||
- Incorrect handling of certificate subject and issuer fields (Medium)(CVE-2021-44533)
|
||||
- Prototype pollution via `console.table` properties (Low)(CVE-2022-21824)
|
||||
|
||||
* Thu Dec 02 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.1-2
|
||||
- Enable building for EPEL 8 modules
|
||||
|
||||
* Thu Dec 02 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.1-1
|
||||
- Update to 16.13.1
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.13.1
|
||||
|
||||
* Thu Nov 25 2021 Honza Horak <hhorak@redhat.com> - 1:16.13.0-3
|
||||
- Make sure binary node-gyp is executable
|
||||
Resolves: #2026615
|
||||
|
||||
* Mon Nov 01 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.13.0-1
|
||||
- Update to 16.13.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.13.0
|
||||
- Add support for epel8
|
||||
|
||||
* Mon Oct 25 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.12.0-1
|
||||
- Update to 16.12.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.12.0
|
||||
|
||||
* Wed Oct 13 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.11.1-1
|
||||
- Update to 16.11.1
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.11.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.11.1
|
||||
|
||||
* Thu Sep 23 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.10.0-1
|
||||
- Update to 16.10.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.10.0
|
||||
|
||||
* Tue Sep 14 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.9.1-4
|
||||
- Correct the bad merge of corepack fix
|
||||
|
||||
* Tue Sep 14 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.9.1-3
|
||||
- Drop auto-dependency on PowerShell introduced by corepack
|
||||
|
||||
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 1:16.9.1-2
|
||||
- Rebuilt with OpenSSL 3.0.0
|
||||
|
||||
* Mon Sep 13 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.9.1-1
|
||||
- Update to 16.9.1
|
||||
- Add experimental 'corepack' tool
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.9.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.9.1
|
||||
|
||||
* Tue Aug 31 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.8.0-1
|
||||
- Update to 16.8.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.8.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.7.0
|
||||
|
||||
* Wed Aug 11 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.6.2-1
|
||||
- Update to 16.6.2
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.6.2
|
||||
|
||||
* Tue Aug 03 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.6.1-1
|
||||
- Update to 16.6.1
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.6.1
|
||||
- Fixes v8 regression introduced in 16.6.0
|
||||
|
||||
* Mon Aug 02 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.6.0-1
|
||||
- Update to 16.6.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.6.0
|
||||
|
||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1:16.5.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Tue Jul 20 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.5.0-1
|
||||
- Update to 16.5.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.5.0
|
||||
|
||||
* Fri Jul 02 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.4.1-2
|
||||
- Re-add support for v8 development headers
|
||||
|
||||
* Thu Jul 01 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.4.1-1
|
||||
- Update to 16.4.1
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.4.1
|
||||
|
||||
* Wed Jun 23 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.4.0-1
|
||||
- Update to 16.4.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.4.0
|
||||
|
||||
* Fri Jun 04 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.3.0-1
|
||||
- Update to 16.3.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.3.0
|
||||
|
||||
|
||||
* Wed May 19 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.2.0-1
|
||||
- Update to 16.2.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.2.0
|
||||
- Fix changelog version numbers
|
||||
|
||||
* Tue May 04 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.1.0-1
|
||||
- Update to 16.1.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.1.0
|
||||
- Drop upstreamed patch
|
||||
|
||||
* Thu Apr 29 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.0.0-1
|
||||
- First release of Node.js 16.x
|
||||
|
||||
%autochangelog
|
||||
|
@ -1,2 +1,2 @@
|
||||
[koji]
|
||||
targets = rawhide f36 f35 epel7
|
||||
targets = f36 f35 epel7
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (node-v16.15.0-stripped.tar.gz) = 0621c917d5144b6cfa845654019981c093b8f79e7695ee233474c37ab524bceaa50fb7e82afd8f6337db505a55e6ba407e2984a91e84ff42380366022e1f059c
|
||||
SHA512 (node-v16.15.1-stripped.tar.gz) = 381d40421666375a917fe317caf8abc48a827c253ce773a974e68b6e8da021e8a59c080b7c1e2676fc18d3aab0f99df172f9f1d9fd3d019fa57dd3d0dfbc00bf
|
||||
SHA512 (icu4c-70_1-data-bin-b.zip) = eff9b41f1df4fe74e13bc216c62a8eab735622e3aa4e0b9c925b61f55294a002238a0022e1579197170d0345de6e877220b04b62d2010796f4ef1fbb2c17ea92
|
||||
SHA512 (icu4c-70_1-data-bin-l.zip) = 041ff3480566330d043d9ddcd31e8851e875183d158ea3ce625583b4a9d96166497a9eedc0e72e2f7a3abc3a9110a0372546151b264ff4d1623215aab33552f5
|
||||
|
Loading…
Reference in New Issue
Block a user