Updated to version 0.2.0.

This commit is contained in:
Vitaly Zaitsev 2018-03-05 11:26:26 +01:00
parent b0a9616dfc
commit 67a2cb918f
No known key found for this signature in database
GPG Key ID: BF99FC6DD45AB90A
7 changed files with 30 additions and 223 deletions

2
.gitignore vendored
View File

@ -6,3 +6,5 @@
/nheko-a1ea11d.tar.gz
/matrix-structs-335ece4.tar.gz
/nheko-c75a136.tar.gz
/matrix-structs-a84b372.tar.gz
/nheko-0.2.0.tar.gz

View File

@ -3,7 +3,7 @@ set -e
echo -n "Downloading header-only libraries..."
mkdir deps
wget https://github.com/nlohmann/json/releases/download/v3.0.0/json.hpp -O deps/json.hpp 2> /dev/null
wget https://github.com/nlohmann/json/releases/download/v3.1.1/json.hpp -O deps/json.hpp 2> /dev/null
wget https://github.com/mpark/variant/releases/download/v1.3.0/variant.hpp -O deps/variant.hpp 2> /dev/null
echo " Done."

View File

@ -1,17 +1,17 @@
From 3747834c19601ec29ecc875ebb5e6a956fbe6c26 Mon Sep 17 00:00:00 2001
From 52f116af8325656a013688f98d84f54cb0dac817 Mon Sep 17 00:00:00 2001
From: Vitaly Zaitsev <vitaly@easycoding.org>
Date: Tue, 12 Dec 2017 15:25:45 +0100
Subject: [PATCH 2/3] Completely remove additional CXXFLAGS.
Subject: [PATCH 1/2] Completely remove additional CXXFLAGS.
---
CMakeLists.txt | 7 -------
1 file changed, 7 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b7b61fb..5872f2b 100644
index 3f0c44e..611a59a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -111,13 +111,6 @@ set(PROJECT_VERSION ${CPACK_PACKAGE_VERSION})
@@ -110,13 +110,6 @@ set(PROJECT_VERSION ${CPACK_PACKAGE_VERSION})
message(STATUS "Version: ${PROJECT_VERSION}")
if(CMAKE_CXX_COMPILER_ID MATCHES "Clang" OR CMAKE_CXX_COMPILER_ID MATCHES "GNU")

View File

@ -1,17 +1,17 @@
From 057046ec20d94c5d90d9b6d5793624a91f78e9e9 Mon Sep 17 00:00:00 2001
From f6e9832f0f47897b98d0e862a0a23eff2f5aa800 Mon Sep 17 00:00:00 2001
From: Vitaly Zaitsev <vitaly@easycoding.org>
Date: Sat, 16 Dec 2017 18:20:43 +0100
Subject: [PATCH 3/3] Remove rpath.
Subject: [PATCH 2/2] Remove rpath.
---
CMakeLists.txt | 1 +
1 file changed, 1 insertion(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5872f2b..e245e81 100644
index 611a59a..d108dc2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -352,3 +352,4 @@ if(UNIX AND NOT APPLE)
@@ -358,3 +358,4 @@ if(UNIX AND NOT APPLE)
COMMAND ${CMAKE_COMMAND} -P ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake)
endif()
endif()

View File

@ -1,29 +0,0 @@
From 258bf62f0c2ccca2cc306f1ed59d2982d9c4b2b2 Mon Sep 17 00:00:00 2001
From: Vitaly Zaitsev <vitaly@easycoding.org>
Date: Tue, 12 Dec 2017 15:24:19 +0100
Subject: [PATCH 1/3] Drop Git submodules from cmake manifest.
---
CMakeLists.txt | 6 ------
1 file changed, 6 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2997f66..b7b61fb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,12 +45,6 @@ else()
find_package_handle_standard_args(LMDB DEFAULT_MSG LMDB_INCLUDE_DIR LMDB_LIBRARY)
endif()
-if (NOT EXISTS "${CMAKE_SOURCE_DIR}/libs/lmdbxx/.git" OR
- NOT EXISTS "${CMAKE_SOURCE_DIR}/libs/matrix-structs/.git")
- message(WARNING "The git submodules are not available.")
- message(STATUS "Running git submodule update --init --recursive ...")
- execute_process(COMMAND git submodule update --init --recursive)
-endif()
#
# Discover Qt dependencies.
--
2.14.3

View File

@ -1,20 +1,15 @@
# Git revision of nheko...
%global commit0 c75a136973a2eaae53223e7374a196c04b7aa6f6
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
%global date 20180226
# Git revision of lmdbxx...
%global commit1 0b43ca87d8cfabba392dfe884eb1edb83874de02
%global shortcommit1 %(c=%{commit1}; echo ${c:0:7})
# Git revision of matrix-structs...
%global commit2 335ece4cbe411393e9179621a299dd96433c1757
%global commit2 a84b37215ead77620dcddc0789c4b9b443757a17
%global shortcommit2 %(c=%{commit2}; echo ${c:0:7})
Summary: Desktop client for the Matrix protocol
Name: nheko
Version: 0.1.0
Release: 27.%{date}git%{shortcommit0}%{?dist}
Version: 0.2.0
Release: 1%{?dist}
# Application and 3rd-party modules licensing:
# * S0 - GPLv3+ -- main source;
@ -30,15 +25,14 @@ License: GPLv3+ and Public Domain and MIT and Boost and ASL 2.0 and CC-BY
URL: https://github.com/mujx/nheko
# Use ./gen_libs.sh script from repository to generate tarball with header-only libraries...
Source0: %{url}/archive/%{commit0}.tar.gz#/%{name}-%{shortcommit0}.tar.gz
Source0: %{url}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
Source1: https://github.com/bendiken/lmdbxx/archive/%{commit1}.tar.gz#/lmdbxx-%{shortcommit1}.tar.gz
Source2: https://github.com/mujx/matrix-structs/archive/%{commit2}.tar.gz#/matrix-structs-%{shortcommit2}.tar.gz
Source3: header_only.tar.gz
Source4: gen_libs.sh
Patch0: %{name}-drop-submodules.patch
Patch1: %{name}-drop-flags.patch
Patch2: %{name}-drop-rpath.patch
Patch0: %{name}-drop-flags.patch
Patch1: %{name}-drop-rpath.patch
BuildRequires: cmake(Qt5Widgets)
BuildRequires: cmake(Qt5Network)
@ -50,6 +44,7 @@ BuildRequires: desktop-file-utils
BuildRequires: libappstream-glib
BuildRequires: ninja-build
BuildRequires: lmdb-devel
BuildRequires: doxygen
BuildRequires: gcc-c++
BuildRequires: cmake
BuildRequires: gcc
@ -62,22 +57,17 @@ for Matrix that feels more like a mainstream chat app.
%prep
# Unpacking main tarball with sources...
%autosetup -n %{name}-%{commit0} -p1
mkdir %{_target_platform}
%autosetup -p1
mkdir {%{_target_platform},.third-party}
sed -i '/GIT_/d' cmake/*.cmake
# Unpacking lmdbxx...
pushd libs
rm -rf lmdbxx
# Unpacking third-party modules...
pushd ".third-party"
tar -xf %{SOURCE1}
mv lmdbxx-%{commit1} lmdbxx
popd
# Unpacking matrix-structs...
pushd libs
rm -rf matrix-structs
tar -xf %{SOURCE2}
mv matrix-structs-%{commit2} matrix-structs
pushd matrix-structs
mv matrix-structs-%{commit2} matrix_structs
pushd matrix_structs
sed -i 's@add_library(${LIBRARY_NAME} ${SRC})@add_library(${LIBRARY_NAME} STATIC ${SRC})@g' CMakeLists.txt
tar -xf %{SOURCE3}
popd
@ -113,167 +103,11 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}.desktop
%{_datadir}/icons/hicolor/*/apps/%{name}.*
%changelog
* Mon Feb 26 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-27.20180226gitc75a136
- Updated to latest snapshot.
* Sat Feb 24 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-26.20180223gitf525b7e
- Updated to latest snapshot.
* Wed Feb 21 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-25.20180220git020f153
- Updated to latest snapshot.
* Tue Feb 20 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-24.20180219git127c52e
- Updated to latest snapshot.
* Mon Feb 19 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-23.20180218gita8e17b9
- Updated to latest snapshot.
* Sun Feb 18 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-22.20180217git7e2f835
- Updated to latest snapshot.
* Sat Feb 17 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-21.20180217git59e4148
- Updated to latest snapshot.
* Fri Feb 16 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-20.20180216gita1ea11d
- Updated to latest snapshot.
* Wed Feb 14 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-19.20180211git6d08e67
- Updated to latest snapshot.
* Sat Feb 10 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-18.20180210gitba8faa3
- Updated to latest snapshot.
* Sat Feb 03 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-17.20180202git43ba4d5
- Updated to latest snapshot.
* Fri Feb 02 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-16.20180202git73bc1ff
- Updated to latest snapshot.
* Thu Feb 01 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-15.20180131git96e9971
- Added AppData manifest. Minor SPEC fixes.
* Thu Feb 01 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-14.20180131git96e9971
- Updated to latest snapshot.
* Wed Jan 31 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-13.20180131git1d7548d
- Updated to latest snapshot.
* Mon Jan 29 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-12.20180129git86aa409
- Updated to latest snapshot.
* Fri Jan 26 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-11.20180125git597f829
- Updated to latest snapshot.
* Thu Jan 25 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-10.20180125git0e91dae
- Updated to latest snapshot.
* Wed Jan 24 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-9.20180123git9eedcd7
- Updated to latest snapshot.
* Mon Jan 22 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-8.20180122git48dabdf
- Updated to latest snapshot.
* Wed Jan 17 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-7.20180117git92a578f
- Updated to latest snapshot.
* Mon Jan 15 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-6.20180114git020a842
- Updated to latest snapshot.
* Sun Jan 14 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-5.20180114git4521837
- Updated to latest snapshot.
* Fri Jan 12 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-4.20180112git396becb
- Updated to latest snapshot.
* Thu Jan 11 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-3.20180111git8beef5e
- Updated to latest snapshot.
* Wed Jan 10 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-2.20180110git7f3b6c4
- Updated to latest snapshot.
* Mon Mar 05 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.2.0-1
- Updated to version 0.2.0.
* Thu Dec 28 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-1
- Updated to version 0.1.0.
* Sun Dec 24 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-28.20171224git6835a97
- Updated to latest snapshot.
* Fri Dec 22 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-27.20171222gita3c1629
- Updated to latest snapshot.
* Thu Dec 21 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-26.20171219git84b5f2b
- Updated to latest snapshot.
* Wed Dec 20 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-25.20171219gitf11044b
- Updated to latest snapshot.
* Mon Dec 18 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-24.20171217git101bf47
- Updated to latest snapshot.
* Sun Dec 17 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-23.20171216git474e52b
- Updated to latest snapshot.
* Sat Dec 16 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-22.20171216gitb5e692b
- Updated to latest snapshot.
* Tue Dec 12 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-21.20171212git6aa635e
- Updated to latest snapshot.
* Mon Dec 11 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-20.20171211git3c5241c
- Updated to latest snapshot.
* Sun Dec 10 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-19.20171210gitbba3bba
- Updated to latest snapshot.
* Thu Dec 07 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-18.20171207git64e4759
- Updated to latest snapshot.
* Wed Dec 06 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-17.20171206gite1a4458
- Updated to latest snapshot.
* Mon Dec 04 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-16.20171204gitb9c4a81
- Updated to latest snapshot.
* Sat Dec 02 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-15.20171201gitf4f78b1
- Updated to latest snapshot.
* Mon Nov 27 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-14.20171127gitf1eb0bb
- Updated to latest snapshot.
* Sun Nov 26 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-13.20171126gite4c8a55
- Updated to latest snapshot.
* Fri Nov 24 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-12.20171124git0f363b5
- Updated to latest snapshot.
* Fri Nov 10 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-11.20171110gite40dab9
- Updated to latest snapshot.
* Thu Nov 09 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-10.20171109gitb586a23
- Updated to latest snapshot.
* Tue Nov 07 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-9.20171107git26904fe
- Updated to latest snapshot.
* Sun Nov 05 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-8.20171105git7a653b2
- Updated to latest snapshot.
* Sat Oct 28 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-7.20171027git845228a
- Updated to latest snapshot.
* Sat Oct 21 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-6.20171021git3cae6c3
- Updated to latest snapshot.
* Sat Oct 21 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-5.20171021git47d1546
- Updated to latest snapshot.
* Wed Oct 18 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-4.20171016git8390ff2
- Updated to latest snapshot.
* Tue Oct 10 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-3.20171010git7748529
- Updated to latest snapshot.
* Mon Oct 09 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-2.20171009git513f69e
- Updated to latest snapshot.
* Mon Sep 25 2017 Vitaly Zaitsev <vitaly@easycoding.org> - 0-1.20170924git9def76a
- Initial SPEC release.

View File

@ -1,4 +1,4 @@
SHA512 (header_only.tar.gz) = 69ad33a9f4114c9caf5f5f3c8117adc8989e2bacd7f691a8c39c859c350d9f4f73504b31415da295b95412bf6b800c0b2f9dd77162e8d9e08b68910bec1d40ab
SHA512 (header_only.tar.gz) = c5b6f6bd9f0dd1ca0daee04048f733e306e6b4ac93c9100136a2714b28d0f9d17864362209359c4251ba65aeb69e14fbaf45942b27f47df9dccf2e268f3cbcb9
SHA512 (lmdbxx-0b43ca8.tar.gz) = 025a945288a398b09549c91c98509a57912f8614c14b476e7c8d4fb0dc8fc1288fa1b3a33567cccea474277a1c48b3701f2df31e8a6acc851eb9549a9822f074
SHA512 (matrix-structs-335ece4.tar.gz) = ab9317fb4deee3cae24b88d432593aa2cc6193c92eccdd2adf3508915afffa245164813db9e38d0f974264b2b9c5262533890ebdd40619ede9a88814ea228d13
SHA512 (nheko-c75a136.tar.gz) = 9aa37dbca56f9ae8156f881a0f9a16d4efb597b2209ccdad98dcf696ad24cc7f77eb7e6a01a7c2641169e9409eb9447be6707d1014d7393b72b3510c88f9f43e
SHA512 (matrix-structs-a84b372.tar.gz) = 8113d7877d14114e14a37e6bf414792a615e9cc825c171a4c3debb2eaa2d02b70cef23f94453bb5262cbea9e1506e73be7f32d6dea71ed9fd115d6981e647c59
SHA512 (nheko-0.2.0.tar.gz) = 3b2a5980e1e0fa38c481a768a4e6511e94d9f38e1457400fcd696cb95d8e86162ff0f468856bdd07b003dc24f21da9edac16d0793952ec3e6c5d9424b5090e2e