Updated to latest Git snapshot.
This commit is contained in:
parent
c30b74398e
commit
56ffda361c
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
||||
/matrix-structs-97201f9.tar.gz
|
||||
/nheko-73bc1ff.tar.gz
|
||||
/nheko-43ba4d5.tar.gz
|
||||
/nheko-a1ea11d.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 6e606f1637e93619feae69bf1eae8dace7d4900d Mon Sep 17 00:00:00 2001
|
||||
From 3747834c19601ec29ecc875ebb5e6a956fbe6c26 Mon Sep 17 00:00:00 2001
|
||||
From: Vitaly Zaitsev <vitaly@easycoding.org>
|
||||
Date: Tue, 12 Dec 2017 15:25:45 +0100
|
||||
Subject: [PATCH 2/3] Completely remove additional CXXFLAGS.
|
||||
@ -8,7 +8,7 @@ Subject: [PATCH 2/3] Completely remove additional CXXFLAGS.
|
||||
1 file changed, 7 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index ecf9645..e481b11 100644
|
||||
index b7b61fb..5872f2b 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -111,13 +111,6 @@ set(PROJECT_VERSION ${CPACK_PACKAGE_VERSION})
|
||||
|
@ -1,4 +1,4 @@
|
||||
From ef0e66934c48abd474d2996c9cfc3382d8ad6dcf Mon Sep 17 00:00:00 2001
|
||||
From 057046ec20d94c5d90d9b6d5793624a91f78e9e9 Mon Sep 17 00:00:00 2001
|
||||
From: Vitaly Zaitsev <vitaly@easycoding.org>
|
||||
Date: Sat, 16 Dec 2017 18:20:43 +0100
|
||||
Subject: [PATCH 3/3] Remove rpath.
|
||||
@ -8,10 +8,10 @@ Subject: [PATCH 3/3] Remove rpath.
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index e481b11..e1f0143 100644
|
||||
index 5872f2b..e245e81 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -350,3 +350,4 @@ if(UNIX AND NOT APPLE)
|
||||
@@ -352,3 +352,4 @@ if(UNIX AND NOT APPLE)
|
||||
COMMAND ${CMAKE_COMMAND} -P ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake)
|
||||
endif()
|
||||
endif()
|
||||
|
@ -1,21 +1,22 @@
|
||||
From d1c519c9e22b3d48cc618242b46e729336a9597e Mon Sep 17 00:00:00 2001
|
||||
From 258bf62f0c2ccca2cc306f1ed59d2982d9c4b2b2 Mon Sep 17 00:00:00 2001
|
||||
From: Vitaly Zaitsev <vitaly@easycoding.org>
|
||||
Date: Tue, 12 Dec 2017 15:24:19 +0100
|
||||
Subject: [PATCH 1/3] Drop Git submodules from cmake manifest.
|
||||
|
||||
---
|
||||
CMakeLists.txt | 5 -----
|
||||
1 file changed, 5 deletions(-)
|
||||
CMakeLists.txt | 6 ------
|
||||
1 file changed, 6 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 876409b..ecf9645 100644
|
||||
index 2997f66..b7b61fb 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -45,11 +45,6 @@ else()
|
||||
@@ -45,12 +45,6 @@ else()
|
||||
find_package_handle_standard_args(LMDB DEFAULT_MSG LMDB_INCLUDE_DIR LMDB_LIBRARY)
|
||||
endif()
|
||||
|
||||
-if (NOT EXISTS "${CMAKE_SOURCE_DIR}/libs/lmdbxx/.git" )
|
||||
-if (NOT EXISTS "${CMAKE_SOURCE_DIR}/libs/lmdbxx/.git" OR
|
||||
- NOT EXISTS "${CMAKE_SOURCE_DIR}/libs/matrix-structs/.git")
|
||||
- message(WARNING "The git submodules are not available.")
|
||||
- message(STATUS "Running git submodule update --init --recursive ...")
|
||||
- execute_process(COMMAND git submodule update --init --recursive)
|
||||
|
19
nheko.spec
19
nheko.spec
@ -1,7 +1,7 @@
|
||||
# Git revision of nheko...
|
||||
%global commit0 43ba4d5ed5fa06fa5d5f093c6c3c0b12307dbb43
|
||||
%global commit0 a1ea11d5ef1177bf1aca9947e02f8292b146ad52
|
||||
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
|
||||
%global date 20180202
|
||||
%global date 20180216
|
||||
|
||||
# Git revision of lmdbxx...
|
||||
%global commit1 0b43ca87d8cfabba392dfe884eb1edb83874de02
|
||||
@ -14,7 +14,7 @@
|
||||
Summary: Desktop client for the Matrix protocol
|
||||
Name: nheko
|
||||
Version: 0.1.0
|
||||
Release: 18.%{date}git%{shortcommit0}%{?dist}
|
||||
Release: 20.%{date}git%{shortcommit0}%{?dist}
|
||||
|
||||
# Application and 3rd-party modules licensing:
|
||||
# * S0 - GPLv3+ -- main source;
|
||||
@ -58,8 +58,7 @@ Requires: hicolor-icon-theme
|
||||
|
||||
%description
|
||||
The motivation behind the project is to provide a native desktop app
|
||||
for Matrix that feels more like a mainstream chat app (Riot,
|
||||
Telegram etc) and less like an IRC client.
|
||||
for Matrix that feels more like a mainstream chat app.
|
||||
|
||||
%prep
|
||||
# Unpacking main tarball with sources...
|
||||
@ -114,8 +113,14 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}.desktop
|
||||
%{_datadir}/icons/hicolor/*/apps/%{name}.*
|
||||
|
||||
%changelog
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.0-18.20180202git43ba4d5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
* Fri Feb 16 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-20.20180216gita1ea11d
|
||||
- Updated to latest snapshot.
|
||||
|
||||
* Wed Feb 14 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-19.20180211git6d08e67
|
||||
- Updated to latest snapshot.
|
||||
|
||||
* Sat Feb 10 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-18.20180210gitba8faa3
|
||||
- Updated to latest snapshot.
|
||||
|
||||
* Sat Feb 03 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.1.0-17.20180202git43ba4d5
|
||||
- Updated to latest snapshot.
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (header_only.tar.gz) = 69ad33a9f4114c9caf5f5f3c8117adc8989e2bacd7f691a8c39c859c350d9f4f73504b31415da295b95412bf6b800c0b2f9dd77162e8d9e08b68910bec1d40ab
|
||||
SHA512 (lmdbxx-0b43ca8.tar.gz) = 025a945288a398b09549c91c98509a57912f8614c14b476e7c8d4fb0dc8fc1288fa1b3a33567cccea474277a1c48b3701f2df31e8a6acc851eb9549a9822f074
|
||||
SHA512 (matrix-structs-97201f9.tar.gz) = dd987c2720f3a807896c76039c37fc905e178a7b113256184199cd3d9070dae6aa8aadba30f80b9c09af52f6b3290f14b05775ffc9ca62710d3c5179879106b0
|
||||
SHA512 (nheko-43ba4d5.tar.gz) = f255a3a7d79ba95f4c17e0ec57d1c3b2ae197d3fc3254f051eee0c2c463d5e45965e79c182751101e7ada8330a1eaa98653f706e415ea9f2a150a62a22fe27fc
|
||||
SHA512 (nheko-a1ea11d.tar.gz) = 046e809cd01eb47a71bde00a24b19c17fc3acc30d8e6c8545356171958ea0afaf2f125efaa1c7f6425a926c8bc1eb137fb019e1e791e690a1c4bc641e625a791
|
||||
|
Loading…
Reference in New Issue
Block a user