Updated to version 0.7.1.

This commit is contained in:
Vitaly Zaitsev 2020-06-03 17:23:53 +02:00
parent 9754b712ef
commit 150f70f224
No known key found for this signature in database
GPG Key ID: BF99FC6DD45AB90A
4 changed files with 54 additions and 36 deletions

1
.gitignore vendored
View File

@ -33,3 +33,4 @@
/nheko-0.6.2.tar.gz
/nheko-0.6.3.tar.gz
/nheko-0.6.4.tar.gz
/nheko-0.7.1.tar.gz

View File

@ -1,21 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fda60b7..cca69ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,8 @@ set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
add_definitions(-DBOOST_MPL_LIMIT_LIST_SIZE=30)
add_definitions(-DBOOST_MPL_CFG_NO_PREPROCESSED_HEADERS)
+add_definitions(-DSPDLOG_COMPILED_LIB)
+add_definitions(-DSPDLOG_FMT_EXTERNAL)
include(GNUInstallDirs)
@@ -395,6 +397,7 @@ set(COMMON_LIBS
MatrixClient::MatrixClient
${Boost_LIBRARIES}
cmark::cmark
+ spdlog::spdlog
Qt5::Widgets
Qt5::Svg
Qt5::Concurrent

View File

@ -1,15 +1,19 @@
Name: nheko
Version: 0.6.4
Release: 5%{?dist}
Summary: Desktop client for the Matrix protocol
%bcond_without clang
# Application and 3rd-party modules licensing:
# * S0 - GPLv3+ -- main source.
%if %{with clang}
%global optflags %(echo %{optflags} | sed -e 's/-mcet//g' -e 's/-fcf-protection//g' -e 's/-fstack-clash-protection//g' -e 's/$/ -Qunused-arguments -Wno-unknown-warning-option -Wno-deprecated-declarations/')
%endif
Name: nheko
Version: 0.7.1
Release: 1%{?dist}
Summary: Desktop client for the Matrix protocol
License: GPLv3+
URL: https://github.com/Nheko-Reborn/nheko
Source0: %{url}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
Patch100: %{name}-modern-spdlog.patch
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
BuildRequires: cmake(Qt5Qml)
BuildRequires: cmake(Qt5Svg)
BuildRequires: cmake(Qt5DBus)
BuildRequires: cmake(Qt5Core)
@ -17,21 +21,24 @@ BuildRequires: cmake(Qt5Widgets)
BuildRequires: cmake(Qt5Network)
BuildRequires: cmake(Qt5Multimedia)
BuildRequires: cmake(Qt5Concurrent)
BuildRequires: cmake(Qt5QuickWidgets)
BuildRequires: cmake(Qt5LinguistTools)
BuildRequires: cmake(Qt5QuickCompiler)
BuildRequires: cmake(Qt5QuickControls2)
BuildRequires: mtxclient-devel >= 0.3.0
BuildRequires: spdlog-devel >= 0.16
BuildRequires: boost-devel >= 1.70
BuildRequires: json-devel >= 3.1.2
BuildRequires: mpark-variant-devel
BuildRequires: desktop-file-utils
BuildRequires: libappstream-glib
BuildRequires: mtxclient-devel
BuildRequires: libsodium-devel
BuildRequires: openssl-devel
BuildRequires: libolm-devel
BuildRequires: tweeny-devel
BuildRequires: lmdbxx-devel
BuildRequires: ninja-build
BuildRequires: boost-devel
BuildRequires: cmark-devel
BuildRequires: lmdb-devel
BuildRequires: zlib-devel
@ -39,6 +46,12 @@ BuildRequires: gcc-c++
BuildRequires: cmake
BuildRequires: gcc
%if %{with clang}
BuildRequires: compiler-rt
BuildRequires: clang
BuildRequires: llvm
%endif
Requires: hicolor-icon-theme
%description
@ -48,15 +61,37 @@ for Matrix that feels more like a mainstream chat app.
%prep
%autosetup -p1
mkdir -p %{_target_platform}
sed -e '/-Wall/d' -e '/-Wextra/d' -e '/-Werror/d' -e '/-pedantic/d' -e '/-pipe/d' -i CMakeLists.txt
echo "set_target_properties(nheko PROPERTIES SKIP_BUILD_RPATH TRUE)" >> CMakeLists.txt
echo "include_directories(%{_includedir}/mpark)" >> CMakeLists.txt
%build
pushd %{_target_platform}
%cmake -G Ninja \
%if %{with clang}
-DCMAKE_C_COMPILER=%{_bindir}/clang \
-DCMAKE_CXX_COMPILER=%{_bindir}/clang++ \
-DCMAKE_AR=%{_bindir}/llvm-ar \
-DCMAKE_RANLIB=%{_bindir}/llvm-ranlib \
-DCMAKE_LINKER=%{_bindir}/llvm-ld \
-DCMAKE_OBJDUMP=%{_bindir}/llvm-objdump \
-DCMAKE_NM=%{_bindir}/llvm-nm \
%else
-DCMAKE_AR=%{_bindir}/gcc-ar \
-DCMAKE_RANLIB=%{_bindir}/gcc-ranlib \
-DCMAKE_NM=%{_bindir}/gcc-nm \
%endif
-DCMAKE_BUILD_TYPE=Release \
-DUSE_BUNDLED=OFF \
-DHUNTER_ENABLED:BOOL=OFF \
-DUSE_BUNDLED_BOOST:BOOL=OFF \
-DUSE_BUNDLED_SPDLOG:BOOL=OFF \
-DUSE_BUNDLED_OLM:BOOL=OFF \
-DUSE_BUNDLED_GTEST:BOOL=OFF \
-DUSE_BUNDLED_CMARK:BOOL=OFF \
-DUSE_BUNDLED_MTXCLIENT:BOOL=OFF \
-DUSE_BUNDLED_LMDB:BOOL=OFF \
-DUSE_BUNDLED_LMDBXX:BOOL=OFF \
-DUSE_BUNDLED_TWEENY:BOOL=OFF \
-DUSE_BUNDLED_JSON:BOOL=OFF \
-DUSE_BUNDLED_OPENSSL:BOOL=OFF \
-DUSE_BUNDLED_SODIUM:BOOL=OFF \
..
popd
%ninja_build -C %{_target_platform}
@ -77,6 +112,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}.desktop
%{_datadir}/icons/hicolor/*/apps/%{name}.*
%changelog
* Wed Jun 03 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 0.7.1-1
- Updated to version 0.7.1.
* Sun May 31 2020 Jonathan Wakely <jwakely@redhat.com> - 0.6.4-5
- Rebuilt for Boost 1.73

View File

@ -1 +1 @@
SHA512 (nheko-0.6.4.tar.gz) = 782673a3ae642029307517798e5be96cf0473cd4261af891988a35dfeb5e2e724d2c034407f62addd2e15973d287d11c6590d70cca739c705354cb0151536470
SHA512 (nheko-0.7.1.tar.gz) = c3f8325c865b4021709114ab7f658ae5198404242eb8761c8589d42b08d175323406a65ff0706b16a4139155ac7676e12282bce078cc0a02284ecd70a7d62bdc