added arbitrary source device and improved .measure spice command
This commit is contained in:
parent
b08147d92e
commit
6b5d886f21
@ -1 +1 @@
|
||||
ng-spice-rework-19.tar.gz
|
||||
ng-spice-rework-20.tar.gz
|
||||
|
@ -1,3 +1,4 @@
|
||||
ngspice-18-1_fc10:HEAD:ngspice-18-1.fc10.src.rpm:1231713849
|
||||
ngspice-18-2_fc10:HEAD:ngspice-18-2.fc10.src.rpm:1235260319
|
||||
ngspice-19-1_fc11:HEAD:ngspice-19-1.fc11.src.rpm:1249833090
|
||||
ngspice-20-1_fc12:HEAD:ngspice-20-1.fc12.src.rpm:1259910372
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- src/frontend/resource.c 2009-04-17 23:59:05.000000000 +0200
|
||||
+++ resource.c 2009-08-08 20:52:02.658775378 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
/**********
|
||||
Copyright 1990 Regents of the University of California. All rights reserved.
|
||||
Author: 1985 Wayne A. Christopher, U. C. Berkeley CAD Group
|
||||
-$Id: resource.c,v 1.31 2009/04/17 21:59:05 h_vogt Exp $
|
||||
+$Id: resource.c,v 1.32 2009/08/08 17:38:23 pnenzi Exp $
|
||||
**********/
|
||||
|
||||
/*
|
||||
@@ -549,7 +549,7 @@
|
||||
#endif /*_WIN32_WINNT 0x0500*/
|
||||
#else
|
||||
FILE *fp;
|
||||
- char buffer[1024];
|
||||
+ char buffer[2048];
|
||||
size_t bytes_read;
|
||||
char *match;
|
||||
long mem_got;
|
@ -1,14 +1,14 @@
|
||||
--- src/main.c 2009-04-12 23:08:18.000000000 +0200
|
||||
+++ main.c 2009-08-01 14:10:46.785485894 +0200
|
||||
@@ -566,6 +566,7 @@
|
||||
--- src/main.c 2009-10-24 08:28:09.000000000 +0200
|
||||
+++ main.c 2009-11-16 15:05:57.196403105 +0100
|
||||
@@ -553,6 +553,7 @@
|
||||
" -i, --interactive run in interactive mode\n"
|
||||
" -n, --no-spiceinit don't load the local or user's config file\n"
|
||||
" -o, --output=FILE set the outputfile\n"
|
||||
+ " -p, --pipe run in I/O pipe mode\n"
|
||||
+ " -p, --pipe run in I/O pipe mode\n"
|
||||
" -q, --completion activate command completion\n"
|
||||
" -r, --rawfile=FILE set the rawfile output\n"
|
||||
" -r, --rawfile=FILE set the rawfile output\n"
|
||||
" -s, --server run spice as a server process\n"
|
||||
@@ -772,6 +773,7 @@
|
||||
@@ -759,6 +760,7 @@
|
||||
{"interactive", 0, 0, 'i'},
|
||||
{"no-spiceinit", 0, 0, 'n'},
|
||||
{"output", 1, 0, 'o'},
|
||||
@ -16,7 +16,7 @@
|
||||
{"completion", 0, 0, 'q'},
|
||||
{"rawfile", 1, 0, 'r'},
|
||||
{"server", 0, 0, 's'},
|
||||
@@ -779,7 +781,7 @@
|
||||
@@ -766,7 +768,7 @@
|
||||
{0, 0, 0, 0}
|
||||
};
|
||||
|
||||
|
21
ngspice.spec
21
ngspice.spec
@ -1,5 +1,5 @@
|
||||
Name: ngspice
|
||||
Version: 19
|
||||
Version: 20
|
||||
Release: 1%{?dist}
|
||||
Summary: A mixed level/signal circuit simulator
|
||||
|
||||
@ -12,13 +12,12 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n
|
||||
|
||||
# Ensuring interoperability with xcircuit via Tcl
|
||||
Patch0: %{name}-xcircuit_bridge.patch
|
||||
Patch1: %{name}-rework-19.memusage_warning.patch
|
||||
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
|
||||
BuildRequires: readline-devel, libXext-devel, libpng-devel, libICE-devel
|
||||
BuildRequires: libXaw-devel, mesa-libGL-devel, libXt-devel
|
||||
BuildRequires: libXaw-devel, mesa-libGL-devel, libXt-devel, automake, libtool
|
||||
|
||||
|
||||
%description
|
||||
@ -70,7 +69,6 @@ code base with many improvements.
|
||||
%setup -q
|
||||
|
||||
%patch0 -p0 -b .xcircuit
|
||||
%patch1 -p0 -b .mem
|
||||
|
||||
# make sure the examples are UTF-8...
|
||||
for nonUTF8 in examples/tclspice/tcl-testbench4/selectfromlist.tcl \
|
||||
@ -101,12 +99,17 @@ sed -i \
|
||||
"s|spice::codemodel ../../src/xspice/icm/spice2poly|spice::codemodel %{_libdir}/tclspice/spice|" \
|
||||
examples/tclspice/tcl-testbench4/tcl-testbench4.tcl
|
||||
|
||||
%{__libtoolize} --force --copy
|
||||
%{__aclocal}
|
||||
%{__automake} --add-missing
|
||||
%{__autoconf}
|
||||
|
||||
%build
|
||||
|
||||
|
||||
# ---- Tclspice ----------------------------------------------------------------
|
||||
# Adding BLT support
|
||||
export CFLAGS="$CFLAGS -I%{_includedir}/blt"
|
||||
export CFLAGS="%{optflags} -I%{_includedir}/blt"
|
||||
|
||||
# Make builddir for tclspice
|
||||
%{__mkdir} -p tclspice
|
||||
@ -128,6 +131,7 @@ sed -i "s|\#define NGSPICEDATADIR \"\`echo \$dprefix/share/ngspice\`\"|\#define
|
||||
--enable-numparam \
|
||||
--enable-dot-global \
|
||||
--enable-shared \
|
||||
--enable-ndev \
|
||||
--with-tcl=%{_libdir}/tcl8.5/ \
|
||||
--libdir=%{_libdir}/tclspice
|
||||
|
||||
@ -148,6 +152,7 @@ cd ..
|
||||
--enable-numparam \
|
||||
--enable-dot-global \
|
||||
--enable-shared \
|
||||
--enable-ndev \
|
||||
--libdir=%{_libdir}
|
||||
|
||||
%{__make} %{?_smp_mflags}
|
||||
@ -178,6 +183,7 @@ cp -pr AUTHORS COPYING README BUGS ChangeLog NEWS %{buildroot}%{_docdir}/%{name}
|
||||
|
||||
# pull as debuginfo
|
||||
chmod +x %{buildroot}%{_libdir}/spice/*.cm
|
||||
chmod +x %{buildroot}%{_libdir}/tclspice/spice/*.cm
|
||||
|
||||
%{__rm} -rf %{buildroot}%{_datadir}/info/dir
|
||||
|
||||
@ -192,7 +198,7 @@ chmod +x %{buildroot}%{_libdir}/spice/*.cm
|
||||
/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
|
||||
|
||||
%preun doc
|
||||
/sbin/install-info --delete %{_infodir}/%{name}.info*.gz %{_infodir}/dir || :
|
||||
/sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
|
||||
|
||||
|
||||
%files
|
||||
@ -217,6 +223,9 @@ chmod +x %{buildroot}%{_libdir}/spice/*.cm
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Nov 16 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 20-1
|
||||
- new upstream release
|
||||
|
||||
* Sun Aug 02 2009 Chitlesh Goorah <chitlesh [AT] fedoraproject DOT org> 19-1
|
||||
- new upstream release
|
||||
- RHBZ #514484 A Long Warning Message (patched)
|
||||
|
Loading…
x
Reference in New Issue
Block a user