nfs-ganesha/xattr.patch
Kaleb S. KEITHLEY e796917a2d disable utils, python
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
2018-07-17 11:58:24 -04:00

30 lines
1.3 KiB
Diff

--- nfs-ganesha-2.6.2/src/CMakeLists.txt.orig 2018-07-17 11:47:09.637390285 -0400
+++ nfs-ganesha-2.6.2/src/CMakeLists.txt 2018-07-17 11:47:50.668390285 -0400
@@ -586,12 +586,12 @@
endif(NOT GFAPI_FOUND)
if(USE_FSAL_GLUSTER)
- check_include_files("unistd.h;attr/xattr.h" HAVE_XATTR_H)
+ check_include_files("unistd.h;sys/xattr.h" HAVE_XATTR_H)
if(NOT HAVE_XATTR_H)
if(STRICT_PACKAGE)
- message(FATAL_ERROR "STRICT PACKAGE: Can not find attr/xattr.h, disabling GLUSTER fsal build")
+ message(FATAL_ERROR "STRICT PACKAGE: Can not find sys/xattr.h, disabling GLUSTER fsal build")
else(STRICT_PACKAGE)
- message(WARNING "Can not find attr/xattr.h, disabling GLUSTER fsal build")
+ message(WARNING "Can not find sys/xattr.h, disabling GLUSTER fsal build")
set(USE_FSAL_GLUSTER OFF)
endif(STRICT_PACKAGE)
endif(NOT HAVE_XATTR_H)
--- nfs-ganesha-2.6.2/src/FSAL/FSAL_GLUSTER/gluster_internal.c.orig 2018-07-17 11:49:01.863390285 -0400
+++ nfs-ganesha-2.6.2/src/FSAL/FSAL_GLUSTER/gluster_internal.c 2018-07-17 11:48:32.581390285 -0400
@@ -26,7 +26,7 @@
*/
#include <sys/types.h>
-#include <attr/xattr.h> /* ENOATTR */
+#include "os/xattr.h" /* ENOATTR */
#include "gluster_internal.h"
#include "fsal_api.h"
#include "fsal_convert.h"