nfs-ganesha/0002-src-CMakeLists.txt.patch

13 lines
609 B
Diff

--- nfs-ganesha-3.0-rc5/src/CMakeLists.txt.orig 2019-11-04 06:12:36.480670795 -0500
+++ nfs-ganesha-3.0-rc5/src/CMakeLists.txt 2019-11-04 06:13:24.795670795 -0500
@@ -1033,6 +1033,9 @@
if (NOT LIBURCU)
message(FATAL_ERROR "userspace-rcu library not found!")
endif(NOT LIBURCU)
+if (CMAKE_MAJOR_VERSION VERSION_EQUAL 3 AND CMAKE_MINOR_VERSION VERSION_GREATER 14)
+ include(CheckSymbolExists)
+endif(CMAKE_MAJOR_VERSION VERSION_EQUAL 3 AND CMAKE_MINOR_VERSION VERSION_GREATER 14)
check_symbol_exists(urcu_ref_get_unless_zero urcu/ref.h HAVE_URCU_REF_GET_UNLESS_ZERO)
# All the plumbing in the basement