nfs-ganesha/nfs-ganesha-2.3rc4-CMakeLis...

63 lines
2.0 KiB
Diff

--- nfs-ganesha-2.3-rc4/src/CMakeLists.txt.orig 2015-09-28 09:41:36.169664072 -0400
+++ nfs-ganesha-2.3-rc4/src/CMakeLists.txt 2015-09-28 09:44:34.120664072 -0400
@@ -780,9 +780,12 @@
set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/portability_cmake_2.8 /usr/share/cmake/Modules ${CMAKE_MODULE_PATH})
endif( "${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" VERSION_LESS "2.8" )
+find_library(LIBNTIRPC ntirpc)
+
+set(CMAKE_C_FLAGS "-isystem /usr/include/ntirpc ${CMAKE_C_FLAGS}")
+
include_directories(
"${PROJECT_BINARY_DIR}/include"
- "${PROJECT_SOURCE_DIR}/libntirpc/ntirpc/"
"${PROJECT_SOURCE_DIR}/include"
"${OS_INCLUDE_DIR}"
"${KRB5_INCLUDE_DIRS}"
@@ -798,12 +801,6 @@
#callers add:
-# target_link_libraries(your_library ${LIBTIRPC_LIBRARIES})
-set(LIBTIRPC_INCLUDE_DIR
- "${PROJECT_BINARY_DIR}/libtirpc/ntirpc"
- "${PROJECT_BINARY_DIR}/libtirpc/ntirpc/rpc"
-)
-set(LIBTIRPC_LIBRARIES ntirpc)
# Find misc system libs
find_library(LIBRT rt) # extended Pthreads functions
@@ -931,6 +928,7 @@
${KRB5_LIBRARIES}
${CMAKE_THREAD_LIBS_INIT}
${LIBRT}
+ ${LIBNTIRPC}
)
# Config file; make sure it doesn't clobber an existing one
@@ -941,16 +939,6 @@
# pre-create PREFIX/var/run/ganesha
install(DIRECTORY DESTINATION ${SYSSTATEDIR}/run/ganesha)
-IF( NOT EXISTS ${PROJECT_SOURCE_DIR}/libntirpc/ganesha/CMakeLists.txt )
-message( FATAL_ERROR
-"No CMakeLists.txt found in libntirpc
-This probably means that the directory was not properly populated.
-Please run the following command to do that and use cmake again:
- git submodule update --init
-Alternatively, if you are not using git, get the current version at
- https://github.com/nfs-ganesha/ntirpc" )
-ENDIF( NOT EXISTS ${PROJECT_SOURCE_DIR}/libntirpc/ganesha/CMakeLists.txt )
-
add_subdirectory(log)
add_subdirectory(config_parsing)
add_subdirectory(cidr)
@@ -960,7 +948,6 @@
add_subdirectory(NodeList)
add_subdirectory(cache_inode)
add_subdirectory(SAL)
-add_subdirectory(libntirpc/ganesha)
add_subdirectory(RPCAL)
add_subdirectory(Protocols)
add_subdirectory(support)