nfs-ganesha/0002-src-CMakeLists.txt.patch

23 lines
959 B
Diff

diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cb10e10e4..a83873888 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -511,12 +511,15 @@ endif (USE_ADMIN_TOOLS)
gopt_test(USE_GUI_ADMIN_TOOLS)
if (USE_ADMIN_TOOLS)
if (USE_GUI_ADMIN_TOOLS)
- find_program(PYUIC NAMES pyuic4 DOC "PyQT UI-compiler executable")
+ find_program(PYUIC NAMES pyuic5 DOC "PyQT UI-compiler executable")
+ if (NOT PYUIC)
+ find_program(PYUIC NAMES pyuic4 DOC "PyQT UI-compiler executable")
+ endif (NOT PYUIC)
if (NOT PYUIC)
if (USE_GUI_ADMIN_TOOLS_REQUIRED)
message(FATAL_ERROR "Cannot find PyQt but GUI admin tools requested on command line")
else (USE_GUI_ADMIN_TOOLS_REQUIRED)
- message(WARNING "Cannot find PyQt4. Disabling GUI admin tools")
+ message(WARNING "Cannot find PyQt4 or PyQt5. Disabling GUI admin tools")
set(USE_GUI_ADMIN_TOOLS OFF)
endif (USE_GUI_ADMIN_TOOLS_REQUIRED)
endif (NOT PYUIC)