2.2.0-0.10rc6, with unbundled libntirpc
This commit is contained in:
parent
25354fc66f
commit
fa9d6dcdee
72
nfs-ganesha-2.2.0-CMakeLists.txt.patch
Normal file
72
nfs-ganesha-2.2.0-CMakeLists.txt.patch
Normal file
@ -0,0 +1,72 @@
|
|||||||
|
--- nfs-ganesha-2.2-rc6/src/CMakeLists.txt.orig 2015-04-01 15:33:18.887000000 -0400
|
||||||
|
+++ nfs-ganesha-2.2-rc6/src/CMakeLists.txt 2015-04-02 12:16:44.245000000 -0400
|
||||||
|
@@ -716,12 +716,15 @@
|
||||||
|
set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/portability_cmake_2.8 /usr/share/cmake/Modules ${CMAKE_MODULE_PATH})
|
||||||
|
endif( "${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" VERSION_LESS "2.8" )
|
||||||
|
|
||||||
|
+find_library(LIBNTIRPC ntirpc) # extended Pthreads functions
|
||||||
|
+set(LIBTIRPC_INCLUDE_DIR "/usr/include/ntirpc")
|
||||||
|
+
|
||||||
|
include_directories(
|
||||||
|
"${PROJECT_BINARY_DIR}/include"
|
||||||
|
- "${PROJECT_SOURCE_DIR}/libntirpc/ntirpc/"
|
||||||
|
"${PROJECT_SOURCE_DIR}/include"
|
||||||
|
"${OS_INCLUDE_DIR}"
|
||||||
|
"${KRB5_INCLUDE_DIRS}"
|
||||||
|
+ "${LIBTIRPC_INCLUDE_DIR}"
|
||||||
|
)
|
||||||
|
|
||||||
|
# Fixup loose bits of autotools legacy
|
||||||
|
@@ -732,14 +735,13 @@
|
||||||
|
set(_USE_CB_SIMULATOR ON)
|
||||||
|
endif(USE_CB_SIMULATOR)
|
||||||
|
|
||||||
|
-
|
||||||
|
#callers add:
|
||||||
|
# target_link_libraries(your_library ${LIBTIRPC_LIBRARIES})
|
||||||
|
-set(LIBTIRPC_INCLUDE_DIR
|
||||||
|
- "${PROJECT_BINARY_DIR}/libtirpc/ntirpc"
|
||||||
|
- "${PROJECT_BINARY_DIR}/libtirpc/ntirpc/rpc"
|
||||||
|
-)
|
||||||
|
-set(LIBTIRPC_LIBRARIES "${PROJECT_BINARY_DIR}/libntirpc/src/libntirpc.a")
|
||||||
|
+#set(LIBTIRPC_INCLUDE_DIR
|
||||||
|
+# "${PROJECT_BINARY_DIR}/libtirpc/ntirpc"
|
||||||
|
+# "${PROJECT_BINARY_DIR}/libtirpc/ntirpc/rpc"
|
||||||
|
+#)
|
||||||
|
+#set(LIBTIRPC_LIBRARIES "${PROJECT_BINARY_DIR}/libntirpc/src/libntirpc.a")
|
||||||
|
|
||||||
|
# Find misc system libs
|
||||||
|
find_library(LIBRT rt) # extended Pthreads functions
|
||||||
|
@@ -867,6 +869,7 @@
|
||||||
|
${KRB5_LIBRARIES}
|
||||||
|
${CMAKE_THREAD_LIBS_INIT}
|
||||||
|
${LIBRT}
|
||||||
|
+ ${LIBNTIRPC}
|
||||||
|
)
|
||||||
|
|
||||||
|
# Config file; make sure it doesn't clobber an existing one
|
||||||
|
@@ -877,16 +880,6 @@
|
||||||
|
# pre-create PREFIX/var/run/ganesha
|
||||||
|
install(DIRECTORY DESTINATION ${SYSSTATEDIR}/run/ganesha)
|
||||||
|
|
||||||
|
-IF( NOT EXISTS ${PROJECT_SOURCE_DIR}/libntirpc/CMakeLists.txt )
|
||||||
|
-message( FATAL_ERROR
|
||||||
|
-"No CMakeLists.txt found in libntirpc
|
||||||
|
-This probably means that the directory was not properly populated.
|
||||||
|
-Please run the following command to do that and use cmake again:
|
||||||
|
- git submodule update --init
|
||||||
|
-Alternatively, if you are not using git, get the current version at
|
||||||
|
- https://github.com/nfs-ganesha/ntirpc" )
|
||||||
|
-ENDIF( NOT EXISTS ${PROJECT_SOURCE_DIR}/libntirpc/CMakeLists.txt )
|
||||||
|
-
|
||||||
|
add_subdirectory(log)
|
||||||
|
add_subdirectory(config_parsing)
|
||||||
|
add_subdirectory(cidr)
|
||||||
|
@@ -896,7 +889,6 @@
|
||||||
|
add_subdirectory(NodeList)
|
||||||
|
add_subdirectory(cache_inode)
|
||||||
|
add_subdirectory(SAL)
|
||||||
|
-add_subdirectory(libntirpc)
|
||||||
|
add_subdirectory(RPCAL)
|
||||||
|
add_subdirectory(Protocols)
|
||||||
|
add_subdirectory(support)
|
@ -72,24 +72,18 @@
|
|||||||
|
|
||||||
%global dev_version %{lua: extraver = string.gsub('-rc6', '%-', ''); print(extraver) }
|
%global dev_version %{lua: extraver = string.gsub('-rc6', '%-', ''); print(extraver) }
|
||||||
|
|
||||||
%global ntirpcname ntirpc
|
|
||||||
%global ntirpcvers 1.2.1
|
|
||||||
%global versiontag 2.2-rc6
|
%global versiontag 2.2-rc6
|
||||||
|
|
||||||
Name: nfs-ganesha
|
Name: nfs-ganesha
|
||||||
Version: 2.2.0
|
Version: 2.2.0
|
||||||
Release: 0.9%{?dev_version:%{dev_version}}%{?dist}
|
Release: 0.10%{?dev_version:%{dev_version}}%{?dist}
|
||||||
Summary: NFS-Ganesha is a NFS Server running in user space
|
Summary: NFS-Ganesha is a NFS Server running in user space
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
License: LGPLv3+
|
License: LGPLv3+
|
||||||
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
|
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
|
||||||
|
|
||||||
Source0: https://github.com/%{name}/%{name}/archive/V%{versiontag}/%{name}-%{version}%{dev_version}.tar.gz
|
Source0: https://github.com/%{name}/%{name}/archive/V%{versiontag}/%{name}-%{version}%{dev_version}.tar.gz
|
||||||
Source1: https://github.com/%{name}/%{ntirpcname}/archive/v%{ntirpcvers}/%{ntirpcname}-%{ntirpcvers}.tar.gz
|
Patch0: nfs-ganesha-2.2.0-CMakeLists.txt.patch
|
||||||
|
|
||||||
# Bundling exception through Fedora 23
|
|
||||||
# https://fedorahosted.org/fpc/ticket/363
|
|
||||||
Provides: bundled(libntirpc)
|
|
||||||
|
|
||||||
%if ( 0%{?rhel} && 0%{?rhel} < 7 )
|
%if ( 0%{?rhel} && 0%{?rhel} < 7 )
|
||||||
BuildRequires: cmake28
|
BuildRequires: cmake28
|
||||||
@ -313,6 +307,7 @@ Group: Applications/System
|
|||||||
Requires: nfs-ganesha = %{version}-%{release}
|
Requires: nfs-ganesha = %{version}-%{release}
|
||||||
BuildRequires: glusterfs-api-devel >= 3.5.1
|
BuildRequires: glusterfs-api-devel >= 3.5.1
|
||||||
BuildRequires: libattr-devel
|
BuildRequires: libattr-devel
|
||||||
|
BuildRequires: libntirpc-devel
|
||||||
|
|
||||||
%description gluster
|
%description gluster
|
||||||
This package contains a FSAL shared object to
|
This package contains a FSAL shared object to
|
||||||
@ -320,9 +315,9 @@ be used with NFS-Ganesha to support Gluster
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{versiontag} -a 1
|
%setup -q -n %{name}-%{versiontag}
|
||||||
rm -rf contrib/libzfswrapper
|
rm -rf contrib/libzfswrapper
|
||||||
mv %{ntirpcname}-%{ntirpcvers}/* src/libntirpc/
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if ( 0%{?rhel} && 0%{?rhel} < 7 )
|
%if ( 0%{?rhel} && 0%{?rhel} < 7 )
|
||||||
@ -575,6 +570,9 @@ mv %{buildroot}/usr%{_sysconfdir}/ganesha/ganesha.conf %{buildroot}%{_sysconfdir
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 2 2015 Kaleb S. KEITHLEY <kkeithle at redhat.com> 2.2.0-0.10rc6
|
||||||
|
- 2.2.0-0.10rc6, with unbundled libntirpc
|
||||||
|
|
||||||
* Mon Mar 30 2015 Kaleb S. KEITHLEY <kkeithle at redhat.com> 2.2.0-0.9rc6
|
* Mon Mar 30 2015 Kaleb S. KEITHLEY <kkeithle at redhat.com> 2.2.0-0.9rc6
|
||||||
- 2.2.0-0.9rc6
|
- 2.2.0-0.9rc6
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user