PyQt4 -> PyQt5

Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
Kaleb S. KEITHLEY 2019-09-25 10:21:26 -04:00
commit e714866557
2 changed files with 32 additions and 1 deletions

View File

@ -0,0 +1,22 @@
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cb10e10e4..a83873888 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -511,12 +511,15 @@ endif (USE_ADMIN_TOOLS)
gopt_test(USE_GUI_ADMIN_TOOLS)
if (USE_ADMIN_TOOLS)
if (USE_GUI_ADMIN_TOOLS)
- find_program(PYUIC NAMES pyuic4 DOC "PyQT UI-compiler executable")
+ find_program(PYUIC NAMES pyuic5 DOC "PyQT UI-compiler executable")
+ if (NOT PYUIC)
+ find_program(PYUIC NAMES pyuic4 DOC "PyQT UI-compiler executable")
+ endif (NOT PYUIC)
if (NOT PYUIC)
if (USE_GUI_ADMIN_TOOLS_REQUIRED)
message(FATAL_ERROR "Cannot find PyQt but GUI admin tools requested on command line")
else (USE_GUI_ADMIN_TOOLS_REQUIRED)
- message(WARNING "Cannot find PyQt4. Disabling GUI admin tools")
+ message(WARNING "Cannot find PyQt4 or PyQt5. Disabling GUI admin tools")
set(USE_GUI_ADMIN_TOOLS OFF)
endif (USE_GUI_ADMIN_TOOLS_REQUIRED)
endif (NOT PYUIC)

View File

@ -131,13 +131,14 @@ Requires: openSUSE-release
Name: nfs-ganesha
Version: 2.8.2
Release: 5%{?dev:%{dev}}%{?dist}
Release: 6%{?dev:%{dev}}%{?dist}
Summary: NFS-Ganesha is a NFS Server running in user space
License: LGPLv3+
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
Source0: https://github.com/%{name}/%{name}/archive/V%{version}/%{name}-%{version}.tar.gz
Patch0001: 0001-src-scripts-gpfs-epoch.patch
Patch0002: 0002-src-CMakeLists.txt.patch
BuildRequires: cmake
BuildRequires: bison
@ -285,9 +286,13 @@ BuildRequires: python2-devel
%if ( 0%{?suse_version} )
BuildRequires: python-qt4-devel
%else
%if ( 0%{?fedora} >= 31 || 0%{?rhel} >= 8 )
BuildRequires: python3-PyQt5-devel
%else
BuildRequires: python3-PyQt4-devel
%endif
%endif
%endif
%description utils
This package contains utility scripts for managing the NFS-GANESHA server
@ -493,6 +498,7 @@ Development headers and auxiliary files for developing with %{name}.
%prep
%setup -q -n %{name}-%{version}
%patch0001 -p1
%patch0002 -p1
%build
cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
@ -868,6 +874,9 @@ exit 0
%endif
%changelog
* Wed Sep 25 2019 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 2.8.2-6
- PyQt4 -> PyQt5
* Wed Aug 14 2019 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 2.8.2-5
- nfs-ganesha 2.8.2, remove Requires: nfs-ganesha-gpfs from utils