- Rebuilt for libntirpc-3.5
- plus https://src.fedoraproject.org/rpms/nfs-ganesha/pull-request/2
This commit is contained in:
parent
32896262e9
commit
df8718b521
16
0001-config_samples-log_rotate.patch
Normal file
16
0001-config_samples-log_rotate.patch
Normal file
@ -0,0 +1,16 @@
|
||||
--- nfs-ganesha-3.5/src/config_samples/logrotate_ganesha.orig 2021-06-11 11:05:49.699522427 -0400
|
||||
+++ nfs-ganesha-3.5/src/config_samples/logrotate_ganesha 2021-06-11 11:06:18.362010100 -0400
|
||||
@@ -1,4 +1,5 @@
|
||||
/var/log/ganesha/ganesha.log {
|
||||
+ su ganesha ganesha
|
||||
weekly
|
||||
rotate 52
|
||||
copytruncate
|
||||
--- nfs-ganesha-3.5/src/config_samples/logrotate_fsal_gluster.orig 2021-06-11 11:05:59.857340860 -0400
|
||||
+++ nfs-ganesha-3.5/src/config_samples/logrotate_fsal_gluster 2021-06-11 11:06:22.785931021 -0400
|
||||
@@ -1,4 +1,5 @@
|
||||
/var/log/ganesha/ganesha-gfapi.log {
|
||||
+ su ganesha ganesha
|
||||
weekly
|
||||
rotate 52
|
||||
copytruncate
|
@ -1,108 +0,0 @@
|
||||
From bf842d0cf9ae13408e20963c977d3c85642a69b3 Mon Sep 17 00:00:00 2001
|
||||
From: "Kaleb S. KEITHLEY" <kkeithle@redhat.com>
|
||||
Date: Thu, 18 Jun 2020 09:38:13 -0400
|
||||
Subject: [PATCH] systemd: revised drop-in conf file handling
|
||||
|
||||
see https://bugzilla.redhat.com/show_bug.cgi?id=1848208
|
||||
|
||||
systemd service file documentation still sucks rocks
|
||||
|
||||
This is my current best guess, and at least it doesn't log errors
|
||||
|
||||
Change-Id: Iec9847356090e561bfcd5f41a64b35c2e686a3d6
|
||||
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
|
||||
---
|
||||
src/nfs-ganesha.spec-in.cmake | 6 +++---
|
||||
src/scripts/systemd/nfs-ganesha-lock.service.debian10 | 2 +-
|
||||
src/scripts/systemd/nfs-ganesha-lock.service.el8 | 2 +-
|
||||
src/scripts/systemd/rpc-statd.conf.debian10 | 2 +-
|
||||
src/scripts/systemd/rpc-statd.conf.el8 | 2 +-
|
||||
5 files changed, 7 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/src/nfs-ganesha.spec-in.cmake b/src/nfs-ganesha.spec-in.cmake
|
||||
index 9cfda6c0e..d66106d6f 100644
|
||||
--- a/src/nfs-ganesha.spec-in.cmake
|
||||
+++ b/src/nfs-ganesha.spec-in.cmake
|
||||
@@ -557,13 +557,13 @@ install -m 644 config_samples/vfs.conf %{buildroot}%{_sysconfdir}/ganesha
|
||||
|
||||
mkdir -p %{buildroot}%{_unitdir}
|
||||
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
|
||||
-mkdir -p %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha.d
|
||||
+mkdir -p %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d
|
||||
%endif
|
||||
|
||||
install -m 644 scripts/systemd/nfs-ganesha.service.el7 %{buildroot}%{_unitdir}/nfs-ganesha.service
|
||||
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
|
||||
install -m 644 scripts/systemd/nfs-ganesha-lock.service.el8 %{buildroot}%{_unitdir}/nfs-ganesha-lock.service
|
||||
-install -m 644 scripts/systemd/rpc-statd.conf.el8 %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha.d/rpc-statd.conf
|
||||
+install -m 644 scripts/systemd/rpc-statd.conf.el8 %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d/rpc-statd.conf
|
||||
%else
|
||||
install -m 644 scripts/systemd/nfs-ganesha-lock.service.el7 %{buildroot}%{_unitdir}/nfs-ganesha-lock.service
|
||||
%endif
|
||||
@@ -677,7 +677,7 @@ exit 0
|
||||
%{_unitdir}/nfs-ganesha-lock.service
|
||||
%{_unitdir}/nfs-ganesha-config.service
|
||||
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
|
||||
-%{_sysconfdir}/systemd/system/nfs-ganesha.d/rpc-statd.conf
|
||||
+%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d/rpc-statd.conf
|
||||
%endif
|
||||
|
||||
%if %{with man_page}
|
||||
diff --git a/src/scripts/systemd/nfs-ganesha-lock.service.debian10 b/src/scripts/systemd/nfs-ganesha-lock.service.debian10
|
||||
index 67af058fe..da06ef4fe 100644
|
||||
--- a/src/scripts/systemd/nfs-ganesha-lock.service.debian10
|
||||
+++ b/src/scripts/systemd/nfs-ganesha-lock.service.debian10
|
||||
@@ -17,7 +17,7 @@
|
||||
|
||||
[Unit]
|
||||
Before=nfs-ganesha.service
|
||||
-Conflicts=nfs-lock.service rpc-statd.service
|
||||
+Conflicts=nfs-lock.service
|
||||
|
||||
[Service]
|
||||
ExecStartPre=
|
||||
diff --git a/src/scripts/systemd/nfs-ganesha-lock.service.el8 b/src/scripts/systemd/nfs-ganesha-lock.service.el8
|
||||
index 67af058fe..da06ef4fe 100644
|
||||
--- a/src/scripts/systemd/nfs-ganesha-lock.service.el8
|
||||
+++ b/src/scripts/systemd/nfs-ganesha-lock.service.el8
|
||||
@@ -17,7 +17,7 @@
|
||||
|
||||
[Unit]
|
||||
Before=nfs-ganesha.service
|
||||
-Conflicts=nfs-lock.service rpc-statd.service
|
||||
+Conflicts=nfs-lock.service
|
||||
|
||||
[Service]
|
||||
ExecStartPre=
|
||||
diff --git a/src/scripts/systemd/rpc-statd.conf.debian10 b/src/scripts/systemd/rpc-statd.conf.debian10
|
||||
index 2138f7467..d06fffd4c 100644
|
||||
--- a/src/scripts/systemd/rpc-statd.conf.debian10
|
||||
+++ b/src/scripts/systemd/rpc-statd.conf.debian10
|
||||
@@ -13,7 +13,7 @@ After=nfs-config.service
|
||||
[Service]
|
||||
EnvironmentFile=-/run/sysconfig/nfs-utils
|
||||
Type=forking
|
||||
-PIDFile=/var/run/rpc.statd.pid
|
||||
+PIDFile=/run/rpc.statd.pid
|
||||
ExecStart=/sbin/rpc.statd --no-notify $STATDARGS
|
||||
|
||||
[Install]
|
||||
diff --git a/src/scripts/systemd/rpc-statd.conf.el8 b/src/scripts/systemd/rpc-statd.conf.el8
|
||||
index 6fec09af1..b67cfdf24 100644
|
||||
--- a/src/scripts/systemd/rpc-statd.conf.el8
|
||||
+++ b/src/scripts/systemd/rpc-statd.conf.el8
|
||||
@@ -1,3 +1,4 @@
|
||||
+[Unit]
|
||||
Description=NFS status monitor for NFSv2/3 locking.
|
||||
DefaultDependencies=no
|
||||
Conflicts=umount.target
|
||||
@@ -10,5 +11,5 @@
|
||||
[Service]
|
||||
Environment=RPC_STATD_NO_NOTIFY=1
|
||||
Type=forking
|
||||
-PIDFile=/var/run/rpc.statd.pid
|
||||
+PIDFile=/run/rpc.statd.pid
|
||||
ExecStart=/usr/sbin/rpc.statd
|
||||
--
|
||||
2.26.2
|
||||
|
@ -1,17 +0,0 @@
|
||||
diff --git a/src/selinux/ganesha.te b/src/selinux/ganesha.te
|
||||
index 246f9cc8c..6692eedf2 100644
|
||||
--- a/src/selinux/ganesha.te
|
||||
+++ b/src/selinux/ganesha.te
|
||||
@@ -307,3 +307,12 @@ allow ganesha_t self:capability { fowner setgid setuid };
|
||||
# allow ganesha_t glusterd_brick_t:dir { add_name getattr open read write remove_name search };
|
||||
# allow ganesha_t glusterd_brick_t:file { create getattr open read write unlink };
|
||||
|
||||
+########################################
|
||||
+#
|
||||
+# ganesha local policy rhbz#1855350
|
||||
+
|
||||
+ifdef(`ceph_read_lib_files',`
|
||||
+ optional_policy(`
|
||||
+ ceph_read_lib_files(ganesha_t)
|
||||
+ ')
|
||||
+')
|
@ -115,12 +115,13 @@ Requires: openSUSE-release
|
||||
|
||||
Name: nfs-ganesha
|
||||
Version: 3.5
|
||||
Release: 5%{?dev:%{dev}}%{?dist}
|
||||
Release: 6%{?dev:%{dev}}%{?dist}
|
||||
Summary: NFS-Ganesha is a NFS Server running in user space
|
||||
License: LGPLv3+
|
||||
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
|
||||
|
||||
Source0: https://github.com/%{name}/%{name}/archive/V%{version}%{?dev:-%{dev}}/%{name}-%{version}%{?dev:-%{dev}}.tar.gz
|
||||
Patch0001: 0001-config_samples-log_rotate.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: make
|
||||
@ -155,7 +156,7 @@ BuildRequires: libwbclient-devel
|
||||
%endif
|
||||
BuildRequires: gcc-c++
|
||||
%if ( %{with_system_ntirpc} )
|
||||
BuildRequires: libntirpc-devel = 3.4
|
||||
BuildRequires: libntirpc-devel >= 3.4
|
||||
%else
|
||||
Requires: libntirpc = @NTIRPC_VERSION_EMBED@
|
||||
%endif
|
||||
@ -496,10 +497,12 @@ Development headers and auxiliary files for developing with %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{?dev:-%{dev}}
|
||||
%patch0001 -p1
|
||||
|
||||
%build
|
||||
cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||
-DBUILD_CONFIG=rpmbuild \
|
||||
-DCMAKE_COLOR_MAKEFILE:BOOL=OFF \
|
||||
-DUSE_FSAL_NULL=%{use_fsal_null} \
|
||||
-DUSE_FSAL_MEM=%{use_fsal_mem} \
|
||||
-DUSE_FSAL_XFS=%{use_fsal_xfs} \
|
||||
@ -530,6 +533,7 @@ cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||
%endif
|
||||
|
||||
export VERBOSE=1
|
||||
export GCC_COLORS=
|
||||
%cmake_build
|
||||
|
||||
%if ( 0%{?fedora} >= 30 || 0%{?rhel} >= 8 )
|
||||
@ -860,6 +864,10 @@ exit 0
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed June 16 2021 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.5-6
|
||||
- Rebuilt for libntirpc-3.5
|
||||
- plus https://src.fedoraproject.org/rpms/nfs-ganesha/pull-request/2
|
||||
|
||||
* Tue Jun 8 2021 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.5-5
|
||||
- Rebuilt for userspace-rcu-0.13
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user