nfs-ganesha 3.0 RC5

Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
Kaleb S. KEITHLEY 2019-11-04 06:20:19 -05:00
parent 79bb7eee69
commit de44192b1b
3 changed files with 12 additions and 31 deletions

View File

@ -8,4 +8,3 @@
+ REQUIRED_VARS NTIRPC_INCLUDE_DIR NTIRPC_LIBRARY + REQUIRED_VARS NTIRPC_INCLUDE_DIR NTIRPC_LIBRARY
VERSION_VAR NTIRPC_VERSION) VERSION_VAR NTIRPC_VERSION)
# VERSION FPHSA options not handled by CMake version < 2.8.2) # VERSION FPHSA options not handled by CMake version < 2.8.2)
# VERSION_VAR)

View File

@ -1,8 +0,0 @@
--- nfs-ganesha-2.8.2/src/scripts/gpfs-epoch.orig 2019-08-14 09:55:02.130227995 -0400
+++ nfs-ganesha-2.8.2/src/scripts/gpfs-epoch 2019-08-14 09:55:13.982227995 -0400
@@ -1,4 +1,4 @@
-#!/usr/bin/python2
+#!/usr/bin/python3
# Usually ganesha daemon start up time is used as its epoch. This is
# fine for a single node configurations, but in clustered environment,

View File

@ -1,22 +1,12 @@
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt --- nfs-ganesha-3.0-rc5/src/CMakeLists.txt.orig 2019-11-04 06:12:36.480670795 -0500
index cb10e10e4..a83873888 100644 +++ nfs-ganesha-3.0-rc5/src/CMakeLists.txt 2019-11-04 06:13:24.795670795 -0500
--- a/src/CMakeLists.txt @@ -1033,6 +1033,9 @@
+++ b/src/CMakeLists.txt if (NOT LIBURCU)
@@ -511,12 +511,15 @@ endif (USE_ADMIN_TOOLS) message(FATAL_ERROR "userspace-rcu library not found!")
gopt_test(USE_GUI_ADMIN_TOOLS) endif(NOT LIBURCU)
if (USE_ADMIN_TOOLS) +if (CMAKE_MAJOR_VERSION VERSION_EQUAL 3 AND CMAKE_MINOR_VERSION VERSION_GREATER 14)
if (USE_GUI_ADMIN_TOOLS) + include(CheckSymbolExists)
- find_program(PYUIC NAMES pyuic4 DOC "PyQT UI-compiler executable") +endif(CMAKE_MAJOR_VERSION VERSION_EQUAL 3 AND CMAKE_MINOR_VERSION VERSION_GREATER 14)
+ find_program(PYUIC NAMES pyuic5 DOC "PyQT UI-compiler executable") check_symbol_exists(urcu_ref_get_unless_zero urcu/ref.h HAVE_URCU_REF_GET_UNLESS_ZERO)
+ if (NOT PYUIC)
+ find_program(PYUIC NAMES pyuic4 DOC "PyQT UI-compiler executable") # All the plumbing in the basement
+ endif (NOT PYUIC)
if (NOT PYUIC)
if (USE_GUI_ADMIN_TOOLS_REQUIRED)
message(FATAL_ERROR "Cannot find PyQt but GUI admin tools requested on command line")
else (USE_GUI_ADMIN_TOOLS_REQUIRED)
- message(WARNING "Cannot find PyQt4. Disabling GUI admin tools")
+ message(WARNING "Cannot find PyQt4 or PyQt5. Disabling GUI admin tools")
set(USE_GUI_ADMIN_TOOLS OFF)
endif (USE_GUI_ADMIN_TOOLS_REQUIRED)
endif (NOT PYUIC)