nfs-ganesha 2.7.3, enable utils w/ python2 on f30 and up
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
parent
c19e20e90e
commit
d73e4a2278
10
0001_src_scripts_ganeshactl_CMakeLists.txt.patch
Normal file
10
0001_src_scripts_ganeshactl_CMakeLists.txt.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- nfs-ganesha-2.7.3/src/scripts/ganeshactl/CMakeLists.txt.orig 2019-05-16 11:24:41.621105054 -0400
|
||||
+++ nfs-ganesha-2.7.3/src/scripts/ganeshactl/CMakeLists.txt 2019-05-16 11:24:51.351105054 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
# Building and packaging DBUS scripts for ganesha
|
||||
|
||||
-find_program(PYTHON "python")
|
||||
+find_program(PYTHON "python2")
|
||||
|
||||
# PyQT based class modules
|
||||
set(GANESHA_BASE_SRCS
|
@ -83,10 +83,10 @@ Requires: openSUSE-release
|
||||
%bcond_without lttng
|
||||
%global use_lttng %{on_off_switch lttng}
|
||||
|
||||
%bcond_with utils
|
||||
%bcond_without utils
|
||||
%global use_utils %{on_off_switch utils}
|
||||
|
||||
%bcond_with gui_utils
|
||||
%bcond_without gui_utils
|
||||
%global use_gui_utils %{on_off_switch gui_utils}
|
||||
|
||||
%bcond_without system_ntirpc
|
||||
@ -128,12 +128,13 @@ Requires: openSUSE-release
|
||||
|
||||
Name: nfs-ganesha
|
||||
Version: 2.7.3
|
||||
Release: 2%{?dev:%{dev}}%{?dist}
|
||||
Release: 3%{?dev:%{dev}}%{?dist}
|
||||
Summary: NFS-Ganesha is a NFS Server running in user space
|
||||
License: LGPLv3+
|
||||
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
|
||||
|
||||
Source0: https://github.com/%{name}/%{name}/archive/V%{version}/%{name}-%{version}.tar.gz
|
||||
Patch1: 0001_src_scripts_ganeshactl_CMakeLists.txt.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: bison
|
||||
@ -277,6 +278,7 @@ Requires: PyQt4
|
||||
BuildRequires: python2-devel
|
||||
Requires: nfs-ganesha = %{version}-%{release}, python
|
||||
%else
|
||||
BuildRequires: python-unversioned-command
|
||||
BuildRequires: python2-devel
|
||||
Requires: nfs-ganesha = %{version}-%{release}, python2
|
||||
%endif
|
||||
@ -484,6 +486,7 @@ Development headers and auxiliary files for developing with %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||
@ -848,6 +851,9 @@ exit 0
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu May 16 2019 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 2.7.3-3
|
||||
- nfs-ganesha 2.7.3, enable utils w/ python2 on f30 and up
|
||||
|
||||
* Fri May 10 2019 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 2.7.3-2
|
||||
- nfs-ganesha 2.7.3, selinux bz#1706462
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user