nfs-ganesha 2.7.4 GA
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
parent
022276c49e
commit
d717b7c667
@ -1,10 +1,10 @@
|
|||||||
--- nfs-ganesha-2.7.3/src/scripts/ganeshactl/CMakeLists.txt.orig 2019-05-16 11:24:41.621105054 -0400
|
--- nfs-ganesha-2.7.4/src/scripts/ganeshactl/CMakeLists.txt.orig 2019-06-05 17:58:40.943933814 -0400
|
||||||
+++ nfs-ganesha-2.7.3/src/scripts/ganeshactl/CMakeLists.txt 2019-05-16 11:24:51.351105054 -0400
|
+++ nfs-ganesha-2.7.4/src/scripts/ganeshactl/CMakeLists.txt 2019-06-05 17:59:26.653933814 -0400
|
||||||
@@ -1,6 +1,6 @@
|
@@ -1,6 +1,6 @@
|
||||||
# Building and packaging DBUS scripts for ganesha
|
# Building and packaging DBUS scripts for ganesha
|
||||||
|
|
||||||
-find_program(PYTHON "python")
|
-find_program(PYTHON NAMES "python" "python3")
|
||||||
+find_program(PYTHON "python2")
|
+find_program(PYTHON NAMES "python2")
|
||||||
|
|
||||||
# PyQT based class modules
|
# PyQT based class modules
|
||||||
set(GANESHA_BASE_SRCS
|
set(GANESHA_BASE_SRCS
|
||||||
|
@ -80,7 +80,7 @@ Requires: openSUSE-release
|
|||||||
|
|
||||||
%bcond_with jemalloc
|
%bcond_with jemalloc
|
||||||
|
|
||||||
%bcond_without lttng
|
%bcond_with lttng
|
||||||
%global use_lttng %{on_off_switch lttng}
|
%global use_lttng %{on_off_switch lttng}
|
||||||
|
|
||||||
%bcond_without utils
|
%bcond_without utils
|
||||||
@ -127,14 +127,14 @@ Requires: openSUSE-release
|
|||||||
#%%global dash_dev_version 2.6-rc5
|
#%%global dash_dev_version 2.6-rc5
|
||||||
|
|
||||||
Name: nfs-ganesha
|
Name: nfs-ganesha
|
||||||
Version: 2.7.3
|
Version: 2.7.4
|
||||||
Release: 4%{?dev:%{dev}}%{?dist}
|
Release: 1%{?dev:%{dev}}%{?dist}
|
||||||
Summary: NFS-Ganesha is a NFS Server running in user space
|
Summary: NFS-Ganesha is a NFS Server running in user space
|
||||||
License: LGPLv3+
|
License: LGPLv3+
|
||||||
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
|
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
|
||||||
|
|
||||||
Source0: https://github.com/%{name}/%{name}/archive/V%{version}/%{name}-%{version}.tar.gz
|
Source0: https://github.com/%{name}/%{name}/archive/V%{version}/%{name}-%{version}.tar.gz
|
||||||
Patch1: 0001_src_scripts_ganeshactl_CMakeLists.txt.patch
|
Patch1: 0001_src_scripts_ganeshactl_CMakeLists.txt.patch
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
@ -164,7 +164,7 @@ BuildRequires: libwbclient-devel
|
|||||||
%endif
|
%endif
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
%if ( %{with_system_ntirpc} )
|
%if ( %{with_system_ntirpc} )
|
||||||
BuildRequires: libntirpc-devel >= 1.7.2
|
BuildRequires: libntirpc-devel >= 1.7.4
|
||||||
%else
|
%else
|
||||||
Requires: libntirpc = @NTIRPC_VERSION_EMBED@
|
Requires: libntirpc = @NTIRPC_VERSION_EMBED@
|
||||||
%endif
|
%endif
|
||||||
@ -278,7 +278,6 @@ Requires: PyQt4
|
|||||||
BuildRequires: python2-devel
|
BuildRequires: python2-devel
|
||||||
Requires: nfs-ganesha = %{version}-%{release}, python
|
Requires: nfs-ganesha = %{version}-%{release}, python
|
||||||
%else
|
%else
|
||||||
BuildRequires: python-unversioned-command
|
|
||||||
BuildRequires: python2-devel
|
BuildRequires: python2-devel
|
||||||
Requires: nfs-ganesha = %{version}-%{release}, python2
|
Requires: nfs-ganesha = %{version}-%{release}, python2
|
||||||
%endif
|
%endif
|
||||||
@ -851,6 +850,9 @@ exit 0
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 5 2019 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 2.7.4-1
|
||||||
|
- nfs-ganesha 2.7.4 GA
|
||||||
|
|
||||||
* Fri May 17 2019 Miro Hrončok <mhroncok@redhat.com> - 2.7.3-4
|
* Fri May 17 2019 Miro Hrončok <mhroncok@redhat.com> - 2.7.3-4
|
||||||
- Avoid unversioned Python requires
|
- Avoid unversioned Python requires
|
||||||
|
|
||||||
|
1
sources
1
sources
@ -1 +1,2 @@
|
|||||||
SHA512 (nfs-ganesha-2.7.3.tar.gz) = 9259860502ad77aec105a1d3ae5d37f34db39227c100b74fd88a6b1a45d517b290baf12538f8bc939ae4c04e07b9022ce617c31d956f69afe36cc91baf702164
|
SHA512 (nfs-ganesha-2.7.3.tar.gz) = 9259860502ad77aec105a1d3ae5d37f34db39227c100b74fd88a6b1a45d517b290baf12538f8bc939ae4c04e07b9022ce617c31d956f69afe36cc91baf702164
|
||||||
|
SHA512 (nfs-ganesha-2.7.4.tar.gz) = 8b8d4fd3bfc332922c9e914df1aa757de4bf24cd8508a892d697c274b285933c94090e3aaf47cd5c2a672c090bd2187b2211535cba4c433e2a658397ce51b1b5
|
||||||
|
Loading…
Reference in New Issue
Block a user