2.3.0 RC5 w/ CMakeLists.txt.patch and config-h.in.cmake.patch
This commit is contained in:
parent
302dfa5b93
commit
d094224413
20
nfs-ganesha-2.3rc5-CMakeLists.txt.patch
Normal file
20
nfs-ganesha-2.3rc5-CMakeLists.txt.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- nfs-ganesha-2.3-rc5/src/CMakeLists.txt.orig 2015-10-05 07:32:38.294664072 -0400
|
||||
+++ nfs-ganesha-2.3-rc5/src/CMakeLists.txt 2015-10-08 14:20:40.238664072 -0400
|
||||
@@ -20,7 +20,7 @@
|
||||
set(GANESHA_MINOR_VERSION 3)
|
||||
|
||||
# needs to come after project()
|
||||
-IF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
|
||||
+IF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT OR CMAKE_INSTALL_PREFIX STREQUAL "/usr")
|
||||
SET(CMAKE_INSTALL_PREFIX "/usr" CACHE PATH "Install prefix for common files" FORCE)
|
||||
message(STATUS "override default CMAKE_INSTALL_PREFIX = ${CMAKE_INSTALL_PREFIX}")
|
||||
SET(SYSCONFDIR "/etc" CACHE PATH "Install prefix for common files" FORCE)
|
||||
@@ -29,7 +29,7 @@
|
||||
message(STATUS "was set CMAKE_INSTALL_PREFIX = ${CMAKE_INSTALL_PREFIX}")
|
||||
SET(SYSCONFDIR "${CMAKE_INSTALL_PREFIX}/etc" CACHE PATH "Install prefix for common files" FORCE)
|
||||
SET(SYSSTATEDIR "${CMAKE_INSTALL_PREFIX}/var" CACHE PATH "Install prefix for common files" FORCE)
|
||||
-ENDIF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
|
||||
+ENDIF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT OR CMAKE_INSTALL_PREFIX STREQUAL "/usr")
|
||||
# Patch level is always ".0" for mainline (master). It is blank for development.
|
||||
# When starting a stable maintenance branch, this becomes ".N"
|
||||
# where N is monotonically increasing starting at 1. Remember to include the "." !!
|
11
nfs-ganesha-2.3rc5-include-config-h.in.cmake.patch
Normal file
11
nfs-ganesha-2.3rc5-include-config-h.in.cmake.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- nfs-ganesha-2.3-rc5/src/include/config-h.in.cmake.orig 2015-10-08 15:04:29.232664072 -0400
|
||||
+++ nfs-ganesha-2.3-rc5/src/include/config-h.in.cmake 2015-10-08 15:04:45.637664072 -0400
|
||||
@@ -14,7 +14,7 @@
|
||||
#define _GIT_HEAD_COMMIT "@_GIT_HEAD_COMMIT@"
|
||||
#define _GIT_DESCRIBE "@_GIT_DESCRIBE@"
|
||||
#define BUILD_HOST "@BUILD_HOST_NAME@"
|
||||
-#define FSAL_MODULE_LOC "@MODULES_PATH@/@FSAL_DESTINATION@"
|
||||
+#define FSAL_MODULE_LOC "@FSAL_DESTINATION@"
|
||||
/* Build controls */
|
||||
|
||||
#cmakedefine _MSPAC_SUPPORT 1
|
@ -82,14 +82,16 @@
|
||||
|
||||
Name: nfs-ganesha
|
||||
Version: 2.3.0
|
||||
Release: 0.8%{?dev_version:%{dev_version}}%{?dist}
|
||||
Release: 0.9%{?dev_version:%{dev_version}}%{?dist}
|
||||
Summary: NFS-Ganesha is a NFS Server running in user space
|
||||
Group: Applications/System
|
||||
License: LGPLv3+
|
||||
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
|
||||
|
||||
Source0: https://github.com/%{name}/%{name}/archive/V%{versiontag}/%{name}-%{versiontag}.tar.gz
|
||||
Patch0: nfs-ganesha-2.3rc5-CMakeLists.txt.patch
|
||||
Patch1: nfs-ganesha-2.3rc5-scripts-ganeshactl-CMakeLists.txt.patch
|
||||
Patch2: nfs-ganesha-2.3rc5-include-config-h.in.cmake.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: bison
|
||||
@ -327,7 +329,9 @@ be used with NFS-Ganesha to support Gluster
|
||||
%prep
|
||||
%setup -q -n %{name}-%{versiontag}
|
||||
rm -rf contrib/libzfswrapper
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
cd src && %cmake . -DCMAKE_BUILD_TYPE=Debug \
|
||||
@ -421,7 +425,6 @@ install -m 755 scripts/init.d/nfs-ganesha.gpfs %{buildroot}%{_sysconfdir}/init.
|
||||
%endif
|
||||
|
||||
make DESTDIR=%{buildroot} install
|
||||
mv %{buildroot}/usr/%{_sysconfdir}/ganesha/* %{buildroot}/%{_sysconfdir}/ganesha
|
||||
|
||||
%post
|
||||
%if %{with_systemd}
|
||||
@ -584,6 +587,9 @@ mv %{buildroot}/usr/%{_sysconfdir}/ganesha/* %{buildroot}/%{_sysconfdir}/ganesha
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Oct 8 2015 Kaleb S. KEITHLEY <kkeithle at redhat.com> 2.3.0-0.9rc5
|
||||
- 2.3.0 RC5 w/ CMakeLists.txt.patch and config-h.in.cmake.patch
|
||||
|
||||
* Wed Oct 7 2015 Kaleb S. KEITHLEY <kkeithle at redhat.com> 2.3.0-0.8rc5
|
||||
- 2.3.0 RC5 mount-9p w/o Requires: nfs-ganesha
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user