2.3.0 RC4
This commit is contained in:
parent
7167f8c99b
commit
b54dd93806
@ -5,6 +5,6 @@
|
||||
install(
|
||||
CODE
|
||||
- "execute_process(WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${PYTHON} ${SETUP_PY} install --skip-build --prefix=$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX})"
|
||||
+ "execute_process(WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${PYTHON} ${SETUP_PY} install --skip-build --prefix=${DESTDIR})"
|
||||
+ "execute_process(WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${PYTHON} ${SETUP_PY} install --skip-build --prefix=${DESTDIR}${CMAKE_INSTALL_PREFIX})"
|
||||
)
|
||||
endif(PYTHON)
|
||||
|
62
nfs-ganesha-2.3rc4-CMakeLists.txt.patch
Normal file
62
nfs-ganesha-2.3rc4-CMakeLists.txt.patch
Normal file
@ -0,0 +1,62 @@
|
||||
--- nfs-ganesha-2.3-rc4/src/CMakeLists.txt.orig 2015-09-28 09:41:36.169664072 -0400
|
||||
+++ nfs-ganesha-2.3-rc4/src/CMakeLists.txt 2015-09-28 09:44:34.120664072 -0400
|
||||
@@ -780,9 +780,12 @@
|
||||
set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/portability_cmake_2.8 /usr/share/cmake/Modules ${CMAKE_MODULE_PATH})
|
||||
endif( "${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" VERSION_LESS "2.8" )
|
||||
|
||||
+find_library(LIBNTIRPC ntirpc)
|
||||
+
|
||||
+set(CMAKE_C_FLAGS "-isystem /usr/include/ntirpc ${CMAKE_C_FLAGS}")
|
||||
+
|
||||
include_directories(
|
||||
"${PROJECT_BINARY_DIR}/include"
|
||||
- "${PROJECT_SOURCE_DIR}/libntirpc/ntirpc/"
|
||||
"${PROJECT_SOURCE_DIR}/include"
|
||||
"${OS_INCLUDE_DIR}"
|
||||
"${KRB5_INCLUDE_DIRS}"
|
||||
@@ -798,12 +801,6 @@
|
||||
|
||||
|
||||
#callers add:
|
||||
-# target_link_libraries(your_library ${LIBTIRPC_LIBRARIES})
|
||||
-set(LIBTIRPC_INCLUDE_DIR
|
||||
- "${PROJECT_BINARY_DIR}/libtirpc/ntirpc"
|
||||
- "${PROJECT_BINARY_DIR}/libtirpc/ntirpc/rpc"
|
||||
-)
|
||||
-set(LIBTIRPC_LIBRARIES ntirpc)
|
||||
|
||||
# Find misc system libs
|
||||
find_library(LIBRT rt) # extended Pthreads functions
|
||||
@@ -931,6 +928,7 @@
|
||||
${KRB5_LIBRARIES}
|
||||
${CMAKE_THREAD_LIBS_INIT}
|
||||
${LIBRT}
|
||||
+ ${LIBNTIRPC}
|
||||
)
|
||||
|
||||
# Config file; make sure it doesn't clobber an existing one
|
||||
@@ -941,16 +939,6 @@
|
||||
# pre-create PREFIX/var/run/ganesha
|
||||
install(DIRECTORY DESTINATION ${SYSSTATEDIR}/run/ganesha)
|
||||
|
||||
-IF( NOT EXISTS ${PROJECT_SOURCE_DIR}/libntirpc/ganesha/CMakeLists.txt )
|
||||
-message( FATAL_ERROR
|
||||
-"No CMakeLists.txt found in libntirpc
|
||||
-This probably means that the directory was not properly populated.
|
||||
-Please run the following command to do that and use cmake again:
|
||||
- git submodule update --init
|
||||
-Alternatively, if you are not using git, get the current version at
|
||||
- https://github.com/nfs-ganesha/ntirpc" )
|
||||
-ENDIF( NOT EXISTS ${PROJECT_SOURCE_DIR}/libntirpc/ganesha/CMakeLists.txt )
|
||||
-
|
||||
add_subdirectory(log)
|
||||
add_subdirectory(config_parsing)
|
||||
add_subdirectory(cidr)
|
||||
@@ -960,7 +948,6 @@
|
||||
add_subdirectory(NodeList)
|
||||
add_subdirectory(cache_inode)
|
||||
add_subdirectory(SAL)
|
||||
-add_subdirectory(libntirpc/ganesha)
|
||||
add_subdirectory(RPCAL)
|
||||
add_subdirectory(Protocols)
|
||||
add_subdirectory(support)
|
@ -73,20 +73,20 @@
|
||||
%bcond_without gui_utils
|
||||
%global use_gui_utils %{on_off_switch gui_utils}
|
||||
|
||||
%global dev_version %{lua: extraver = string.gsub('-rc3', '%-', ''); print(extraver) }
|
||||
%global dev_version %{lua: extraver = string.gsub('-rc4', '%-', ''); print(extraver) }
|
||||
|
||||
%global versiontag 2.3-rc3
|
||||
%global versiontag 2.3-rc4
|
||||
|
||||
Name: nfs-ganesha
|
||||
Version: 2.3.0
|
||||
Release: 0.4%{?dev_version:%{dev_version}}%{?dist}
|
||||
Release: 0.5%{?dev_version:%{dev_version}}%{?dist}
|
||||
Summary: NFS-Ganesha is a NFS Server running in user space
|
||||
Group: Applications/System
|
||||
License: LGPLv3+
|
||||
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
|
||||
|
||||
Source0: https://github.com/%{name}/%{name}/archive/V%{versiontag}/%{name}-%{versiontag}.tar.gz
|
||||
Patch0: nfs-ganesha-2.3rc3-CMakeLists.txt.patch
|
||||
Patch0: nfs-ganesha-2.3rc4-CMakeLists.txt.patch
|
||||
Patch1: nfs-ganesha-2.3rc3-scripts-ganeshactl-CMakeLists.txt.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
@ -424,9 +424,9 @@ install -m 755 scripts/init.d/nfs-ganesha.gpfs %{buildroot}%{_sysconfdir}/init.
|
||||
echo "make DESTDIR=%{buildroot} install"
|
||||
make DESTDIR=%{buildroot} install
|
||||
mv %{buildroot}/share %{buildroot}/usr/
|
||||
rm %{buildroot}/bin
|
||||
rm %{buildroot}/lib
|
||||
rm %{buildroot}/lib64
|
||||
rm -f %{buildroot}/bin
|
||||
rm -f %{buildroot}/lib
|
||||
rm -f %{buildroot}/lib64
|
||||
|
||||
%post
|
||||
%if %{with_systemd}
|
||||
@ -582,6 +582,9 @@ rm %{buildroot}/lib64
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Sep 28 2015 Kaleb S. KEITHLEY <kkeithle at redhat.com> 2.3.0-0.5rc4
|
||||
- 2.3.0 RC4
|
||||
|
||||
* Fri Sep 18 2015 Kaleb S. KEITHLEY <kkeithle at redhat.com> 2.3.0-0.4rc3
|
||||
- 2.3.0 RC3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user