Merge remote-tracking branch 'origin' into f32

This commit is contained in:
Kaleb S. KEITHLEY 2020-06-18 13:20:04 -04:00
commit ac289ea526
2 changed files with 45 additions and 21 deletions

View File

@ -1,4 +1,4 @@
From 55e918b43c001edd2a781c19fc7ed76139aa5fd1 Mon Sep 17 00:00:00 2001
From bf842d0cf9ae13408e20963c977d3c85642a69b3 Mon Sep 17 00:00:00 2001
From: "Kaleb S. KEITHLEY" <kkeithle@redhat.com>
Date: Thu, 18 Jun 2020 09:38:13 -0400
Subject: [PATCH] systemd: revised drop-in conf file handling
@ -12,17 +12,47 @@ This is my current best guess, and at least it doesn't log errors
Change-Id: Iec9847356090e561bfcd5f41a64b35c2e686a3d6
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
---
src/scripts/systemd/nfs-ganesha-lock.service.debian10 | 5 ++---
src/scripts/systemd/nfs-ganesha-lock.service.el8 | 5 ++---
src/nfs-ganesha.spec-in.cmake | 6 +++---
src/scripts/systemd/nfs-ganesha-lock.service.debian10 | 2 +-
src/scripts/systemd/nfs-ganesha-lock.service.el8 | 2 +-
src/scripts/systemd/rpc-statd.conf.debian10 | 2 +-
src/scripts/systemd/rpc-statd.conf.el8 | 2 +-
4 files changed, 6 insertions(+), 8 deletions(-)
5 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/src/nfs-ganesha.spec-in.cmake b/src/nfs-ganesha.spec-in.cmake
index 9cfda6c0e..d66106d6f 100644
--- a/src/nfs-ganesha.spec-in.cmake
+++ b/src/nfs-ganesha.spec-in.cmake
@@ -557,13 +557,13 @@ install -m 644 config_samples/vfs.conf %{buildroot}%{_sysconfdir}/ganesha
mkdir -p %{buildroot}%{_unitdir}
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
-mkdir -p %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha.d
+mkdir -p %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d
%endif
install -m 644 scripts/systemd/nfs-ganesha.service.el7 %{buildroot}%{_unitdir}/nfs-ganesha.service
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
install -m 644 scripts/systemd/nfs-ganesha-lock.service.el8 %{buildroot}%{_unitdir}/nfs-ganesha-lock.service
-install -m 644 scripts/systemd/rpc-statd.conf.el8 %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha.d/rpc-statd.conf
+install -m 644 scripts/systemd/rpc-statd.conf.el8 %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d/rpc-statd.conf
%else
install -m 644 scripts/systemd/nfs-ganesha-lock.service.el7 %{buildroot}%{_unitdir}/nfs-ganesha-lock.service
%endif
@@ -677,7 +677,7 @@ exit 0
%{_unitdir}/nfs-ganesha-lock.service
%{_unitdir}/nfs-ganesha-config.service
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
-%{_sysconfdir}/systemd/system/nfs-ganesha.d/rpc-statd.conf
+%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d/rpc-statd.conf
%endif
%if %{with man_page}
diff --git a/src/scripts/systemd/nfs-ganesha-lock.service.debian10 b/src/scripts/systemd/nfs-ganesha-lock.service.debian10
index 67af058fe..53c19d5c6 100644
index 67af058fe..da06ef4fe 100644
--- a/src/scripts/systemd/nfs-ganesha-lock.service.debian10
+++ b/src/scripts/systemd/nfs-ganesha-lock.service.debian10
@@ -17,9 +17,8 @@
@@ -17,7 +17,7 @@
[Unit]
Before=nfs-ganesha.service
@ -30,15 +60,12 @@ index 67af058fe..53c19d5c6 100644
+Conflicts=nfs-lock.service
[Service]
-ExecStartPre=
-ExecStopPost=
+ExecStart=systemctl start rpc-statd.service
ExecStartPre=
diff --git a/src/scripts/systemd/nfs-ganesha-lock.service.el8 b/src/scripts/systemd/nfs-ganesha-lock.service.el8
index 67af058fe..53c19d5c6 100644
index 67af058fe..da06ef4fe 100644
--- a/src/scripts/systemd/nfs-ganesha-lock.service.el8
+++ b/src/scripts/systemd/nfs-ganesha-lock.service.el8
@@ -17,9 +17,8 @@
@@ -17,7 +17,7 @@
[Unit]
Before=nfs-ganesha.service
@ -46,10 +73,7 @@ index 67af058fe..53c19d5c6 100644
+Conflicts=nfs-lock.service
[Service]
-ExecStartPre=
-ExecStopPost=
+ExecStart=systemctl start rpc-statd.service
ExecStartPre=
diff --git a/src/scripts/systemd/rpc-statd.conf.debian10 b/src/scripts/systemd/rpc-statd.conf.debian10
index 2138f7467..d06fffd4c 100644
--- a/src/scripts/systemd/rpc-statd.conf.debian10

View File

@ -115,7 +115,7 @@ Requires: openSUSE-release
Name: nfs-ganesha
Version: 3.3
Release: 2%{?dev:%{dev}}%{?dist}
Release: 3%{?dev:%{dev}}%{?dist}
Summary: NFS-Ganesha is a NFS Server running in user space
License: LGPLv3+
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
@ -558,13 +558,13 @@ install -m 644 config_samples/rgw.conf %{buildroot}%{_sysconfdir}/ganesha
mkdir -p %{buildroot}%{_unitdir}
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
mkdir -p %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha.d
mkdir -p %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d
%endif
install -m 644 scripts/systemd/nfs-ganesha.service.el7 %{buildroot}%{_unitdir}/nfs-ganesha.service
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
install -m 644 scripts/systemd/nfs-ganesha-lock.service.el8 %{buildroot}%{_unitdir}/nfs-ganesha-lock.service
install -m 644 scripts/systemd/rpc-statd.conf.el8 %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha.d/rpc-statd.conf
install -m 644 scripts/systemd/rpc-statd.conf.el8 %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d/rpc-statd.conf
%else
install -m 644 scripts/systemd/nfs-ganesha-lock.service.el7 %{buildroot}%{_unitdir}/nfs-ganesha-lock.service
%endif
@ -677,7 +677,7 @@ exit 0
%{_unitdir}/nfs-ganesha-lock.service
%{_unitdir}/nfs-ganesha-config.service
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
%{_sysconfdir}/systemd/system/nfs-ganesha.d/rpc-statd.conf
%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d/rpc-statd.conf
%endif
%if %{with man_page}
@ -859,7 +859,7 @@ exit 0
%endif
%changelog
* Thu Jun 18 2020 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.3-2
* Thu Jun 18 2020 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.3-3
- rhbz#1848208
* Mon Jun 8 2020 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.3-1