NFS-Ganesha 4.0 RC3

Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
Kaleb S. KEITHLEY 2021-11-09 15:00:28 -05:00
parent 4211c1b372
commit 9caf1185dd
3 changed files with 88 additions and 39 deletions

17
0002-CMakeLists.txt.patch Normal file
View File

@ -0,0 +1,17 @@
--- nfs-ganesha-4-rc3/src/CMakeLists.txt.orig 2021-11-08 18:24:19.024041776 -0500
+++ nfs-ganesha-4-rc3/src/CMakeLists.txt 2021-11-09 13:54:02.553226811 -0500
@@ -558,11 +558,11 @@
gopt_test(USE_ADMIN_TOOLS)
if (USE_ADMIN_TOOLS)
- find_package (Python COMPONENTS Interpreter Development)
- if (NOT Python_Interpreter_FOUND)
+ find_package(PythonInterp ${USE_ADMIN_TOOLS_REQUIRED})
+ if (NOT PYTHONINTERP_FOUND)
message(WARNING "Cannot find python. Disablin admin tools")
set(USE_ADMIN_TOOLS OFF)
- endif (NOT Python_Interpreter_FOUND)
+ endif (NOT PYTHONINTERP_FOUND)
endif (USE_ADMIN_TOOLS)
gopt_test(USE_GUI_ADMIN_TOOLS)

View File

@ -57,8 +57,11 @@ Requires: openSUSE-release
%bcond_without gluster %bcond_without gluster
%global use_fsal_gluster %{on_off_switch gluster} %global use_fsal_gluster %{on_off_switch gluster}
%bcond_with panfs %bcond_with kvsfs
%global use_fsal_panfs %{on_off_switch panfs} %global use_fsal_kvsfs %{on_off_switch kvsfs}
%bcond_with proxy_v3
%global use_proxy_v3 %{on_off_switch proxy_v3}
%bcond_with rdma %bcond_with rdma
%global use_rdma %{on_off_switch rdma} %global use_rdma %{on_off_switch rdma}
@ -71,10 +74,10 @@ Requires: openSUSE-release
%bcond_with lttng %bcond_with lttng
%global use_lttng %{on_off_switch lttng} %global use_lttng %{on_off_switch lttng}
%bcond_without utils %bcond_with utils
%global use_utils %{on_off_switch utils} %global use_utils %{on_off_switch utils}
%bcond_without gui_utils %bcond_with gui_utils
%global use_gui_utils %{on_off_switch gui_utils} %global use_gui_utils %{on_off_switch gui_utils}
%bcond_without system_ntirpc %bcond_without system_ntirpc
@ -111,17 +114,18 @@ Requires: openSUSE-release
%endif %endif
%global dev_version %{lua: s = string.gsub('@GANESHA_EXTRA_VERSION@', '^%-', ''); s2 = string.gsub(s, '%-', '.'); print((s2 ~= nil and s2 ~= '') and s2 or "0.1") } %global dev_version %{lua: s = string.gsub('@GANESHA_EXTRA_VERSION@', '^%-', ''); s2 = string.gsub(s, '%-', '.'); print((s2 ~= nil and s2 ~= '') and s2 or "0.1") }
# %%global dev rc5 %global dev rc3
Name: nfs-ganesha Name: nfs-ganesha
Version: 3.5 Version: 4.0
Release: 9%{?dev:%{dev}}%{?dist} Release: 0.1%{?dev:%{dev}}%{?dist}
Summary: NFS-Ganesha is a NFS Server running in user space Summary: NFS-Ganesha is a NFS Server running in user space
License: LGPLv3+ License: LGPLv3+
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
Source0: https://github.com/%{name}/%{name}/archive/V%{version}%{?dev:-%{dev}}/%{name}-%{version}%{?dev:-%{dev}}.tar.gz Source0: https://github.com/%{name}/%{name}/archive/V%{version}%{?dev:-%{dev}}/%{name}-%{version}%{?dev:%{dev}}.tar.gz
Patch0001: 0001-config_samples-log_rotate.patch Patch0001: 0001-config_samples-log_rotate.patch
Patch0002: 0002-CMakeLists.txt.patch
BuildRequires: cmake BuildRequires: cmake
BuildRequires: make BuildRequires: make
@ -156,7 +160,7 @@ BuildRequires: libwbclient-devel
%endif %endif
BuildRequires: gcc-c++ BuildRequires: gcc-c++
%if ( %{with_system_ntirpc} ) %if ( %{with_system_ntirpc} )
BuildRequires: libntirpc-devel >= 3.4 BuildRequires: libntirpc-devel >= 4.0
%else %else
Requires: libntirpc = @NTIRPC_VERSION_EMBED@ Requires: libntirpc = @NTIRPC_VERSION_EMBED@
%endif %endif
@ -245,14 +249,25 @@ Requires: nfs-ganesha = %{version}-%{release}
This package contains a FSAL shared object to This package contains a FSAL shared object to
be used with NFS-Ganesha to support VFS based filesystems be used with NFS-Ganesha to support VFS based filesystems
%package proxy %package proxy-v4
Summary: The NFS-GANESHA PROXY FSAL Summary: The NFS-GANESHA PROXY_V4 FSAL
BuildRequires: libattr-devel BuildRequires: libattr-devel
Requires: nfs-ganesha = %{version}-%{release} Requires: nfs-ganesha = %{version}-%{release}
%description proxy %description proxy-v4
This package contains a FSAL shared object to This package contains a FSAL shared object to
be used with NFS-Ganesha to support PROXY based filesystems be used with NFS-Ganesha to support PROXY_V4 based filesystems
%if %{with proxy_v3}
%package proxy-v3
Summary: The NFS-GANESHA PROXY_V3 FSAL
BuildRequires: libattr-devel
Requires: nfs-ganesha = %{version}-%{release}
%description proxy-v3
This package contains a FSAL shared object to
be used with NFS-Ganesha to support PROXY_V3 based filesystems
%endif
%if %{with utils} %if %{with utils}
%package utils %package utils
@ -409,15 +424,17 @@ This package contains a FSAL shared object to
be used with NFS-Ganesha to support LUSTRE based filesystems be used with NFS-Ganesha to support LUSTRE based filesystems
%endif %endif
# PANFS # KVSFS
%if %{with panfs} %if %{with kvsfs}
%package panfs %package kvsfs
Summary: The NFS-GANESHA PANFS FSAL Summary: The NFS-GANESHA KVSFS FSAL
Requires: nfs-ganesha = %{version}-%{release} Requires: nfs-ganesha = %{version}-%{release}
Requires: libkvsns >= 1.2.0
BuildRequires: libkvsns-devel >= 1.2.0
%description panfs %description kvsfs
This package contains a FSAL shared object to This package contains a FSAL shared object to
be used with NFS-Ganesha to support PANFS be used with NFS-Ganesha to support KVSFS/libkvsns
%endif %endif
# GLUSTER # GLUSTER
@ -498,10 +515,12 @@ Development headers and auxiliary files for developing with %{name}.
%endif %endif
%prep %prep
%setup -q -n %{name}-%{version}%{?dev:-%{dev}} %setup -q -n %{name}-4%{?dev:-%{dev}}
%patch0001 -p1 %patch0001 -p1
%patch0002 -p1
%build %build
export VERBOSE=1
cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \ cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DBUILD_CONFIG=rpmbuild \ -DBUILD_CONFIG=rpmbuild \
-DCMAKE_COLOR_MAKEFILE:BOOL=OFF \ -DCMAKE_COLOR_MAKEFILE:BOOL=OFF \
@ -512,7 +531,7 @@ cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DUSE_FSAL_CEPH=%{use_fsal_ceph} \ -DUSE_FSAL_CEPH=%{use_fsal_ceph} \
-DUSE_FSAL_RGW=%{use_fsal_rgw} \ -DUSE_FSAL_RGW=%{use_fsal_rgw} \
-DUSE_FSAL_GPFS=%{use_fsal_gpfs} \ -DUSE_FSAL_GPFS=%{use_fsal_gpfs} \
-DUSE_FSAL_PANFS=%{use_fsal_panfs} \ -DUSE_FSAL_KVSFS=%{use_fsal_kvsfs} \
-DUSE_FSAL_GLUSTER=%{use_fsal_gluster} \ -DUSE_FSAL_GLUSTER=%{use_fsal_gluster} \
-DUSE_SYSTEM_NTIRPC=%{use_system_ntirpc} \ -DUSE_SYSTEM_NTIRPC=%{use_system_ntirpc} \
-DUSE_9P_RDMA=%{use_rdma} \ -DUSE_9P_RDMA=%{use_rdma} \
@ -522,7 +541,8 @@ cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DUSE_RADOS_RECOV=%{use_rados_recov} \ -DUSE_RADOS_RECOV=%{use_rados_recov} \
-DRADOS_URLS=%{use_rados_urls} \ -DRADOS_URLS=%{use_rados_urls} \
-DUSE_FSAL_VFS=ON \ -DUSE_FSAL_VFS=ON \
-DUSE_FSAL_PROXY=ON \ -DUSE_FSAL_PROXY_V4=ON \
-DUSE_FSAL_PROXY_V3=OFF \
-DUSE_DBUS=ON \ -DUSE_DBUS=ON \
-DUSE_9P=%{use_9P} \ -DUSE_9P=%{use_9P} \
-DDISTNAME_HAS_GIT_DATA=OFF \ -DDISTNAME_HAS_GIT_DATA=OFF \
@ -534,7 +554,6 @@ cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DALLOCATOR=jemalloc -DALLOCATOR=jemalloc
%endif %endif
export VERBOSE=1
export GCC_COLORS= export GCC_COLORS=
%cmake_build %cmake_build
@ -725,10 +744,18 @@ exit 0
%{_mandir}/*/ganesha-vfs-config.8.gz %{_mandir}/*/ganesha-vfs-config.8.gz
%endif %endif
%files proxy %files proxy-v4
%{_libdir}/ganesha/libfsalproxy* %{_libdir}/ganesha/libfsalproxy_v4*
%if %{with man_page} %if %{with man_page}
%{_mandir}/*/ganesha-proxy-config.8.gz %{_mandir}/*/ganesha-proxy-v4-config.8.gz
%endif
%if %{with proxy_v3}
%files proxy-v3
%{_libdir}/ganesha/libfsalproxy_v3*
%if %{with man_page}
%{_mandir}/*/ganesha-proxy-v3-config.8.gz
%endif
%endif %endif
# Optional packages # Optional packages
@ -759,7 +786,9 @@ exit 0
%config(noreplace) %{_sysconfdir}/ganesha/gpfs.ganesha.main.conf %config(noreplace) %{_sysconfdir}/ganesha/gpfs.ganesha.main.conf
%config(noreplace) %{_sysconfdir}/ganesha/gpfs.ganesha.log.conf %config(noreplace) %{_sysconfdir}/ganesha/gpfs.ganesha.log.conf
%config(noreplace) %{_sysconfdir}/ganesha/gpfs.ganesha.exports.conf %config(noreplace) %{_sysconfdir}/ganesha/gpfs.ganesha.exports.conf
%if %{with utils}
%{_libexecdir}/ganesha/gpfs-epoch %{_libexecdir}/ganesha/gpfs-epoch
%endif
%if %{with man_page} %if %{with man_page}
%{_mandir}/*/ganesha-gpfs-config.8.gz %{_mandir}/*/ganesha-gpfs-config.8.gz
%endif %endif
@ -811,7 +840,7 @@ exit 0
%if ! %{with system_ntirpc} %if ! %{with system_ntirpc}
%files -n libntirpc %files -n libntirpc
%{_libdir}/libntirpc.so.@NTIRPC_VERSION_EMBED@ %{_libdir}/libntirpc.so.@NTIRPC_VERSION_EMBED@
%{_libdir}/libntirpc.so.1.6 %{_libdir}/libntirpc.so.4.0
%{_libdir}/libntirpc.so %{_libdir}/libntirpc.so
%{!?_licensedir:%global license %%doc} %{!?_licensedir:%global license %%doc}
%license libntirpc/COPYING %license libntirpc/COPYING
@ -822,9 +851,9 @@ exit 0
%{_includedir}/ntirpc/* %{_includedir}/ntirpc/*
%endif %endif
%if %{with panfs} %if %{with kvsfs}
%files panfs %files kvsfs
%{_libdir}/ganesha/libfsalpanfs* %{_libdir}/ganesha/libfsalkvsfs*
%endif %endif
%if %{with lttng} %if %{with lttng}
@ -866,6 +895,9 @@ exit 0
%endif %endif
%changelog %changelog
* Mon Nov 8 2021 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 4.0-0.1rc3
- NFS-Ganesha 4.0 RC3
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.5-9 * Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.5-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
@ -876,7 +908,7 @@ exit 0
* Tue Jun 22 2021 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.5-7 * Tue Jun 22 2021 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.5-7
- Rebuilt for userspace-rcu-0.13 again - Rebuilt for userspace-rcu-0.13 again
* Wed June 16 2021 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.5-6 * Wed Jun 16 2021 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.5-6
- Rebuilt for libntirpc-3.5 - Rebuilt for libntirpc-3.5
- plus https://src.fedoraproject.org/rpms/nfs-ganesha/pull-request/2 - plus https://src.fedoraproject.org/rpms/nfs-ganesha/pull-request/2
@ -913,10 +945,10 @@ exit 0
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Mon Jul 20 2020 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.3-6 * Mon Jul 20 2020 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.3-6
- use cmake_build and %cmake_install - use %%cmake_build and %%cmake_install
* Mon Jul 20 2020 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.3-5 * Mon Jul 20 2020 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.3-5
- use %make_install - use %%make_install
* Mon Jul 13 2020 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.3-4 * Mon Jul 13 2020 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.3-4
- rpc-statd.conf.el8 - rpc-statd.conf.el8

View File

@ -1 +1 @@
SHA512 (nfs-ganesha-3.5.tar.gz) = c2a2a6d9993a7c96771d74f61465bc56a9b6ef45be10abaa351ace8f3fcb045a4f799d92292f8228bae0ac52961c0081f4fc5d852f795c7617f235ddf57bc22c SHA512 (nfs-ganesha-4.0rc3.tar.gz) = 318cfecb0bc58bc76849c915e0bd714133318a54ad62d969fd8d282d191fff0fcf9d5233c1749044035d9a2e97ec124aae7a39935fda243d3b21d4d6fb8de0cf