2.3.0 RC3
This commit is contained in:
parent
98765927f8
commit
7167f8c99b
62
nfs-ganesha-2.3rc3-CMakeLists.txt.patch
Normal file
62
nfs-ganesha-2.3rc3-CMakeLists.txt.patch
Normal file
@ -0,0 +1,62 @@
|
|||||||
|
--- nfs-ganesha-2.3-rc2/src/CMakeLists.txt.orig 2015-09-11 19:01:01.530344661 -0400
|
||||||
|
+++ nfs-ganesha-2.3-rc2/src/CMakeLists.txt 2015-09-11 19:05:13.269344661 -0400
|
||||||
|
@@ -765,9 +765,12 @@
|
||||||
|
set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/portability_cmake_2.8 /usr/share/cmake/Modules ${CMAKE_MODULE_PATH})
|
||||||
|
endif( "${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" VERSION_LESS "2.8" )
|
||||||
|
|
||||||
|
+find_library(LIBNTIRPC ntirpc)
|
||||||
|
+
|
||||||
|
+set(CMAKE_C_FLAGS "-isystem /usr/include/ntirpc ${CMAKE_C_FLAGS}")
|
||||||
|
+
|
||||||
|
include_directories(
|
||||||
|
"${PROJECT_BINARY_DIR}/include"
|
||||||
|
- "${PROJECT_SOURCE_DIR}/libntirpc/ntirpc/"
|
||||||
|
"${PROJECT_SOURCE_DIR}/include"
|
||||||
|
"${OS_INCLUDE_DIR}"
|
||||||
|
"${KRB5_INCLUDE_DIRS}"
|
||||||
|
@@ -783,12 +786,6 @@
|
||||||
|
|
||||||
|
|
||||||
|
#callers add:
|
||||||
|
-# target_link_libraries(your_library ${LIBTIRPC_LIBRARIES})
|
||||||
|
-set(LIBTIRPC_INCLUDE_DIR
|
||||||
|
- "${PROJECT_BINARY_DIR}/libtirpc/ntirpc"
|
||||||
|
- "${PROJECT_BINARY_DIR}/libtirpc/ntirpc/rpc"
|
||||||
|
-)
|
||||||
|
-set(LIBTIRPC_LIBRARIES ntirpc)
|
||||||
|
|
||||||
|
# Find misc system libs
|
||||||
|
find_library(LIBRT rt) # extended Pthreads functions
|
||||||
|
@@ -916,6 +913,7 @@
|
||||||
|
${KRB5_LIBRARIES}
|
||||||
|
${CMAKE_THREAD_LIBS_INIT}
|
||||||
|
${LIBRT}
|
||||||
|
+ ${LIBNTIRPC}
|
||||||
|
)
|
||||||
|
|
||||||
|
# Config file; make sure it doesn't clobber an existing one
|
||||||
|
@@ -926,16 +924,6 @@
|
||||||
|
# pre-create PREFIX/var/run/ganesha
|
||||||
|
install(DIRECTORY DESTINATION ${SYSSTATEDIR}/run/ganesha)
|
||||||
|
|
||||||
|
-IF( NOT EXISTS ${PROJECT_SOURCE_DIR}/libntirpc/ganesha/CMakeLists.txt )
|
||||||
|
-message( FATAL_ERROR
|
||||||
|
-"No CMakeLists.txt found in libntirpc
|
||||||
|
-This probably means that the directory was not properly populated.
|
||||||
|
-Please run the following command to do that and use cmake again:
|
||||||
|
- git submodule update --init
|
||||||
|
-Alternatively, if you are not using git, get the current version at
|
||||||
|
- https://github.com/nfs-ganesha/ntirpc" )
|
||||||
|
-ENDIF( NOT EXISTS ${PROJECT_SOURCE_DIR}/libntirpc/ganesha/CMakeLists.txt )
|
||||||
|
-
|
||||||
|
add_subdirectory(log)
|
||||||
|
add_subdirectory(config_parsing)
|
||||||
|
add_subdirectory(cidr)
|
||||||
|
@@ -945,7 +933,6 @@
|
||||||
|
add_subdirectory(NodeList)
|
||||||
|
add_subdirectory(cache_inode)
|
||||||
|
add_subdirectory(SAL)
|
||||||
|
-add_subdirectory(libntirpc/ganesha)
|
||||||
|
add_subdirectory(RPCAL)
|
||||||
|
add_subdirectory(Protocols)
|
||||||
|
add_subdirectory(support)
|
10
nfs-ganesha-2.3rc3-scripts-ganeshactl-CMakeLists.txt.patch
Normal file
10
nfs-ganesha-2.3rc3-scripts-ganeshactl-CMakeLists.txt.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- nfs-ganesha-2.3-rc3/src/scripts/ganeshactl/CMakeLists.txt.orig 2015-09-18 08:12:14.081542533 -0400
|
||||||
|
+++ nfs-ganesha-2.3-rc3/src/scripts/ganeshactl/CMakeLists.txt 2015-09-18 08:47:26.199542533 -0400
|
||||||
|
@@ -124,6 +124,6 @@
|
||||||
|
|
||||||
|
install(
|
||||||
|
CODE
|
||||||
|
- "execute_process(WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${PYTHON} ${SETUP_PY} install --skip-build --prefix=$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX})"
|
||||||
|
+ "execute_process(WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${PYTHON} ${SETUP_PY} install --skip-build --prefix=${DESTDIR})"
|
||||||
|
)
|
||||||
|
endif(PYTHON)
|
@ -73,20 +73,21 @@
|
|||||||
%bcond_without gui_utils
|
%bcond_without gui_utils
|
||||||
%global use_gui_utils %{on_off_switch gui_utils}
|
%global use_gui_utils %{on_off_switch gui_utils}
|
||||||
|
|
||||||
%global dev_version %{lua: extraver = string.gsub('-rc2', '%-', ''); print(extraver) }
|
%global dev_version %{lua: extraver = string.gsub('-rc3', '%-', ''); print(extraver) }
|
||||||
|
|
||||||
%global versiontag 2.3-rc2
|
%global versiontag 2.3-rc3
|
||||||
|
|
||||||
Name: nfs-ganesha
|
Name: nfs-ganesha
|
||||||
Version: 2.3.0
|
Version: 2.3.0
|
||||||
Release: 0.3%{?dev_version:%{dev_version}}%{?dist}
|
Release: 0.4%{?dev_version:%{dev_version}}%{?dist}
|
||||||
Summary: NFS-Ganesha is a NFS Server running in user space
|
Summary: NFS-Ganesha is a NFS Server running in user space
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
License: LGPLv3+
|
License: LGPLv3+
|
||||||
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
|
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
|
||||||
|
|
||||||
Source0: https://github.com/%{name}/%{name}/archive/V%{versiontag}/%{name}-%{versiontag}.tar.gz
|
Source0: https://github.com/%{name}/%{name}/archive/V%{versiontag}/%{name}-%{versiontag}.tar.gz
|
||||||
Patch0: nfs-ganesha-2.3rc2-jumbo.patch
|
Patch0: nfs-ganesha-2.3rc3-CMakeLists.txt.patch
|
||||||
|
Patch1: nfs-ganesha-2.3rc3-scripts-ganeshactl-CMakeLists.txt.patch
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: bison flex
|
BuildRequires: bison flex
|
||||||
@ -322,9 +323,11 @@ be used with NFS-Ganesha to support Gluster
|
|||||||
%setup -q -n %{name}-%{versiontag}
|
%setup -q -n %{name}-%{versiontag}
|
||||||
rm -rf contrib/libzfswrapper
|
rm -rf contrib/libzfswrapper
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake ./src -DCMAKE_BUILD_TYPE=Debug \
|
%cmake ./src -DDESTDIR=%{buildroot} \
|
||||||
|
-DCMAKE_BUILD_TYPE=Debug \
|
||||||
-DBUILD_CONFIG=rpmbuild \
|
-DBUILD_CONFIG=rpmbuild \
|
||||||
-DUSE_FSAL_NULL=%{use_fsal_null} \
|
-DUSE_FSAL_NULL=%{use_fsal_null} \
|
||||||
-DUSE_FSAL_ZFS=NO \
|
-DUSE_FSAL_ZFS=NO \
|
||||||
@ -361,6 +364,8 @@ mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
|
|||||||
mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
|
mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
|
||||||
mkdir -p %{buildroot}%{_bindir}
|
mkdir -p %{buildroot}%{_bindir}
|
||||||
ln -s %{buildroot}%{_bindir} %{buildroot}/bin
|
ln -s %{buildroot}%{_bindir} %{buildroot}/bin
|
||||||
|
ln -s %{buildroot}%{_libdir} %{buildroot}/lib64
|
||||||
|
ln -s %{buildroot}/usr/lib %{buildroot}/lib
|
||||||
mkdir -p %{buildroot}%{_sbindir}
|
mkdir -p %{buildroot}%{_sbindir}
|
||||||
mkdir -p %{buildroot}%{_libdir}/ganesha
|
mkdir -p %{buildroot}%{_libdir}/ganesha
|
||||||
mkdir -p %{buildroot}%{_localstatedir}/run/ganesha
|
mkdir -p %{buildroot}%{_localstatedir}/run/ganesha
|
||||||
@ -416,18 +421,12 @@ install -m 755 scripts/init.d/nfs-ganesha.gpfs %{buildroot}%{_sysconfdir}/init.
|
|||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{with utils}
|
|
||||||
pushd .
|
|
||||||
cd scripts/ganeshactl/
|
|
||||||
echo "python setup.py install --root=%{buildroot}"
|
|
||||||
python setup.py install --root=%{buildroot}
|
|
||||||
popd
|
|
||||||
%endif
|
|
||||||
|
|
||||||
echo "make DESTDIR=%{buildroot} install"
|
echo "make DESTDIR=%{buildroot} install"
|
||||||
make DESTDIR=%{buildroot} install
|
make DESTDIR=%{buildroot} install
|
||||||
mv %{buildroot}/share %{buildroot}/usr/
|
mv %{buildroot}/share %{buildroot}/usr/
|
||||||
rm %{buildroot}/bin
|
rm %{buildroot}/bin
|
||||||
|
rm %{buildroot}/lib
|
||||||
|
rm %{buildroot}/lib64
|
||||||
|
|
||||||
%post
|
%post
|
||||||
%if %{with_systemd}
|
%if %{with_systemd}
|
||||||
@ -583,6 +582,9 @@ rm %{buildroot}/bin
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 18 2015 Kaleb S. KEITHLEY <kkeithle at redhat.com> 2.3.0-0.4rc3
|
||||||
|
- 2.3.0 RC3
|
||||||
|
|
||||||
* Fri Sep 11 2015 Kaleb S. KEITHLEY <kkeithle at redhat.com> 2.3.0-0.3rc2
|
* Fri Sep 11 2015 Kaleb S. KEITHLEY <kkeithle at redhat.com> 2.3.0-0.3rc2
|
||||||
- 2.3.0 RC2
|
- 2.3.0 RC2
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user