rhbz#1848208

Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
Kaleb S. KEITHLEY 2020-06-18 12:35:53 -04:00
parent f2329c1b20
commit 61b4a55812
4 changed files with 112 additions and 34 deletions

View File

@ -1,8 +0,0 @@
--- nfs-ganesha-2.8.2/src/scripts/gpfs-epoch.orig 2019-08-14 09:55:02.130227995 -0400
+++ nfs-ganesha-2.8.2/src/scripts/gpfs-epoch 2019-08-14 09:55:13.982227995 -0400
@@ -1,4 +1,4 @@
-#!/usr/bin/python2
+#!/usr/bin/python3
# Usually ganesha daemon start up time is used as its epoch. This is
# fine for a single node configurations, but in clustered environment,

View File

@ -0,0 +1,103 @@
From bf842d0cf9ae13408e20963c977d3c85642a69b3 Mon Sep 17 00:00:00 2001
From: "Kaleb S. KEITHLEY" <kkeithle@redhat.com>
Date: Thu, 18 Jun 2020 09:38:13 -0400
Subject: [PATCH] systemd: revised drop-in conf file handling
see https://bugzilla.redhat.com/show_bug.cgi?id=1848208
systemd service file documentation still sucks rocks
This is my current best guess, and at least it doesn't log errors
Change-Id: Iec9847356090e561bfcd5f41a64b35c2e686a3d6
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
---
src/nfs-ganesha.spec-in.cmake | 6 +++---
src/scripts/systemd/nfs-ganesha-lock.service.debian10 | 2 +-
src/scripts/systemd/nfs-ganesha-lock.service.el8 | 2 +-
src/scripts/systemd/rpc-statd.conf.debian10 | 2 +-
src/scripts/systemd/rpc-statd.conf.el8 | 2 +-
5 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/src/nfs-ganesha.spec-in.cmake b/src/nfs-ganesha.spec-in.cmake
index 9cfda6c0e..d66106d6f 100644
--- a/src/nfs-ganesha.spec-in.cmake
+++ b/src/nfs-ganesha.spec-in.cmake
@@ -557,13 +557,13 @@ install -m 644 config_samples/vfs.conf %{buildroot}%{_sysconfdir}/ganesha
mkdir -p %{buildroot}%{_unitdir}
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
-mkdir -p %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha.d
+mkdir -p %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d
%endif
install -m 644 scripts/systemd/nfs-ganesha.service.el7 %{buildroot}%{_unitdir}/nfs-ganesha.service
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
install -m 644 scripts/systemd/nfs-ganesha-lock.service.el8 %{buildroot}%{_unitdir}/nfs-ganesha-lock.service
-install -m 644 scripts/systemd/rpc-statd.conf.el8 %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha.d/rpc-statd.conf
+install -m 644 scripts/systemd/rpc-statd.conf.el8 %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d/rpc-statd.conf
%else
install -m 644 scripts/systemd/nfs-ganesha-lock.service.el7 %{buildroot}%{_unitdir}/nfs-ganesha-lock.service
%endif
@@ -677,7 +677,7 @@ exit 0
%{_unitdir}/nfs-ganesha-lock.service
%{_unitdir}/nfs-ganesha-config.service
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
-%{_sysconfdir}/systemd/system/nfs-ganesha.d/rpc-statd.conf
+%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d/rpc-statd.conf
%endif
%if %{with man_page}
diff --git a/src/scripts/systemd/nfs-ganesha-lock.service.debian10 b/src/scripts/systemd/nfs-ganesha-lock.service.debian10
index 67af058fe..da06ef4fe 100644
--- a/src/scripts/systemd/nfs-ganesha-lock.service.debian10
+++ b/src/scripts/systemd/nfs-ganesha-lock.service.debian10
@@ -17,7 +17,7 @@
[Unit]
Before=nfs-ganesha.service
-Conflicts=nfs-lock.service rpc-statd.service
+Conflicts=nfs-lock.service
[Service]
ExecStartPre=
diff --git a/src/scripts/systemd/nfs-ganesha-lock.service.el8 b/src/scripts/systemd/nfs-ganesha-lock.service.el8
index 67af058fe..da06ef4fe 100644
--- a/src/scripts/systemd/nfs-ganesha-lock.service.el8
+++ b/src/scripts/systemd/nfs-ganesha-lock.service.el8
@@ -17,7 +17,7 @@
[Unit]
Before=nfs-ganesha.service
-Conflicts=nfs-lock.service rpc-statd.service
+Conflicts=nfs-lock.service
[Service]
ExecStartPre=
diff --git a/src/scripts/systemd/rpc-statd.conf.debian10 b/src/scripts/systemd/rpc-statd.conf.debian10
index 2138f7467..d06fffd4c 100644
--- a/src/scripts/systemd/rpc-statd.conf.debian10
+++ b/src/scripts/systemd/rpc-statd.conf.debian10
@@ -13,7 +13,7 @@ After=nfs-config.service
[Service]
EnvironmentFile=-/run/sysconfig/nfs-utils
Type=forking
-PIDFile=/var/run/rpc.statd.pid
+PIDFile=/run/rpc.statd.pid
ExecStart=/sbin/rpc.statd --no-notify $STATDARGS
[Install]
diff --git a/src/scripts/systemd/rpc-statd.conf.el8 b/src/scripts/systemd/rpc-statd.conf.el8
index 6fec09af1..b67cfdf24 100644
--- a/src/scripts/systemd/rpc-statd.conf.el8
+++ b/src/scripts/systemd/rpc-statd.conf.el8
@@ -10,5 +10,5 @@ PartOf=nfs-utils.service
[Service]
Environment=RPC_STATD_NO_NOTIFY=1
Type=forking
-PIDFile=/var/run/rpc.statd.pid
+PIDFile=/run/rpc.statd.pid
ExecStart=/usr/sbin/rpc.statd
--
2.26.2

View File

@ -1,22 +0,0 @@
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cb10e10e4..a83873888 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -511,12 +511,15 @@ endif (USE_ADMIN_TOOLS)
gopt_test(USE_GUI_ADMIN_TOOLS)
if (USE_ADMIN_TOOLS)
if (USE_GUI_ADMIN_TOOLS)
- find_program(PYUIC NAMES pyuic4 DOC "PyQT UI-compiler executable")
+ find_program(PYUIC NAMES pyuic5 DOC "PyQT UI-compiler executable")
+ if (NOT PYUIC)
+ find_program(PYUIC NAMES pyuic4 DOC "PyQT UI-compiler executable")
+ endif (NOT PYUIC)
if (NOT PYUIC)
if (USE_GUI_ADMIN_TOOLS_REQUIRED)
message(FATAL_ERROR "Cannot find PyQt but GUI admin tools requested on command line")
else (USE_GUI_ADMIN_TOOLS_REQUIRED)
- message(WARNING "Cannot find PyQt4. Disabling GUI admin tools")
+ message(WARNING "Cannot find PyQt4 or PyQt5. Disabling GUI admin tools")
set(USE_GUI_ADMIN_TOOLS OFF)
endif (USE_GUI_ADMIN_TOOLS_REQUIRED)
endif (NOT PYUIC)

View File

@ -115,12 +115,13 @@ Requires: openSUSE-release
Name: nfs-ganesha
Version: 2.8.4
Release: 1%{?dev:%{dev}}%{?dist}
Release: 2%{?dev:%{dev}}%{?dist}
Summary: NFS-Ganesha is a NFS Server running in user space
License: LGPLv3+
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
Source0: https://github.com/%{name}/%{name}/archive/V%{version}%{?dev:-%{dev}}/%{name}-%{version}%{?dev:-%{dev}}.tar.gz
Patch0001: 0001-systemd-revised-drop-in-conf-file-handling.patch
BuildRequires: cmake
BuildRequires: bison
@ -493,6 +494,7 @@ Development headers and auxiliary files for developing with %{name}.
%prep
%setup -q -n %{name}-%{version}%{?dev:-%{dev}}
%patch0001 -p1
%build
cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
@ -557,12 +559,12 @@ install -m 644 config_samples/rgw.conf %{buildroot}%{_sysconfdir}/ganesha
mkdir -p %{buildroot}%{_unitdir}
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
mkdir -p %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha.d
mkdir -p %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d
%endif
install -m 644 scripts/systemd/nfs-ganesha.service.el7 %{buildroot}%{_unitdir}/nfs-ganesha.service
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
install -m 644 scripts/systemd/nfs-ganesha-lock.service.el8 %{buildroot}%{_unitdir}/nfs-ganesha-lock.service
install -m 644 scripts/systemd/rpc-statd.conf.el8 %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha.d/rpc-statd.conf
install -m 644 scripts/systemd/rpc-statd.conf.el8 %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d/rpc-statd.conf
%else
install -m 644 scripts/systemd/nfs-ganesha-lock.service.el7 %{buildroot}%{_unitdir}/nfs-ganesha-lock.service
%endif
@ -675,7 +677,7 @@ exit 0
%{_unitdir}/nfs-ganesha-lock.service
%{_unitdir}/nfs-ganesha-config.service
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
%{_sysconfdir}/systemd/system/nfs-ganesha.d/rpc-statd.conf
%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d/rpc-statd.conf
%endif
%if %{with man_page}
@ -857,6 +859,9 @@ exit 0
%endif
%changelog
* Thu Jun 18 2020 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 2.8.4-2
- rhbz#1848208
* Wed May 6 2020 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 2.8.4-1
- nfs-ganesha 2.8.4 GA