NFS-Ganesha 3.4 GA

Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
Kaleb S KEITHLEY 2020-12-24 10:46:02 -05:00
commit 4d7020b5c4
3 changed files with 16 additions and 119 deletions

View File

@ -1,108 +0,0 @@
From bf842d0cf9ae13408e20963c977d3c85642a69b3 Mon Sep 17 00:00:00 2001
From: "Kaleb S. KEITHLEY" <kkeithle@redhat.com>
Date: Thu, 18 Jun 2020 09:38:13 -0400
Subject: [PATCH] systemd: revised drop-in conf file handling
see https://bugzilla.redhat.com/show_bug.cgi?id=1848208
systemd service file documentation still sucks rocks
This is my current best guess, and at least it doesn't log errors
Change-Id: Iec9847356090e561bfcd5f41a64b35c2e686a3d6
Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
---
src/nfs-ganesha.spec-in.cmake | 6 +++---
src/scripts/systemd/nfs-ganesha-lock.service.debian10 | 2 +-
src/scripts/systemd/nfs-ganesha-lock.service.el8 | 2 +-
src/scripts/systemd/rpc-statd.conf.debian10 | 2 +-
src/scripts/systemd/rpc-statd.conf.el8 | 2 +-
5 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/src/nfs-ganesha.spec-in.cmake b/src/nfs-ganesha.spec-in.cmake
index 9cfda6c0e..d66106d6f 100644
--- a/src/nfs-ganesha.spec-in.cmake
+++ b/src/nfs-ganesha.spec-in.cmake
@@ -557,13 +557,13 @@ install -m 644 config_samples/vfs.conf %{buildroot}%{_sysconfdir}/ganesha
mkdir -p %{buildroot}%{_unitdir}
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
-mkdir -p %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha.d
+mkdir -p %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d
%endif
install -m 644 scripts/systemd/nfs-ganesha.service.el7 %{buildroot}%{_unitdir}/nfs-ganesha.service
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
install -m 644 scripts/systemd/nfs-ganesha-lock.service.el8 %{buildroot}%{_unitdir}/nfs-ganesha-lock.service
-install -m 644 scripts/systemd/rpc-statd.conf.el8 %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha.d/rpc-statd.conf
+install -m 644 scripts/systemd/rpc-statd.conf.el8 %{buildroot}%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d/rpc-statd.conf
%else
install -m 644 scripts/systemd/nfs-ganesha-lock.service.el7 %{buildroot}%{_unitdir}/nfs-ganesha-lock.service
%endif
@@ -677,7 +677,7 @@ exit 0
%{_unitdir}/nfs-ganesha-lock.service
%{_unitdir}/nfs-ganesha-config.service
%if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} >= 8 )
-%{_sysconfdir}/systemd/system/nfs-ganesha.d/rpc-statd.conf
+%{_sysconfdir}/systemd/system/nfs-ganesha-lock.service.d/rpc-statd.conf
%endif
%if %{with man_page}
diff --git a/src/scripts/systemd/nfs-ganesha-lock.service.debian10 b/src/scripts/systemd/nfs-ganesha-lock.service.debian10
index 67af058fe..da06ef4fe 100644
--- a/src/scripts/systemd/nfs-ganesha-lock.service.debian10
+++ b/src/scripts/systemd/nfs-ganesha-lock.service.debian10
@@ -17,7 +17,7 @@
[Unit]
Before=nfs-ganesha.service
-Conflicts=nfs-lock.service rpc-statd.service
+Conflicts=nfs-lock.service
[Service]
ExecStartPre=
diff --git a/src/scripts/systemd/nfs-ganesha-lock.service.el8 b/src/scripts/systemd/nfs-ganesha-lock.service.el8
index 67af058fe..da06ef4fe 100644
--- a/src/scripts/systemd/nfs-ganesha-lock.service.el8
+++ b/src/scripts/systemd/nfs-ganesha-lock.service.el8
@@ -17,7 +17,7 @@
[Unit]
Before=nfs-ganesha.service
-Conflicts=nfs-lock.service rpc-statd.service
+Conflicts=nfs-lock.service
[Service]
ExecStartPre=
diff --git a/src/scripts/systemd/rpc-statd.conf.debian10 b/src/scripts/systemd/rpc-statd.conf.debian10
index 2138f7467..d06fffd4c 100644
--- a/src/scripts/systemd/rpc-statd.conf.debian10
+++ b/src/scripts/systemd/rpc-statd.conf.debian10
@@ -13,7 +13,7 @@ After=nfs-config.service
[Service]
EnvironmentFile=-/run/sysconfig/nfs-utils
Type=forking
-PIDFile=/var/run/rpc.statd.pid
+PIDFile=/run/rpc.statd.pid
ExecStart=/sbin/rpc.statd --no-notify $STATDARGS
[Install]
diff --git a/src/scripts/systemd/rpc-statd.conf.el8 b/src/scripts/systemd/rpc-statd.conf.el8
index 6fec09af1..b67cfdf24 100644
--- a/src/scripts/systemd/rpc-statd.conf.el8
+++ b/src/scripts/systemd/rpc-statd.conf.el8
@@ -1,3 +1,4 @@
+[Unit]
Description=NFS status monitor for NFSv2/3 locking.
DefaultDependencies=no
Conflicts=umount.target
@@ -10,5 +11,5 @@
[Service]
Environment=RPC_STATD_NO_NOTIFY=1
Type=forking
-PIDFile=/var/run/rpc.statd.pid
+PIDFile=/run/rpc.statd.pid
ExecStart=/usr/sbin/rpc.statd
--
2.26.2

View File

@ -114,16 +114,16 @@ Requires: openSUSE-release
# %%global dev rc5
Name: nfs-ganesha
Version: 3.3
Release: 3%{?dev:%{dev}}%{?dist}
Version: 3.4
Release: 1%{?dev:%{dev}}%{?dist}
Summary: NFS-Ganesha is a NFS Server running in user space
License: LGPLv3+
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
Source0: https://github.com/%{name}/%{name}/archive/V%{version}%{?dev:-%{dev}}/%{name}-%{version}%{?dev:-%{dev}}.tar.gz
Patch0001: 0001-systemd-revised-drop-in-conf-file-handling.patch
BuildRequires: cmake
BuildRequires: make
BuildRequires: bison
BuildRequires: flex
BuildRequires: pkgconfig
@ -155,7 +155,7 @@ BuildRequires: libwbclient-devel
%endif
BuildRequires: gcc-c++
%if ( %{with_system_ntirpc} )
BuildRequires: libntirpc-devel = 3.3
BuildRequires: libntirpc-devel = 3.4
%else
Requires: libntirpc = @NTIRPC_VERSION_EMBED@
%endif
@ -209,7 +209,8 @@ BuildRequires: python3-sphinx
%endif
%endif
Requires(post): psmisc
Requires(pre): shadow-utils
Requires(pre): /usr/sbin/useradd
Requires(pre): /usr/sbin/groupadd
%if ( 0%{?fedora} >= 30 || 0%{?rhel} >= 8 )
Requires: nfs-ganesha-selinux = %{version}-%{release}
@ -259,12 +260,13 @@ BuildRequires: python-devel
%else
Requires: python3-gobject, python3-pyparsing
BuildRequires: python3-devel
%endif
BuildRequires: python3-setuptools
%if ( 0%{?suse_version} )
Requires: dbus-1-python
%else
Requires: python3-dbus
%endif
%endif
%if %{with gui_utils}
%if ( 0%{?suse_version} )
@ -359,6 +361,7 @@ be used with NFS-Ganesha to support GPFS backend
Summary: The NFS-GANESHA CephFS FSAL
Requires: nfs-ganesha = %{version}-%{release}
BuildRequires: libcephfs2-devel >= 12.2.0
BuildRequires: libacl-devel
%description ceph
This package contains a FSAL shared object to
@ -493,7 +496,6 @@ Development headers and auxiliary files for developing with %{name}.
%prep
%setup -q -n %{name}-%{version}%{?dev:-%{dev}}
%patch0001 -p1
%build
cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
@ -527,7 +529,9 @@ cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DALLOCATOR=jemalloc
%endif
make VERBOSE=1 %{?_smp_mflags} || make %{?_smp_mflags} || make
export VERBOSE=1
make %{?_smp_mflags} || make %{?_smp_mflags} || make
%if ( 0%{?fedora} >= 30 || 0%{?rhel} >= 8 )
make -C selinux -f /usr/share/selinux/devel/Makefile ganesha.pp
@ -665,8 +669,6 @@ exit 0
%config(noreplace) %{_sysconfdir}/logrotate.d/ganesha
%dir %{_sysconfdir}/ganesha/
%config(noreplace) %{_sysconfdir}/ganesha/ganesha.conf
%dir %{_defaultdocdir}/ganesha/
%{_defaultdocdir}/ganesha/*
%doc src/ChangeLog
%dir %{_rundir}/ganesha
%dir %{_libexecdir}/ganesha/
@ -859,6 +861,9 @@ exit 0
%endif
%changelog
* Wed Dec 23 2020 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.4-1
- NFS-Ganesha 3.4 GA
* Mon Jul 13 2020 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 3.3-3
- rpc-statd.conf.el8

View File

@ -1 +1 @@
SHA512 (nfs-ganesha-3.3.tar.gz) = 35b5f0da26ba7a29738e7c80bb339d7643a1e06cb70e96c790a750a6d8d2ae76434f0e912e9bd00c9fcddb2916fdadc0c5f224069b1699cb4f90926231d64e71
SHA512 (nfs-ganesha-3.4.tar.gz) = fe72d41cf9983824c78a622752e1ae608e14737868b9ab3528ffc019ff990c0336e226fe2a43de1757a694a470ddd47b4dc5580591c47d480f8472c72ee76058