nfs-ganesha 2.6.3 GA

Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
Kaleb S. KEITHLEY 2018-08-22 11:25:11 -04:00
parent bcd493e99b
commit 42f662bec2
3 changed files with 8 additions and 36 deletions

View File

@ -99,15 +99,14 @@ Requires: openSUSE-release
#%%global dash_dev_version 2.6-rc5 #%%global dash_dev_version 2.6-rc5
Name: nfs-ganesha Name: nfs-ganesha
Version: 2.6.2 Version: 2.6.3
Release: 5%{?dev:%{dev}}%{?dist} Release: 1%{?dev:%{dev}}%{?dist}
Summary: NFS-Ganesha is a NFS Server running in user space Summary: NFS-Ganesha is a NFS Server running in user space
Group: Applications/System Group: Applications/System
License: LGPLv3+ License: LGPLv3+
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
Source0: https://github.com/%{name}/%{name}/archive/V%{version}/%{name}-%{version}.tar.gz Source0: https://github.com/%{name}/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
Patch0: xattr.patch
BuildRequires: cmake BuildRequires: cmake
BuildRequires: bison BuildRequires: bison
@ -130,7 +129,7 @@ BuildRequires: libblkid-devel
BuildRequires: libuuid-devel BuildRequires: libuuid-devel
BuildRequires: gcc-c++ BuildRequires: gcc-c++
%if %{with system_ntirpc} %if %{with system_ntirpc}
BuildRequires: libntirpc-devel = 1.6.2 BuildRequires: libntirpc-devel = 1.6.3
%else %else
Requires: libntirpc = @NTIRPC_VERSION_EMBED@ Requires: libntirpc = @NTIRPC_VERSION_EMBED@
%endif %endif
@ -412,7 +411,6 @@ Development headers and auxiliary files for developing with %{name}.
%prep %prep
%setup -q -n %{name}-%{version} %setup -q -n %{name}-%{version}
%patch0 -p1
%build %build
cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \ cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
@ -733,6 +731,9 @@ exit 0
%endif %endif
%changelog %changelog
* Wed Aug 22 2018 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 2.6.3-1
- nfs-ganesha 2.6.3 GA
* Fri Aug 10 2018 Petr Lautrbach <plautrba@redhat.com> - 2.6.2-5 * Fri Aug 10 2018 Petr Lautrbach <plautrba@redhat.com> - 2.6.2-5
- require the correct package with /usr/sbin/semanage - require the correct package with /usr/sbin/semanage

View File

@ -1 +1 @@
SHA512 (nfs-ganesha-2.6.2.tar.gz) = 4a0e87fa0fcb530a5cb2c3a38a7f25098efa1be4d591c25fa2002353173b5b567cf9dfa792070587d77b93ff8817665cf035e9e3f0d154ec63f807382fc3f2d9 SHA512 (nfs-ganesha-2.6.3.tar.gz) = 0689fbf9ce65919611927439260b0d6508973b50dbb497bb8d808d907558b7b7ea58ff8134e6edf6dd0c0b61cdbc7521adf5179e10b3d2880befc5d47ad0ecae

View File

@ -1,29 +0,0 @@
--- nfs-ganesha-2.6.2/src/CMakeLists.txt.orig 2018-07-17 11:47:09.637390285 -0400
+++ nfs-ganesha-2.6.2/src/CMakeLists.txt 2018-07-17 11:47:50.668390285 -0400
@@ -586,12 +586,12 @@
endif(NOT GFAPI_FOUND)
if(USE_FSAL_GLUSTER)
- check_include_files("unistd.h;attr/xattr.h" HAVE_XATTR_H)
+ check_include_files("unistd.h;sys/xattr.h" HAVE_XATTR_H)
if(NOT HAVE_XATTR_H)
if(STRICT_PACKAGE)
- message(FATAL_ERROR "STRICT PACKAGE: Can not find attr/xattr.h, disabling GLUSTER fsal build")
+ message(FATAL_ERROR "STRICT PACKAGE: Can not find sys/xattr.h, disabling GLUSTER fsal build")
else(STRICT_PACKAGE)
- message(WARNING "Can not find attr/xattr.h, disabling GLUSTER fsal build")
+ message(WARNING "Can not find sys/xattr.h, disabling GLUSTER fsal build")
set(USE_FSAL_GLUSTER OFF)
endif(STRICT_PACKAGE)
endif(NOT HAVE_XATTR_H)
--- nfs-ganesha-2.6.2/src/FSAL/FSAL_GLUSTER/gluster_internal.c.orig 2018-07-17 11:49:01.863390285 -0400
+++ nfs-ganesha-2.6.2/src/FSAL/FSAL_GLUSTER/gluster_internal.c 2018-07-17 11:48:32.581390285 -0400
@@ -26,7 +26,7 @@
*/
#include <sys/types.h>
-#include <attr/xattr.h> /* ENOATTR */
+#include "os/xattr.h" /* ENOATTR */
#include "gluster_internal.h"
#include "fsal_api.h"
#include "fsal_convert.h"