nfs-ganesha 2.8.0 RC1, utils and gui_utils disabled until the python

byte_compile problems can be resolved

Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
Kaleb S. KEITHLEY 2019-05-30 18:07:08 -04:00
parent 022276c49e
commit 418b8af108
3 changed files with 45 additions and 36 deletions

View File

@ -1,10 +0,0 @@
--- nfs-ganesha-2.7.3/src/scripts/ganeshactl/CMakeLists.txt.orig 2019-05-16 11:24:41.621105054 -0400
+++ nfs-ganesha-2.7.3/src/scripts/ganeshactl/CMakeLists.txt 2019-05-16 11:24:51.351105054 -0400
@@ -1,6 +1,6 @@
# Building and packaging DBUS scripts for ganesha
-find_program(PYTHON "python")
+find_program(PYTHON "python2")
# PyQT based class modules
set(GANESHA_BASE_SRCS

View File

@ -78,15 +78,18 @@ Requires: openSUSE-release
%bcond_with rdma %bcond_with rdma
%global use_rdma %{on_off_switch rdma} %global use_rdma %{on_off_switch rdma}
%bcond_with 9P
%global use_9P %{on_off_switch 9P}
%bcond_with jemalloc %bcond_with jemalloc
%bcond_without lttng %bcond_with lttng
%global use_lttng %{on_off_switch lttng} %global use_lttng %{on_off_switch lttng}
%bcond_without utils %bcond_with utils
%global use_utils %{on_off_switch utils} %global use_utils %{on_off_switch utils}
%bcond_without gui_utils %bcond_with gui_utils
%global use_gui_utils %{on_off_switch gui_utils} %global use_gui_utils %{on_off_switch gui_utils}
%bcond_without system_ntirpc %bcond_without system_ntirpc
@ -123,23 +126,24 @@ Requires: openSUSE-release
%endif %endif
%global dev_version %{lua: s = string.gsub('@GANESHA_EXTRA_VERSION@', '^%-', ''); s2 = string.gsub(s, '%-', '.'); print((s2 ~= nil and s2 ~= '') and s2 or "0.1") } %global dev_version %{lua: s = string.gsub('@GANESHA_EXTRA_VERSION@', '^%-', ''); s2 = string.gsub(s, '%-', '.'); print((s2 ~= nil and s2 ~= '') and s2 or "0.1") }
#%%global dev rc5 %global dev rc1
#%%global dash_dev_version 2.6-rc5 %global dash_dev_version 2.8-rc1
Name: nfs-ganesha Name: nfs-ganesha
Version: 2.7.3 Version: 2.8.0
Release: 4%{?dev:%{dev}}%{?dist} Release: 0.1%{?dev:%{dev}}%{?dist}
Summary: NFS-Ganesha is a NFS Server running in user space Summary: NFS-Ganesha is a NFS Server running in user space
License: LGPLv3+ License: LGPLv3+
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
Source0: https://github.com/%{name}/%{name}/archive/V%{version}/%{name}-%{version}.tar.gz Source0: https://github.com/%{name}/%{name}/archive/V%{dash_dev_version}/%{name}-%{dash_dev_version}.tar.gz
Patch1: 0001_src_scripts_ganeshactl_CMakeLists.txt.patch Patch1: 0001_src_scripts_ganeshactl_CMakeLists.txt.patch
BuildRequires: cmake BuildRequires: cmake
BuildRequires: bison BuildRequires: bison
BuildRequires: flex BuildRequires: flex
BuildRequires: pkgconfig BuildRequires: pkgconfig
BuildRequires: userspace-rcu-devel
BuildRequires: krb5-devel BuildRequires: krb5-devel
%if ( 0%{?suse_version} >= 1330 ) %if ( 0%{?suse_version} >= 1330 )
BuildRequires: libnsl-devel BuildRequires: libnsl-devel
@ -164,7 +168,7 @@ BuildRequires: libwbclient-devel
%endif %endif
BuildRequires: gcc-c++ BuildRequires: gcc-c++
%if ( %{with_system_ntirpc} ) %if ( %{with_system_ntirpc} )
BuildRequires: libntirpc-devel >= 1.7.2 BuildRequires: libntirpc-devel >= 1.8.0
%else %else
Requires: libntirpc = @NTIRPC_VERSION_EMBED@ Requires: libntirpc = @NTIRPC_VERSION_EMBED@
%endif %endif
@ -231,12 +235,14 @@ nfs-ganesha : NFS-GANESHA is a NFS Server running in user space.
It comes with various back-end modules (called FSALs) provided as It comes with various back-end modules (called FSALs) provided as
shared objects to support different file systems and name-spaces. shared objects to support different file systems and name-spaces.
%if %{with 9P}
%package mount-9P %package mount-9P
Summary: a 9p mount helper Summary: a 9p mount helper
%description mount-9P %description mount-9P
This package contains the mount.9P script that clients can use This package contains the mount.9P script that clients can use
to simplify mounting to NFS-GANESHA. This is a 9p mount helper. to simplify mounting to NFS-GANESHA. This is a 9p mount helper.
%endif
%package vfs %package vfs
Summary: The NFS-GANESHA VFS FSAL Summary: The NFS-GANESHA VFS FSAL
@ -262,8 +268,17 @@ be used with NFS-Ganesha to support PROXY based filesystems
Summary: The NFS-GANESHA util scripts Summary: The NFS-GANESHA util scripts
%if ( 0%{?suse_version} ) %if ( 0%{?suse_version} )
Requires: dbus-1-python, python-gobject2 python-pyparsing Requires: dbus-1-python, python-gobject2 python-pyparsing
Requires: gpfs.nfs-ganesha = %{version}-%{release}, python
%else
%if ( 0%{?fedora} >= 28 || 0%{?rhel} >= 8 )
Requires: python3-dbus, python3-gobject, python3-pyparsing
Requires: gpfs.nfs-ganesha = %{version}-%{release}, python3
BuildRequires: python3-devel
%else %else
Requires: python2-dbus, pygobject2, python2-pyparsing Requires: python2-dbus, pygobject2, python2-pyparsing
Requires: gpfs.nfs-ganesha = %{version}-%{release}, python2
BuildRequires: python2-devel
%endif
%endif %endif
%if %{with gui_utils} %if %{with gui_utils}
%if ( 0%{?suse_version} ) %if ( 0%{?suse_version} )
@ -274,14 +289,6 @@ BuildRequires: PyQt4-devel
Requires: PyQt4 Requires: PyQt4
%endif %endif
%endif %endif
%if ( 0%{?suse_version} )
BuildRequires: python2-devel
Requires: nfs-ganesha = %{version}-%{release}, python
%else
BuildRequires: python-unversioned-command
BuildRequires: python2-devel
Requires: nfs-ganesha = %{version}-%{release}, python2
%endif
%description utils %description utils
This package contains utility scripts for managing the NFS-GANESHA server This package contains utility scripts for managing the NFS-GANESHA server
@ -485,7 +492,7 @@ Development headers and auxiliary files for developing with %{name}.
%endif %endif
%prep %prep
%setup -q -n %{name}-%{version} %setup -q -n %{name}-%{dash_dev_version}
%patch1 -p1 %patch1 -p1
%build %build
@ -510,7 +517,7 @@ cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DUSE_FSAL_VFS=ON \ -DUSE_FSAL_VFS=ON \
-DUSE_FSAL_PROXY=ON \ -DUSE_FSAL_PROXY=ON \
-DUSE_DBUS=ON \ -DUSE_DBUS=ON \
-DUSE_9P=ON \ -DUSE_9P=%{use_9P} \
-DDISTNAME_HAS_GIT_DATA=OFF \ -DDISTNAME_HAS_GIT_DATA=OFF \
-DUSE_MAN_PAGE=%{use_man_page} \ -DUSE_MAN_PAGE=%{use_man_page} \
-DRPCBIND=%{use_rpcbind} \ -DRPCBIND=%{use_rpcbind} \
@ -520,7 +527,7 @@ cd src && %cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DALLOCATOR=jemalloc -DALLOCATOR=jemalloc
%endif %endif
make %{?_smp_mflags} || make %{?_smp_mflags} || make make VERBOSE=1 %{?_smp_mflags} || make %{?_smp_mflags} || make
%if ( 0%{?fedora} >= 30 || 0%{?rhel} >= 8 ) %if ( 0%{?fedora} >= 30 || 0%{?rhel} >= 8 )
make -C selinux -f /usr/share/selinux/devel/Makefile ganesha.pp make -C selinux -f /usr/share/selinux/devel/Makefile ganesha.pp
@ -541,7 +548,9 @@ cd src
install -m 644 config_samples/logrotate_ganesha %{buildroot}%{_sysconfdir}/logrotate.d/ganesha install -m 644 config_samples/logrotate_ganesha %{buildroot}%{_sysconfdir}/logrotate.d/ganesha
install -m 644 scripts/ganeshactl/org.ganesha.nfsd.conf %{buildroot}%{_sysconfdir}/dbus-1/system.d install -m 644 scripts/ganeshactl/org.ganesha.nfsd.conf %{buildroot}%{_sysconfdir}/dbus-1/system.d
install -m 755 scripts/nfs-ganesha-config.sh %{buildroot}%{_libexecdir}/ganesha install -m 755 scripts/nfs-ganesha-config.sh %{buildroot}%{_libexecdir}/ganesha
%if %{with 9P}
install -m 755 tools/mount.9P %{buildroot}%{_sbindir}/mount.9P install -m 755 tools/mount.9P %{buildroot}%{_sbindir}/mount.9P
%endif
install -m 644 config_samples/vfs.conf %{buildroot}%{_sysconfdir}/ganesha install -m 644 config_samples/vfs.conf %{buildroot}%{_sysconfdir}/ganesha
%if %{with rgw} %if %{with rgw}
install -m 644 config_samples/rgw.conf %{buildroot}%{_sysconfdir}/ganesha install -m 644 config_samples/rgw.conf %{buildroot}%{_sysconfdir}/ganesha
@ -576,10 +585,6 @@ install -m 644 config_samples/xfs.conf %{buildroot}%{_sysconfdir}/ganesha
install -m 644 config_samples/ceph.conf %{buildroot}%{_sysconfdir}/ganesha install -m 644 config_samples/ceph.conf %{buildroot}%{_sysconfdir}/ganesha
%endif %endif
%if %{with rados_recov}
install -m 755 tools/ganesha-rados-grace %{buildroot}%{_bindir}/ganesha-rados-grace
%endif
%if %{with rgw} %if %{with rgw}
install -m 644 config_samples/rgw.conf %{buildroot}%{_sysconfdir}/ganesha install -m 644 config_samples/rgw.conf %{buildroot}%{_sysconfdir}/ganesha
install -m 644 config_samples/rgw_bucket.conf %{buildroot}%{_sysconfdir}/ganesha install -m 644 config_samples/rgw_bucket.conf %{buildroot}%{_sysconfdir}/ganesha
@ -658,6 +663,7 @@ exit 0
%files %files
%license src/LICENSE.txt %license src/LICENSE.txt
%{_bindir}/ganesha.nfsd %{_bindir}/ganesha.nfsd
%{_libdir}/libganesha_nfsd.so*
%config %{_sysconfdir}/dbus-1/system.d/org.ganesha.nfsd.conf %config %{_sysconfdir}/dbus-1/system.d/org.ganesha.nfsd.conf
%config(noreplace) %{_sysconfdir}/sysconfig/ganesha %config(noreplace) %{_sysconfdir}/sysconfig/ganesha
%config(noreplace) %{_sysconfdir}/logrotate.d/ganesha %config(noreplace) %{_sysconfdir}/logrotate.d/ganesha
@ -699,11 +705,13 @@ exit 0
%endif %endif
%endif %endif
%if %{with 9P}
%files mount-9P %files mount-9P
%{_sbindir}/mount.9P %{_sbindir}/mount.9P
%if %{with man_page} %if %{with man_page}
%{_mandir}/*/ganesha-9p-config.8.gz %{_mandir}/*/ganesha-9p-config.8.gz
%endif %endif
%endif
%files vfs %files vfs
%{_libdir}/ganesha/libfsalvfs* %{_libdir}/ganesha/libfsalvfs*
@ -828,18 +836,25 @@ exit 0
%{python2_sitelib}/Ganesha/* %{python2_sitelib}/Ganesha/*
%{python2_sitelib}/ganeshactl-*-info %{python2_sitelib}/ganeshactl-*-info
%else %else
%if ( 0%{?fedora} >= 28 || 0%{?rhel} >= 8 )
%{python3_sitelib}/Ganesha/*
%{python3_sitelib}/ganeshactl-*-info
%else
%{python2_sitelib}/Ganesha/* %{python2_sitelib}/Ganesha/*
%{python2_sitelib}/ganeshactl-*-info %{python2_sitelib}/ganeshactl-*-info
%endif %endif
%endif
%if %{with gui_utils} %if %{with gui_utils}
%{_bindir}/ganesha-admin %{_bindir}/ganesha-admin
%{_bindir}/manage_clients %{_bindir}/manage_clients
%{_bindir}/manage_exports %{_bindir}/manage_exports
%{_bindir}/manage_logger %{_bindir}/manage_logger
%{_bindir}/ganeshactl %{_bindir}/ganeshactl
%if %{with 9P}
%{_bindir}/client_stats_9pOps %{_bindir}/client_stats_9pOps
%{_bindir}/export_stats_9pOps %{_bindir}/export_stats_9pOps
%endif %endif
%endif
%{_bindir}/fake_recall %{_bindir}/fake_recall
%{_bindir}/get_clientids %{_bindir}/get_clientids
%{_bindir}/grace_period %{_bindir}/grace_period
@ -851,6 +866,10 @@ exit 0
%endif %endif
%changelog %changelog
* Thu May 30 2019 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 2.8.0-0.1rc1
- nfs-ganesha 2.8.0 RC1, utils and gui_utils disabled until the python
byte_compile problems can be resolved
* Fri May 17 2019 Miro Hrončok <mhroncok@redhat.com> - 2.7.3-4 * Fri May 17 2019 Miro Hrončok <mhroncok@redhat.com> - 2.7.3-4
- Avoid unversioned Python requires - Avoid unversioned Python requires

View File

@ -1 +1 @@
SHA512 (nfs-ganesha-2.7.3.tar.gz) = 9259860502ad77aec105a1d3ae5d37f34db39227c100b74fd88a6b1a45d517b290baf12538f8bc939ae4c04e07b9022ce617c31d956f69afe36cc91baf702164 SHA512 (nfs-ganesha-2.8-rc1.tar.gz) = 5ee34329a9276d9e379e14db4046df60708b67b3647123e52def10de395f76c90e01d3f0746f7d4ab8f425eb465f07522b037dac1ce793571ef0886f943edcb4