NFS-Ganesha 4.0 RC4, w/ utils and gui_utils (python)

Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
Kaleb S. KEITHLEY 2021-11-17 09:48:47 -05:00
parent 66fd3679e7
commit 047b685db6
3 changed files with 67 additions and 4 deletions

View File

@ -15,3 +15,64 @@
endif (USE_ADMIN_TOOLS)
gopt_test(USE_GUI_ADMIN_TOOLS)
--- nfs-ganesha-4-rc4/src/scripts/ganeshactl/CMakeLists.txt.orig 2021-11-17 09:22:20.860134361 -0500
+++ nfs-ganesha-4-rc4/src/scripts/ganeshactl/CMakeLists.txt 2021-11-17 09:41:47.651949504 -0500
@@ -44,7 +44,7 @@
Ganesha/QtUI/ui_log_dialog.ui
)
-if(Python_FOUND)
+if(PYTHONINTERP_FOUND)
set(SETUP_PY_IN "${CMAKE_CURRENT_SOURCE_DIR}/setup.py.in")
set(SETUP_PY "${CMAKE_CURRENT_BINARY_DIR}/setup.py")
set(OUTPUT "${CMAKE_CURRENT_BINARY_DIR}/build/ganeshactl_timestamp")
@@ -118,7 +118,7 @@
add_custom_command(
OUTPUT ${OUTPUT}
- COMMAND ${Python_EXECUTABLE} "${SETUP_PY}" build
+ COMMAND ${PYTHON_EXECUTABLE} "${SETUP_PY}" build
COMMAND ${CMAKE_COMMAND} -E touch ${OUTPUT}
DEPENDS ${GANESHA_SRCS} ${UI_PY_FILES} ${SCRIPTS}
)
@@ -127,9 +127,9 @@
install(
CODE
- "execute_process(WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${Python_EXECUTABLE} ${SETUP_PY} install --skip-build --no-compile --prefix=\$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX})"
+ "execute_process(WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${PYTHON_EXECUTABLE} ${SETUP_PY} install --skip-build --no-compile --prefix=\$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX})"
)
-endif(Python_FOUND)
+endif(PYTHONINTERP_FOUND)
# Man page
set(man8_file ganesha_conf.man)
--- nfs-ganesha-4-rc4/src/scripts/gpfs-epoch/CMakeLists.txt.orig 2021-11-17 09:22:55.938555754 -0500
+++ nfs-ganesha-4-rc4/src/scripts/gpfs-epoch/CMakeLists.txt 2021-11-17 09:41:32.836208727 -0500
@@ -1,6 +1,6 @@
if(USE_FSAL_GPFS)
- if(Python_FOUND)
+ if(PYTHONINTERP_FOUND)
set(SETUP_PY_IN "${CMAKE_CURRENT_SOURCE_DIR}/setup.py.in")
set(SETUP_PY "${CMAKE_CURRENT_BINARY_DIR}/setup.py")
set(OUTPUT "${CMAKE_CURRENT_BINARY_DIR}/build/gpfs_epoch_timestamp")
@@ -38,7 +38,7 @@
add_custom_command(
OUTPUT ${OUTPUT}
COMMAND ${CMAKE_COMMAND} -E touch __init__.py
- COMMAND ${Python_EXECUTABLE} "${SETUP_PY}" build
+ COMMAND ${PYTHON_EXECUTABLE} "${SETUP_PY}" build
COMMAND ${CMAKE_COMMAND} -E touch ${OUTPUT}
DEPENDS ${GPFS_EPOCH_SRCS} ${SCRIPTS}
)
@@ -47,7 +47,7 @@
install(
CODE
- "execute_process(WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${Python_EXECUTABLE} ${SETUP_PY} install --skip-build --no-compile --prefix=\$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX} --install-scripts=\$ENV{DESTDIR}${LIBEXECDIR}/ganesha)"
+ "execute_process(WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${PYTHON_EXECUTABLE} ${SETUP_PY} install --skip-build --no-compile --prefix=\$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX} --install-scripts=\$ENV{DESTDIR}${LIBEXECDIR}/ganesha)"
)
- endif(Python_FOUND)
+ endif(PYTHONINTERP_FOUND)
endif(USE_FSAL_GPFS)

View File

@ -71,10 +71,10 @@ Requires: openSUSE-release
%bcond_with lttng
%global use_lttng %{on_off_switch lttng}
%bcond_with utils
%bcond_without utils
%global use_utils %{on_off_switch utils}
%bcond_with gui_utils
%bcond_without gui_utils
%global use_gui_utils %{on_off_switch gui_utils}
%bcond_without system_ntirpc
@ -115,7 +115,7 @@ Requires: openSUSE-release
Name: nfs-ganesha
Version: 4.0
Release: 0.2%{?dev:%{dev}}%{?dist}
Release: 0.3%{?dev:%{dev}}%{?dist}
Summary: NFS-Ganesha is a NFS Server running in user space
License: LGPLv3+
Url: https://github.com/nfs-ganesha/nfs-ganesha/wiki
@ -888,6 +888,9 @@ exit 0
%endif
%changelog
* Wed Nov 17 2021 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 4.0-0.3rc4
- NFS-Ganesha 4.0 RC4, w/ utils and gui_utils (python)
* Wed Nov 17 2021 Kaleb S. KEITHLEY <kkeithle at redhat.com> - 4.0-0.2rc4
- NFS-Ganesha 4.0 RC4

View File

@ -1,2 +1 @@
SHA512 (nfs-ganesha-4.0rc3.tar.gz) = 318cfecb0bc58bc76849c915e0bd714133318a54ad62d969fd8d282d191fff0fcf9d5233c1749044035d9a2e97ec124aae7a39935fda243d3b21d4d6fb8de0cf
SHA512 (nfs-ganesha-4.0rc4.tar.gz) = 25fb9ac0368a57a0db42c8d949c53e86d309107df018a18e47e1b950945f4e3b9654e8aefb6bc24d9a9e8df55244e4979eee1047322d82e2300b9bc573157c3e