Initial commit

This commit is contained in:
Stanislav Ochotnicky 2011-01-18 11:02:23 +01:00
parent ec165c1d8a
commit af5fe56c10
6 changed files with 404 additions and 0 deletions

1
.gitignore vendored
View File

@ -0,0 +1 @@
/netty-3.2.3.Final-dist.tar.bz2

View File

@ -0,0 +1,61 @@
From 12b26381c9c47432d63f941b2bf4877874e78c12 Mon Sep 17 00:00:00 2001
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
Date: Thu, 13 Jan 2011 14:59:07 +0100
Subject: [PATCH 1/3] Remove parent and fix javadoc plugin config
---
pom.xml | 21 ---------------------
1 files changed, 0 insertions(+), 21 deletions(-)
diff --git a/pom.xml b/pom.xml
index fbece2d..806f05c 100644
--- a/pom.xml
+++ b/pom.xml
@@ -17,11 +17,6 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
- <parent>
- <groupId>org.jboss</groupId>
- <artifactId>jboss-parent</artifactId>
- <version>5</version>
- </parent>
<groupId>org.jboss.netty</groupId>
<artifactId>netty</artifactId>
@@ -400,23 +395,9 @@
</execution>
</executions>
<configuration>
- <doclet>org.jboss.apiviz.APIviz</doclet>
- <docletArtifact>
- <groupId>org.jboss.apiviz</groupId>
- <artifactId>apiviz</artifactId>
- <version>1.3.1.GA</version>
- </docletArtifact>
- <attach>false</attach>
<stylesheetfile>${basedir}/src/javadoc/stylesheet.css</stylesheetfile>
- <javadocDirectory>${basedir}/src/javadoc</javadocDirectory>
- <docfilessubdirs>true</docfilessubdirs>
- <useStandardDocletOptions>true</useStandardDocletOptions>
- <outputDirectory>${project.build.directory}/api</outputDirectory>
- <reportOutputDirectory>${project.build.directory}/api</reportOutputDirectory>
- <destDir>api</destDir>
<charset>UTF-8</charset>
<docencoding>UTF-8</docencoding>
- <breakiterator>true</breakiterator>
<version>true</version>
<author>true</author>
<keywords>true</keywords>
@@ -438,8 +419,6 @@
-group "Reusable I/O event interceptors" ${project.groupId}.handler*
-group "Miscellaneous" ${project.groupId}.logging*:${project.groupId}.util*
- -sourceclasspath ${project.build.outputDirectory}
- -nopackagediagram
</additionalparam>
<encoding>UTF-8</encoding>
<locale>en_US</locale>
--
1.7.3.4

View File

@ -0,0 +1,172 @@
From 13a221991b69065fbd70fd9f6d29d62f03880ef1 Mon Sep 17 00:00:00 2001
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
Date: Thu, 13 Jan 2011 14:59:40 +0100
Subject: [PATCH 2/3] Remove optional deps
---
pom.xml | 135 ---------------------------------------------------------------
1 files changed, 0 insertions(+), 135 deletions(-)
diff --git a/pom.xml b/pom.xml
index 806f05c..e61a552 100644
--- a/pom.xml
+++ b/pom.xml
@@ -111,13 +111,6 @@
<optional>true</optional>
</dependency>
<dependency>
- <groupId>org.jboss.logging</groupId>
- <artifactId>jboss-logging-spi</artifactId>
- <version>2.1.1.GA</version>
- <scope>compile</scope>
- <optional>true</optional>
- </dependency>
- <dependency>
<groupId>log4j</groupId>
<artifactId>log4j</artifactId>
<version>1.2.16</version>
@@ -157,12 +150,6 @@
<scope>test</scope>
</dependency>
<dependency>
- <groupId>org.easymock</groupId>
- <artifactId>easymockclassextension</artifactId>
- <version>2.5.2</version>
- <scope>test</scope>
- </dependency>
- <dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-simple</artifactId>
<version>1.5.11</version>
@@ -426,128 +413,6 @@
</configuration>
</plugin>
<plugin>
- <artifactId>maven-jxr-plugin</artifactId>
- <version>2.1</version>
- <executions>
- <execution>
- <id>generate-xref</id>
- <phase>package</phase>
- <goals>
- <goal>jxr</goal>
- </goals>
- </execution>
- </executions>
- <configuration>
- <inputEncoding>UTF-8</inputEncoding>
- <outputEncoding>UTF-8</outputEncoding>
- <linkJavadoc>true</linkJavadoc>
- <destDir>${project.build.directory}/xref</destDir>
- <javadocDir>${project.build.directory}/api</javadocDir>
- <stylesheet>${basedir}/src/xref/stylesheet.css</stylesheet>
- <docTitle>${project.name} Source Xref (${project.version}, r${buildNumber})</docTitle>
- <windowTitle>${project.name} Source Xref (${project.version}, r${buildNumber})</windowTitle>
- </configuration>
- </plugin>
- <plugin>
- <groupId>org.jboss.maven.plugins</groupId>
- <artifactId>maven-jdocbook-plugin</artifactId>
- <version>2.2.1</version>
- <executions>
- <execution>
- <id>generate-docbook</id>
- <phase>package</phase>
- <goals>
- <goal>resources</goal>
- <goal>generate</goal>
- </goals>
- </execution>
- </executions>
- <dependencies>
- <dependency>
- <groupId>org.jboss</groupId>
- <artifactId>jbossorg-docbook-xslt</artifactId>
- <version>1.1.0</version>
- <exclusions>
- <exclusion>
- <groupId>org.eclipse.wst.css</groupId>
- <artifactId>core</artifactId>
- </exclusion>
- <exclusion>
- <groupId>org.eclipse.wst.sse</groupId>
- <artifactId>core</artifactId>
- </exclusion>
- </exclusions>
- </dependency>
- <dependency>
- <groupId>org.jboss</groupId>
- <artifactId>jbossorg-jdocbook-style</artifactId>
- <version>1.1.0</version>
- <type>jdocbook-style</type>
- <exclusions>
- <exclusion>
- <groupId>org.eclipse.wst.css</groupId>
- <artifactId>core</artifactId>
- </exclusion>
- <exclusion>
- <groupId>org.eclipse.wst.sse</groupId>
- <artifactId>core</artifactId>
- </exclusion>
- </exclusions>
- </dependency>
- <dependency>
- <groupId>org.jboss</groupId>
- <artifactId>jbossorg-fonts</artifactId>
- <version>1.0.0</version>
- <type>jdocbook-style</type>
- </dependency>
- </dependencies>
- <configuration>
- <sourceDocumentName>master.xml</sourceDocumentName>
- <sourceDirectory>${basedir}/src/docbook</sourceDirectory>
- <cssResource>
- <directory>${basedir}/src/docbook</directory>
- <includes>
- <include>css/**/*</include>
- </includes>
- </cssResource>
- <imageResource>
- <directory>${basedir}/src/docbook</directory>
- <includes>
- <include>images/**/*</include>
- </includes>
- </imageResource>
- <formats>
- <format>
- <formatName>html</formatName>
- <stylesheetResource>file:///${basedir}/src/docbook/xslt/xhtml.xsl</stylesheetResource>
- <finalName>index.html</finalName>
- </format>
- <format>
- <formatName>html_single</formatName>
- <stylesheetResource>file:///${basedir}/src/docbook/xslt/xhtml-single.xsl</stylesheetResource>
- <finalName>index.html</finalName>
- </format>
- <format>
- <formatName>eclipse</formatName>
- <stylesheetResource>file:///${basedir}/src/docbook/xslt/eclipse.xsl</stylesheetResource>
- <finalName>index.html</finalName>
- </format>
- <format>
- <formatName>pdf</formatName>
- <stylesheetResource>file:///${basedir}/src/docbook/xslt/pdf.xsl</stylesheetResource>
- <finalName>netty.pdf</finalName>
- </format>
- </formats>
- <options>
- <xincludeSupported>true</xincludeSupported>
- <xmlTransformerType>saxon</xmlTransformerType>
- <docbookVersion>1.72.0</docbookVersion>
- <localeSeparator>-</localeSeparator>
- <autoDetectFonts>true</autoDetectFonts>
- </options>
- </configuration>
- </plugin>
- <plugin>
<artifactId>maven-assembly-plugin</artifactId>
<version>2.2-beta-5</version>
<executions>
--
1.7.3.4

View File

@ -0,0 +1,33 @@
From 06b89af693f824af86a3103505bb7f93128c22a2 Mon Sep 17 00:00:00 2001
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
Date: Thu, 13 Jan 2011 15:02:01 +0100
Subject: [PATCH 3/3] Replace jboss logger with jdk logger
---
.../microcontainer/NettyLoggerConfigurator.java | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/main/java/org/jboss/netty/container/microcontainer/NettyLoggerConfigurator.java b/src/main/java/org/jboss/netty/container/microcontainer/NettyLoggerConfigurator.java
index 2ccc731..eca8a6a 100644
--- a/src/main/java/org/jboss/netty/container/microcontainer/NettyLoggerConfigurator.java
+++ b/src/main/java/org/jboss/netty/container/microcontainer/NettyLoggerConfigurator.java
@@ -16,7 +16,7 @@
package org.jboss.netty.container.microcontainer;
import org.jboss.netty.logging.InternalLoggerFactory;
-import org.jboss.netty.logging.JBossLoggerFactory;
+import org.jboss.netty.logging.JdkLoggerFactory;
/**
* A bean that configures the default {@link InternalLoggerFactory}.
@@ -27,6 +27,6 @@ import org.jboss.netty.logging.JBossLoggerFactory;
*/
public class NettyLoggerConfigurator {
public NettyLoggerConfigurator() {
- InternalLoggerFactory.setDefaultFactory(new JBossLoggerFactory());
+ InternalLoggerFactory.setDefaultFactory(new JdkLoggerFactory());
}
}
--
1.7.3.4

136
netty.spec Normal file
View File

@ -0,0 +1,136 @@
Name: netty
Version: 3.2.3
Release: 2%{?dist}
Summary: An asynchronous event-driven network application framework and tools for Java
Group: Development/Libraries
License: ASL 2.0
URL: http://www.jboss.org/netty
Source0: http://sourceforge.net/projects/jboss/files/%{name}-%{version}.Final-dist.tar.bz2
Patch0: 0001-Remove-parent-and-fix-javadoc-plugin-config.patch
Patch1: 0002-Remove-optional-deps.patch
Patch2: 0003-Replace-jboss-logger-with-jdk-logger.patch
BuildArch: noarch
# This pulls in all of the required java and maven stuff
BuildRequires: maven
BuildRequires: maven-antrun-plugin
BuildRequires: maven-assembly-plugin
BuildRequires: maven-compiler-plugin
BuildRequires: maven-eclipse-plugin
BuildRequires: maven-javadoc-plugin
BuildRequires: maven-resources-plugin
BuildRequires: maven-release-plugin
BuildRequires: maven-source-plugin
BuildRequires: maven-surefire-plugin
BuildRequires: maven-plugin-bundle
BuildRequires: buildnumber-maven-plugin
BuildRequires: ant-contrib
BuildRequires: subversion
BuildRequires: protobuf-java
BuildRequires: felix-osgi-compendium
Requires: java
Requires: protobuf-java
Requires(post): jpackage-utils
Requires(postun): jpackage-utils
%description
Netty is a NIO client server framework which enables quick and easy
development of network applications such as protocol servers and
clients. It greatly simplifies and streamlines network programming
such as TCP and UDP socket server.
'Quick and easy' doesn't mean that a resulting application will suffer
from a maintainability or a performance issue. Netty has been designed
carefully with the experiences earned from the implementation of a lot
of protocols such as FTP, SMTP, HTTP, and various binary and
text-based legacy protocols. As a result, Netty has succeeded to find
a way to achieve ease of development, performance, stability, and
flexibility without a compromise.
%package javadoc
Summary: API documentation for %{name}
Group: Documentation
Requires: jpackage-utils
%description javadoc
%{summary}.
%prep
%setup -q -n %{name}-%{version}.Final
# just to be sure, but not used anyway
rm -rf jar/
%patch0 -p1
%patch1 -p1
# we don't have jboss logging facilites so we replace it with jdk logger
rm src/main/java/org/jboss/netty/logging/JBossLogger*.java
%patch2 -p1
%build
export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
mkdir -p $MAVEN_REPO_LOCAL
# skipping tests because we don't have all dependencies in Fedora
mvn-local \
-Dmaven.repo.local=$MAVEN_REPO_LOCAL \
-Dmaven.test.skip=true \
install javadoc:javadoc
%install
install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
install -m 644 target/%{name}-%{version}.Final.jar \
$RPM_BUILD_ROOT%{_javadir}/%{name}.jar
install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}
cp -pr target/site/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
install -d -m 755 $RPM_BUILD_ROOT%{_mavenpomdir}
install -pm 644 pom.xml $RPM_BUILD_ROOT/%{_mavenpomdir}/JPP-%{name}.pom
%add_to_maven_depmap org.jboss.netty netty %{version} JPP %{name}
%post
%update_maven_depmap
%postun
%update_maven_depmap
%files
%defattr(-,root,root,-)
%doc LICENSE.txt NOTICE.txt
%{_javadir}/*.jar
%{_mavendepmapfragdir}/%{name}
%{_mavenpomdir}/JPP-%{name}.pom
%files javadoc
%defattr(-,root,root,-)
%doc LICENSE.txt NOTICE.txt
%{_javadocdir}/%{name}
%changelog
* Mon Jan 17 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.2.3-2
- Use maven 3 to build
- Drop ant-contrib depmap (no longer needed)
* Thu Jan 13 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.2.3-1
- Initial version of the package

View File

@ -0,0 +1 @@
000441ea4a805fc9f3abe3aa1e93c85f netty-3.2.3.Final-dist.tar.bz2