Update to latest upstream version
This commit is contained in:
parent
09fe525990
commit
329d8d630b
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/netty-3.2.3.Final-dist.tar.bz2
|
/netty-3.2.3.Final-dist.tar.bz2
|
||||||
|
/netty-3.2.4.Final-dist.tar.bz2
|
||||||
|
@ -1,23 +1,23 @@
|
|||||||
From 13a221991b69065fbd70fd9f6d29d62f03880ef1 Mon Sep 17 00:00:00 2001
|
From f246eb5c5ac4f19e93706630b39ce27cea1918e1 Mon Sep 17 00:00:00 2001
|
||||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||||
Date: Thu, 13 Jan 2011 14:59:40 +0100
|
Date: Mon, 5 Dec 2011 14:15:52 +0100
|
||||||
Subject: [PATCH 2/3] Remove optional deps
|
Subject: [PATCH 1/4] Remove optional deps
|
||||||
|
|
||||||
---
|
---
|
||||||
pom.xml | 135 ---------------------------------------------------------------
|
pom.xml | 129 ---------------------------------------------------------------
|
||||||
1 files changed, 0 insertions(+), 135 deletions(-)
|
1 files changed, 0 insertions(+), 129 deletions(-)
|
||||||
|
|
||||||
diff --git a/pom.xml b/pom.xml
|
diff --git a/pom.xml b/pom.xml
|
||||||
index 806f05c..e61a552 100644
|
index a1597fe..77fb611 100644
|
||||||
--- a/pom.xml
|
--- a/pom.xml
|
||||||
+++ b/pom.xml
|
+++ b/pom.xml
|
||||||
@@ -111,13 +111,6 @@
|
@@ -116,13 +116,6 @@
|
||||||
<optional>true</optional>
|
<optional>true</optional>
|
||||||
</dependency>
|
</dependency>
|
||||||
<dependency>
|
<dependency>
|
||||||
- <groupId>org.jboss.logging</groupId>
|
- <groupId>org.jboss.logging</groupId>
|
||||||
- <artifactId>jboss-logging-spi</artifactId>
|
- <artifactId>jboss-logging-spi</artifactId>
|
||||||
- <version>2.1.1.GA</version>
|
- <version>2.1.2.GA</version>
|
||||||
- <scope>compile</scope>
|
- <scope>compile</scope>
|
||||||
- <optional>true</optional>
|
- <optional>true</optional>
|
||||||
- </dependency>
|
- </dependency>
|
||||||
@ -25,25 +25,12 @@ index 806f05c..e61a552 100644
|
|||||||
<groupId>log4j</groupId>
|
<groupId>log4j</groupId>
|
||||||
<artifactId>log4j</artifactId>
|
<artifactId>log4j</artifactId>
|
||||||
<version>1.2.16</version>
|
<version>1.2.16</version>
|
||||||
@@ -157,12 +150,6 @@
|
@@ -462,128 +455,6 @@
|
||||||
<scope>test</scope>
|
|
||||||
</dependency>
|
|
||||||
<dependency>
|
|
||||||
- <groupId>org.easymock</groupId>
|
|
||||||
- <artifactId>easymockclassextension</artifactId>
|
|
||||||
- <version>2.5.2</version>
|
|
||||||
- <scope>test</scope>
|
|
||||||
- </dependency>
|
|
||||||
- <dependency>
|
|
||||||
<groupId>org.slf4j</groupId>
|
|
||||||
<artifactId>slf4j-simple</artifactId>
|
|
||||||
<version>1.5.11</version>
|
|
||||||
@@ -426,128 +413,6 @@
|
|
||||||
</configuration>
|
</configuration>
|
||||||
</plugin>
|
</plugin>
|
||||||
<plugin>
|
<plugin>
|
||||||
- <artifactId>maven-jxr-plugin</artifactId>
|
- <artifactId>maven-jxr-plugin</artifactId>
|
||||||
- <version>2.1</version>
|
- <version>2.2</version>
|
||||||
- <executions>
|
- <executions>
|
||||||
- <execution>
|
- <execution>
|
||||||
- <id>generate-xref</id>
|
- <id>generate-xref</id>
|
||||||
@ -60,8 +47,8 @@ index 806f05c..e61a552 100644
|
|||||||
- <destDir>${project.build.directory}/xref</destDir>
|
- <destDir>${project.build.directory}/xref</destDir>
|
||||||
- <javadocDir>${project.build.directory}/api</javadocDir>
|
- <javadocDir>${project.build.directory}/api</javadocDir>
|
||||||
- <stylesheet>${basedir}/src/xref/stylesheet.css</stylesheet>
|
- <stylesheet>${basedir}/src/xref/stylesheet.css</stylesheet>
|
||||||
- <docTitle>${project.name} Source Xref (${project.version}, r${buildNumber})</docTitle>
|
- <docTitle>${project.name} Source Xref (${project.version})</docTitle>
|
||||||
- <windowTitle>${project.name} Source Xref (${project.version}, r${buildNumber})</windowTitle>
|
- <windowTitle>${project.name} Source Xref (${project.version})</windowTitle>
|
||||||
- </configuration>
|
- </configuration>
|
||||||
- </plugin>
|
- </plugin>
|
||||||
- <plugin>
|
- <plugin>
|
||||||
@ -165,8 +152,8 @@ index 806f05c..e61a552 100644
|
|||||||
- </plugin>
|
- </plugin>
|
||||||
- <plugin>
|
- <plugin>
|
||||||
<artifactId>maven-assembly-plugin</artifactId>
|
<artifactId>maven-assembly-plugin</artifactId>
|
||||||
<version>2.2-beta-5</version>
|
<version>2.2</version>
|
||||||
<executions>
|
<executions>
|
||||||
--
|
--
|
||||||
1.7.3.4
|
1.7.7.3
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
From 06b89af693f824af86a3103505bb7f93128c22a2 Mon Sep 17 00:00:00 2001
|
From 61b66b45737653da51cc25d2771a97c811525e0f Mon Sep 17 00:00:00 2001
|
||||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||||
Date: Thu, 13 Jan 2011 15:02:01 +0100
|
Date: Thu, 13 Jan 2011 15:02:01 +0100
|
||||||
Subject: [PATCH 3/3] Replace jboss logger with jdk logger
|
Subject: [PATCH 2/4] Replace jboss logger with jdk logger
|
||||||
|
|
||||||
---
|
---
|
||||||
.../microcontainer/NettyLoggerConfigurator.java | 4 ++--
|
.../microcontainer/NettyLoggerConfigurator.java | 4 ++--
|
||||||
@ -29,5 +29,5 @@ index 2ccc731..eca8a6a 100644
|
|||||||
}
|
}
|
||||||
}
|
}
|
||||||
--
|
--
|
||||||
1.7.3.4
|
1.7.7.3
|
||||||
|
|
@ -1,29 +1,17 @@
|
|||||||
From 12b26381c9c47432d63f941b2bf4877874e78c12 Mon Sep 17 00:00:00 2001
|
From 0312ee7b5802105ec60de51ef4aeb0797dec972c Mon Sep 17 00:00:00 2001
|
||||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||||
Date: Thu, 13 Jan 2011 14:59:07 +0100
|
Date: Mon, 5 Dec 2011 14:31:36 +0100
|
||||||
Subject: [PATCH 1/3] Remove parent and fix javadoc plugin config
|
Subject: [PATCH 3/4] Fix javadoc plugin configuration
|
||||||
|
|
||||||
---
|
---
|
||||||
pom.xml | 21 ---------------------
|
pom.xml | 16 ----------------
|
||||||
1 files changed, 0 insertions(+), 21 deletions(-)
|
1 files changed, 0 insertions(+), 16 deletions(-)
|
||||||
|
|
||||||
diff --git a/pom.xml b/pom.xml
|
diff --git a/pom.xml b/pom.xml
|
||||||
index fbece2d..806f05c 100644
|
index 77fb611..8615b36 100644
|
||||||
--- a/pom.xml
|
--- a/pom.xml
|
||||||
+++ b/pom.xml
|
+++ b/pom.xml
|
||||||
@@ -17,11 +17,6 @@
|
@@ -408,23 +408,9 @@
|
||||||
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
|
|
||||||
|
|
||||||
<modelVersion>4.0.0</modelVersion>
|
|
||||||
- <parent>
|
|
||||||
- <groupId>org.jboss</groupId>
|
|
||||||
- <artifactId>jboss-parent</artifactId>
|
|
||||||
- <version>5</version>
|
|
||||||
- </parent>
|
|
||||||
|
|
||||||
<groupId>org.jboss.netty</groupId>
|
|
||||||
<artifactId>netty</artifactId>
|
|
||||||
@@ -400,23 +395,9 @@
|
|
||||||
</execution>
|
</execution>
|
||||||
</executions>
|
</executions>
|
||||||
<configuration>
|
<configuration>
|
||||||
@ -47,7 +35,7 @@ index fbece2d..806f05c 100644
|
|||||||
<version>true</version>
|
<version>true</version>
|
||||||
<author>true</author>
|
<author>true</author>
|
||||||
<keywords>true</keywords>
|
<keywords>true</keywords>
|
||||||
@@ -438,8 +419,6 @@
|
@@ -446,8 +432,6 @@
|
||||||
-group "Reusable I/O event interceptors" ${project.groupId}.handler*
|
-group "Reusable I/O event interceptors" ${project.groupId}.handler*
|
||||||
-group "Miscellaneous" ${project.groupId}.logging*:${project.groupId}.util*
|
-group "Miscellaneous" ${project.groupId}.logging*:${project.groupId}.util*
|
||||||
|
|
||||||
@ -57,5 +45,5 @@ index fbece2d..806f05c 100644
|
|||||||
<encoding>UTF-8</encoding>
|
<encoding>UTF-8</encoding>
|
||||||
<locale>en_US</locale>
|
<locale>en_US</locale>
|
||||||
--
|
--
|
||||||
1.7.3.4
|
1.7.7.3
|
||||||
|
|
71
0004-Remove-antun-execution-for-removing-examples.patch
Normal file
71
0004-Remove-antun-execution-for-removing-examples.patch
Normal file
@ -0,0 +1,71 @@
|
|||||||
|
From e25559365fd6bd5ff6942351bc53ab0a5a61ef77 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||||
|
Date: Mon, 5 Dec 2011 15:52:27 +0100
|
||||||
|
Subject: [PATCH 4/4] Remove antun execution for removing examples
|
||||||
|
|
||||||
|
For some reason -sources.jar is not generated before so it
|
||||||
|
fails. Should investigate one of these days...
|
||||||
|
---
|
||||||
|
pom.xml | 46 ----------------------------------------------
|
||||||
|
1 files changed, 0 insertions(+), 46 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/pom.xml b/pom.xml
|
||||||
|
index 8615b36..443b4c8 100644
|
||||||
|
--- a/pom.xml
|
||||||
|
+++ b/pom.xml
|
||||||
|
@@ -324,52 +324,6 @@
|
||||||
|
</tasks>
|
||||||
|
</configuration>
|
||||||
|
</execution>
|
||||||
|
- <execution>
|
||||||
|
- <id>remove-examples</id>
|
||||||
|
- <phase>package</phase>
|
||||||
|
- <goals>
|
||||||
|
- <goal>run</goal>
|
||||||
|
- </goals>
|
||||||
|
- <configuration>
|
||||||
|
- <tasks>
|
||||||
|
- <taskdef resource="net/sf/antcontrib/antlib.xml" />
|
||||||
|
- <if>
|
||||||
|
- <or>
|
||||||
|
- <equals arg2="jar" arg1="${project.packaging}" />
|
||||||
|
- <equals arg2="bundle" arg1="${project.packaging}" />
|
||||||
|
- </or>
|
||||||
|
- <then>
|
||||||
|
- <move file="${project.build.directory}/${project.build.finalName}.jar" tofile="${project.build.directory}/${project.build.finalName}.orig.jar" />
|
||||||
|
- <zip destfile="${project.build.directory}/${project.build.finalName}.jar">
|
||||||
|
- <zipfileset filemode="644" src="${project.build.directory}/${project.build.finalName}.orig.jar" dirmode="755">
|
||||||
|
- <include name="META-INF/MANIFEST.MF" />
|
||||||
|
- </zipfileset>
|
||||||
|
- <zipfileset filemode="644" src="${project.build.directory}/${project.build.finalName}.orig.jar" dirmode="755">
|
||||||
|
- <exclude name="META-INF/MANIFEST.MF" />
|
||||||
|
- <exclude name="*/*/*/example/**" />
|
||||||
|
- </zipfileset>
|
||||||
|
- </zip>
|
||||||
|
- <delete file="${project.build.directory}/${project.build.finalName}.orig.jar" />
|
||||||
|
- <checksum file="${project.build.directory}/${project.build.finalName}.jar" algorithm="md5" forceoverwrite="yes" />
|
||||||
|
- <checksum file="${project.build.directory}/${project.build.finalName}.jar" algorithm="sha1" forceoverwrite="yes" />
|
||||||
|
- <move file="${project.build.directory}/${project.build.finalName}-sources.jar" tofile="${project.build.directory}/${project.build.finalName}-sources.orig.jar" />
|
||||||
|
- <zip destfile="${project.build.directory}/${project.build.finalName}-sources.jar">
|
||||||
|
- <zipfileset filemode="644" src="${project.build.directory}/${project.build.finalName}-sources.orig.jar" dirmode="755">
|
||||||
|
- <include name="META-INF/MANIFEST.MF" />
|
||||||
|
- </zipfileset>
|
||||||
|
- <zipfileset filemode="644" src="${project.build.directory}/${project.build.finalName}-sources.orig.jar" dirmode="755">
|
||||||
|
- <exclude name="META-INF/MANIFEST.MF" />
|
||||||
|
- <exclude name="*/*/*/example/**" />
|
||||||
|
- </zipfileset>
|
||||||
|
- </zip>
|
||||||
|
- <delete file="${project.build.directory}/${project.build.finalName}-sources.orig.jar" />
|
||||||
|
- <checksum file="${project.build.directory}/${project.build.finalName}-sources.jar" algorithm="md5" forceoverwrite="yes" />
|
||||||
|
- <checksum file="${project.build.directory}/${project.build.finalName}-sources.jar" algorithm="sha1" forceoverwrite="yes" />
|
||||||
|
- </then>
|
||||||
|
- </if>
|
||||||
|
- </tasks>
|
||||||
|
- </configuration>
|
||||||
|
- </execution>
|
||||||
|
</executions>
|
||||||
|
<dependencies>
|
||||||
|
<dependency>
|
||||||
|
--
|
||||||
|
1.7.7.3
|
||||||
|
|
26
netty.spec
26
netty.spec
@ -1,6 +1,6 @@
|
|||||||
Name: netty
|
Name: netty
|
||||||
Version: 3.2.3
|
Version: 3.2.4
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: An asynchronous event-driven network application framework and tools for Java
|
Summary: An asynchronous event-driven network application framework and tools for Java
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -8,9 +8,10 @@ License: ASL 2.0
|
|||||||
URL: http://www.jboss.org/netty
|
URL: http://www.jboss.org/netty
|
||||||
Source0: http://sourceforge.net/projects/jboss/files/%{name}-%{version}.Final-dist.tar.bz2
|
Source0: http://sourceforge.net/projects/jboss/files/%{name}-%{version}.Final-dist.tar.bz2
|
||||||
|
|
||||||
Patch0: 0001-Remove-parent-and-fix-javadoc-plugin-config.patch
|
Patch0: 0001-Remove-optional-deps.patch
|
||||||
Patch1: 0002-Remove-optional-deps.patch
|
Patch1: 0002-Replace-jboss-logger-with-jdk-logger.patch
|
||||||
Patch2: 0003-Replace-jboss-logger-with-jdk-logger.patch
|
Patch2: 0003-Fix-javadoc-plugin-configuration.patch
|
||||||
|
Patch3: 0004-Remove-antun-execution-for-removing-examples.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
@ -31,11 +32,10 @@ BuildRequires: ant-contrib
|
|||||||
BuildRequires: subversion
|
BuildRequires: subversion
|
||||||
BuildRequires: protobuf-java
|
BuildRequires: protobuf-java
|
||||||
BuildRequires: felix-osgi-compendium
|
BuildRequires: felix-osgi-compendium
|
||||||
|
BuildRequires: jboss-parent
|
||||||
|
|
||||||
Requires: java
|
Requires: java
|
||||||
Requires: protobuf-java
|
Requires: protobuf-java
|
||||||
Requires(post): jpackage-utils
|
|
||||||
Requires(postun): jpackage-utils
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Netty is a NIO client server framework which enables quick and easy
|
Netty is a NIO client server framework which enables quick and easy
|
||||||
@ -66,6 +66,9 @@ Requires: jpackage-utils
|
|||||||
# just to be sure, but not used anyway
|
# just to be sure, but not used anyway
|
||||||
rm -rf jar/
|
rm -rf jar/
|
||||||
|
|
||||||
|
# example doesn't build with our protobuf
|
||||||
|
rm -rf src/main/java/org/jboss/netty/example/localtime
|
||||||
|
|
||||||
|
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
@ -73,11 +76,11 @@ rm -rf jar/
|
|||||||
# we don't have jboss logging facilites so we replace it with jdk logger
|
# we don't have jboss logging facilites so we replace it with jdk logger
|
||||||
rm src/main/java/org/jboss/netty/logging/JBossLogger*.java
|
rm src/main/java/org/jboss/netty/logging/JBossLogger*.java
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# skipping tests because we don't have all dependencies in Fedora
|
# skipping tests because we don't have all dependencies in Fedora
|
||||||
mvn-rpmbuild \
|
mvn-rpmbuild -Dmaven.test.skip=true \
|
||||||
-Dmaven.test.skip=true \
|
|
||||||
install javadoc:javadoc
|
install javadoc:javadoc
|
||||||
|
|
||||||
|
|
||||||
@ -98,7 +101,7 @@ install -pm 644 pom.xml $RPM_BUILD_ROOT/%{_mavenpomdir}/JPP-%{name}.pom
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%doc LICENSE.txt NOTICE.txt
|
%doc LICENSE.txt NOTICE.txt
|
||||||
%{_javadir}/*.jar
|
%{_javadir}/%{name}.jar
|
||||||
%{_mavendepmapfragdir}/%{name}
|
%{_mavendepmapfragdir}/%{name}
|
||||||
%{_mavenpomdir}/JPP-%{name}.pom
|
%{_mavenpomdir}/JPP-%{name}.pom
|
||||||
|
|
||||||
@ -107,6 +110,9 @@ install -pm 644 pom.xml $RPM_BUILD_ROOT/%{_mavenpomdir}/JPP-%{name}.pom
|
|||||||
%{_javadocdir}/%{name}
|
%{_javadocdir}/%{name}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 5 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 3.2.4-1
|
||||||
|
- Update to latest upstream version
|
||||||
|
|
||||||
* Mon Jul 4 2011 Alexander Kurtakov <akurtako@redhat.com> 3.2.3-4
|
* Mon Jul 4 2011 Alexander Kurtakov <akurtako@redhat.com> 3.2.3-4
|
||||||
- Fix FTBFS.
|
- Fix FTBFS.
|
||||||
- Adapt to current guidelines.
|
- Adapt to current guidelines.
|
||||||
|
Loading…
x
Reference in New Issue
Block a user