99 lines
2.9 KiB
Diff
99 lines
2.9 KiB
Diff
--- sys/unix/Makefile.src.orig 2005-06-23 14:57:08.000000000 -0400
|
|
+++ sys/unix/Makefile.src 2005-06-23 15:03:21.000000000 -0400
|
|
@@ -124,8 +124,8 @@
|
|
|
|
# flags for Linux
|
|
# compile normally
|
|
-# CFLAGS = -O2 -fomit-frame-pointer -I../include
|
|
-# LFLAGS = -L/usr/X11R6/lib
|
|
+CFLAGS = $(RPM_OPT_FLAGS) -I../include
|
|
+LFLAGS = -L/usr/X11R6/lib
|
|
# OR compile backwards compatible a.out format
|
|
# CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
|
|
# LFLAGS = -b i486-linuxaout -L/usr/X11R6/lib
|
|
@@ -151,8 +151,8 @@
|
|
# flags for debugging:
|
|
# CFLAGS = -g -I../include
|
|
|
|
-CFLAGS = -O -I../include
|
|
-LFLAGS =
|
|
+#CFLAGS = -O -I../include
|
|
+#LFLAGS =
|
|
|
|
# The Qt and Be window systems are written in C++, while the rest of
|
|
# NetHack is standard C. If using Qt, uncomment the LINK line here to get
|
|
@@ -230,8 +230,8 @@
|
|
# WINTTYLIB = -ltermcap
|
|
# WINTTYLIB = -lcurses
|
|
# WINTTYLIB = -lcurses16
|
|
-# WINTTYLIB = -lncurses
|
|
-WINTTYLIB = -ltermlib
|
|
+WINTTYLIB = -lncurses
|
|
+#WINTTYLIB = -ltermlib
|
|
#
|
|
# libraries for X11
|
|
# If USE_XPM is defined in config.h, you will also need -lXpm here.
|
|
--- sys/unix/Makefile.utl.orig 2005-06-24 19:48:16.000000000 -0400
|
|
+++ sys/unix/Makefile.utl 2005-06-24 19:49:07.000000000 -0400
|
|
@@ -15,7 +15,7 @@
|
|
|
|
# if you are using gcc as your compiler,
|
|
# uncomment the CC definition below if it's not in your environment
|
|
-# CC = gcc
|
|
+CC = gcc
|
|
#
|
|
# For Bull DPX/2 systems at B.O.S. 2.0 or higher use the following:
|
|
#
|
|
@@ -72,8 +72,8 @@
|
|
|
|
# flags for Linux
|
|
# compile normally
|
|
-# CFLAGS = -O2 -fomit-frame-pointer -I../include
|
|
-# LFLAGS = -L/usr/X11R6/lib
|
|
+CFLAGS = $(RPM_OPT_FLAGS) -I../include
|
|
+LFLAGS = -L/usr/X11R6/lib
|
|
# OR compile backwards compatible a.out format
|
|
# CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
|
|
# LFLAGS = -b i486-linuxaout -L/usr/X11R6/lib
|
|
@@ -89,8 +89,8 @@
|
|
# flags for debugging:
|
|
# CFLAGS = -g -I../include
|
|
|
|
-CFLAGS = -O -I../include
|
|
-LFLAGS =
|
|
+#CFLAGS = -O -I../include
|
|
+#LFLAGS =
|
|
|
|
LIBS =
|
|
|
|
@@ -101,11 +101,11 @@
|
|
|
|
# yacc/lex programs to use to generate *_comp.h, *_lex.c, and *_yacc.c.
|
|
# if, instead of yacc/lex you have bison/flex, comment/uncomment the following.
|
|
-YACC = yacc
|
|
-LEX = lex
|
|
-# YACC = bison -y
|
|
+#YACC = yacc
|
|
+#LEX = lex
|
|
+YACC = bison -y
|
|
# YACC = byacc
|
|
-# LEX = flex
|
|
+LEX = flex
|
|
|
|
# these are the names of the output files from YACC/LEX. Under MS-DOS
|
|
# and similar systems, they may differ
|
|
--- sys/unix/Makefile.doc.orig 2005-08-14 00:07:23.000000000 -0400
|
|
+++ sys/unix/Makefile.doc 2005-08-14 00:07:31.000000000 -0400
|
|
@@ -59,10 +59,7 @@
|
|
|
|
manpages:
|
|
-$(GAMEMANCREATE) $(MANDIR)/$(GAME).$(MANEXT)
|
|
- -$(LEVMANCREATE) $(MANDIR)/lev_comp.$(MANEXT)
|
|
- -$(DGNMANCREATE) $(MANDIR)/dgn_comp.$(MANEXT)
|
|
- -$(RCVRMANCREATE) $(MANDIR)/recover.$(MANEXT)
|
|
- -$(DLBMANCREATE) $(MANDIR)/dlb.$(MANEXT)
|
|
+ -$(RCVRMANCREATE) $(MANDIR)/nethack-recover.$(MANEXT)
|
|
|
|
# manual creation for distribution
|
|
DISTRIB = Guidebook.txt nethack.txt lev_comp.txt dgn_comp.txt recover.txt dlb.txt
|