102 lines
3.3 KiB
Diff
102 lines
3.3 KiB
Diff
--- sys/unix/Makefile.src.orig 2016-10-02 19:07:41.996506529 -0500
|
|
+++ sys/unix/Makefile.src 2016-10-02 19:12:05.083455291 -0500
|
|
@@ -64,7 +64,7 @@
|
|
# if you get setcgtty() warnings during execution, you are feeding gcc
|
|
# a non-ANSI <sys/ioctl.h> -- either run fixincludes on it or use
|
|
# -traditional in CFLAGS
|
|
-# CC = gcc
|
|
+CC = gcc
|
|
#
|
|
# For Bull DPX/2 systems at B.O.S. 2.0 or higher use the following:
|
|
#
|
|
@@ -128,7 +128,7 @@
|
|
# flags for Linux
|
|
# compile normally
|
|
# CFLAGS = -O2 -fomit-frame-pointer -I../include
|
|
-# LFLAGS = -L/usr/X11R6/lib
|
|
+LFLAGS = -L/usr/X11R6/lib
|
|
# OR compile backwards compatible a.out format
|
|
# CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
|
|
# LFLAGS = -b i486-linuxaout -L/usr/X11R6/lib
|
|
@@ -222,8 +222,8 @@
|
|
|
|
#
|
|
#
|
|
-#WINSRC = $(WINTTYSRC)
|
|
-#WINOBJ = $(WINTTYOBJ)
|
|
+WINSRC = $(WINTTYSRC) $(WINX11SRC)
|
|
+WINOBJ = $(WINTTYOBJ) $(WINX11OBJ)
|
|
|
|
# on some systems the termcap library is in -ltermcap or -lcurses
|
|
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
|
|
@@ -238,12 +238,12 @@
|
|
# WINTTYLIB = -ltermcap
|
|
# WINTTYLIB = -lcurses
|
|
# WINTTYLIB = -lcurses16
|
|
-# WINTTYLIB = -lncurses
|
|
+WINTTYLIB = -lncurses
|
|
#WINTTYLIB = -ltermlib
|
|
#
|
|
# libraries for X11
|
|
# If USE_XPM is defined in config.h, you will also need -lXpm here.
|
|
-WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
|
|
+WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11
|
|
# WINX11LIB = -lXaw -lXmu -lXt -lX11
|
|
# WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
|
|
# WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
|
|
@@ -263,7 +263,7 @@
|
|
# libraries for BeOS
|
|
WINBELIB = -lbe
|
|
|
|
-#WINLIB = $(WINTTYLIB)
|
|
+WINLIB = $(WINTTYLIB) $(WINX11LIB)
|
|
|
|
# any other strange libraries your system needs (for Sysunix only -- the more
|
|
# specialized targets should already be right)
|
|
--- sys/unix/Makefile.utl.orig 2016-10-02 20:22:37.262531451 -0500
|
|
+++ sys/unix/Makefile.utl 2016-10-02 19:13:15.878978496 -0500
|
|
@@ -18,7 +18,7 @@
|
|
|
|
# if you are using gcc as your compiler,
|
|
# uncomment the CC definition below if it's not in your environment
|
|
-# CC = gcc
|
|
+CC = gcc
|
|
#
|
|
# For Bull DPX/2 systems at B.O.S. 2.0 or higher use the following:
|
|
#
|
|
@@ -76,7 +76,7 @@
|
|
# flags for Linux
|
|
# compile normally
|
|
# CFLAGS = -O2 -fomit-frame-pointer -I../include
|
|
-# LFLAGS = -L/usr/X11R6/lib
|
|
+LFLAGS = -L/usr/X11R6/lib
|
|
# OR compile backwards compatible a.out format
|
|
# CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
|
|
# LFLAGS = -b i486-linuxaout -L/usr/X11R6/lib
|
|
@@ -104,11 +104,11 @@
|
|
|
|
# yacc/lex programs to use to generate *_comp.h, *_lex.c, and *_yacc.c.
|
|
# if, instead of yacc/lex you have bison/flex, comment/uncomment the following.
|
|
-YACC = yacc
|
|
-LEX = lex
|
|
-# YACC = bison -y
|
|
+#YACC = yacc
|
|
+#LEX = lex
|
|
+YACC = bison -y
|
|
# YACC = byacc
|
|
-# LEX = flex
|
|
+LEX = flex
|
|
|
|
# these are the names of the output files from YACC/LEX. Under MS-DOS
|
|
# and similar systems, they may differ
|
|
--- sys/unix/Makefile.top.orig 2016-10-02 19:08:10.317717433 -0500
|
|
+++ sys/unix/Makefile.top 2016-10-02 20:37:08.558986445 -0500
|
|
@@ -47,6 +47,7 @@
|
|
# per discussion in Install.X11 and Install.Qt
|
|
#VARDATND =
|
|
# VARDATND = x11tiles NetHack.ad pet_mark.xbm pilemark.xpm
|
|
+VARDATND = x11tiles NetHack.ad pet_mark.xbm rip.xpm
|
|
# VARDATND = x11tiles NetHack.ad pet_mark.xbm pilemark.xpm rip.xpm
|
|
# for Atari/Gem
|
|
# VARDATND = nh16.img title.img GEM_RSC.RSC rip.img
|